Solved

Veeam Monitor 5 Never finishes retrieving performance data

Posted on 2011-02-15
8
2,122 Views
Last Modified: 2012-08-14
I have installed a trial of the Veeam Monitor for VMware version 5 on a Windows 2008 R2 vm that is running at my main site; and added two vCenter Servers to it. One of the servers (at a remote DR site) manages a small infrastructure of a single ESX 4.1 host, one datacenter, one cluster, and 27 virtual machines. It is connected to my main site via an IPSec VPN PIX to ASA with about a 50 Mbit bandwidth of which much is consumed by Oracle RAC Dataguard replication. This site works fine and seems to be updating properly.

At the main site, that is all interconnected via Gigabit Ethernet, the Veeam Monitor seems to never finish retrieving performance data. This site consists of a mixture of nine ESX and ESXi 4.1 hosts, two datacenters, three clusters, and 155 virtual machines. I have even gone so far as to make a DRS rule that keeps the Veeam Monitor and vCenter server together on the same host, and thus the same vSwitch.

Both vCenter Servers are running on Windows 2008 R2, at the main site vCenter is on a vm and at the DR site on a physical box. I have tried numerous times to restart the services on the vCenter and restart the Veeam Collector service.

Looking for ideas
0
Comment
Question by:bgoering
8 Comments
 
LVL 16

Expert Comment

by:danm66
ID: 34933821
I'm not familiar with their monitoring tool, but have you checked out the Veeam logs?

I think they are in C:\Documents and Settings\All Users\Application Data\Veeam\Veeam Monitor for VMware

Or maybe you can get to them from Veeam monitor Server Settings, go the Logs tab, selected the "open logs folder" button


0
 
LVL 28

Author Comment

by:bgoering
ID: 34952259
Sorry for the delay getting back (I didn't notice a comment was added!) I do see errors "Collecting thread will exit due to serious error (The underlying connection was closed: An unexpected error occurred on a send.)" frequently in the VeeamDCS log. That is what initially caused me to lock both the vm hosting vCenter and the vm hosting Veeam Monitor onto the same host and vswitch - to try to eliminate any network issues.

So far I have been contacted by the Veeam sales guy and I explained the problem - he recommends I talk to support because support is offered for the trial. Haven't had time to do that yet but will likely open a ticket with them sometime this week.
0
 
LVL 16

Expert Comment

by:danm66
ID: 34953193
did you see this forum listing?  http://www.veeam.com/forums/viewtopic.php?f=5&t=5652
0
 
LVL 28

Author Comment

by:bgoering
ID: 34953391
I hadn't seen that particular post, but it doesn't appear to be especially relevant. That post described failing to add a standalone host to the monitor and could not complete the add. In my case I have added the vCenter server to the cluster and that completed fine. I can see certain things like storage utilization and alarms, but it never gets the the import done for historical data on cpu and memory information, and thus never gives me those counters.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 2

Expert Comment

by:phantom024
ID: 35124794
We had similar difficulties with Veeam Monitor 5 but cant remember what we found in the logs.  What finally fixed our situation was to be sure that the monitor server trusted the certificates installed on the vcenter servers.  After importing those certificates into the certificate stores on the monitor server all worked well.
0
 
LVL 28

Author Comment

by:bgoering
ID: 35129307
Well - I did a fresh install of Veeam Monitor 5 and added the certificates for all of my vCenter and ESX(i) servers to the monitor machine. Still works with my remote vCenter, but can't seem to get the real time data for my local vCenter.

A log extract is attached.
VeeamMon5LogExtract.txt
0
 
LVL 1

Accepted Solution

by:
Occam earned 500 total points
ID: 35207063
There is a hot fix for this issue. Contact Veeam support and they will send it to you. It does not matter if you are a paying customer they will still give you some support.
0
 
LVL 28

Author Closing Comment

by:bgoering
ID: 35263615
I finally followed up with support and obtained the hotfix. It seems to be working fine now except that the trial period has run out and now I am using it as the "free" limited version. Thanks so much
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
vm server patching 4 107
Standalone converter (Shrinking process) 4 55
virtualization 6 64
vmware 5.5 1 39
In this article, I will show you HOW TO: Perform a Physical to Virtual (P2V) Conversion the easy way from a computer backup (image).
In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
With the power of JIRA, there's an unlimited number of ways you can customize it, use it and benefit from it. With that in mind, there's bound to be things that I wasn't able to cover in this course. With this summary we'll look at some places to go…

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now