Link to home
Start Free TrialLog in
Avatar of rvfowler2
rvfowler2Flag for United States of America

asked on

FM - Portal Filter Help

I've got this to work in another db, but not in this layout.  Filtering by County and Town work fine, but as soon as I add the more complex ones of filtering by Price or by BusinessType1, no records show when all global fields are empty (when all are supposed to show), and when you select a Price or BusinessType from their respective drop-down selection, nothing happens.

-Portal1.JPG
-Portal2.JPG
SOLUTION
Avatar of Will Loving
Will Loving
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of rvfowler2

ASKER

Will, thanks for the tip; makes it simple.  Alaska, yes, you taught me about indexing once before, but I had forgot it.  That cleaned up most problems, but I have one more that I've never seen.  About half of my records do not show any portal records, even though the count field shows the correct number.  Never seen this or heard of this one.  I even tried relating the table by only one of the four portal fields, cycling through each one and obtained the same result.  Half of the records show no portal rows.
-Portal1.JPG
As soon as I posted, went back and figured it out.  I had copied this portal from another layout and changed all the fields, but forgot to change the filter, which had the portal record not equal to the record of the main layout, so that the record one is on does not show as one of the portal rows.  But, of course, needed to change the table and field names.  Thanks.
Thanks.