Solved

Problem with Zend Optimiser

Posted on 2011-02-15
14
1,165 Views
Last Modified: 2012-05-11
I may be missing something obvious but i recently migrated a site to my new server and it requested that I install Zend optimiser which I did.

I also am running host headers on my web server and for my particular site i have temporarilly put up the PHP config file

www.supportonthespot.co.uk/info.php it seems to have Zend installed and working yet when you navigate to www.supportonthespot.co.uk it tells me that I require zend optimiser.

Can anybody assist please
0
Comment
Question by:Supportonthespot
  • 8
  • 6
14 Comments
 
LVL 4

Expert Comment

by:JayDiablo
ID: 34899039
I don't see that Zend Optimizer is installed based on the output of the PHP Info page you linked above.  Are you certain it's installed?

Perhaps basic install info is helpful?

http://forums.hostsearch.com/showthread.php?2296-How-to-install-Zend-optimizer-on-Windows

Did you restart your webserver?
0
 
LVL 4

Author Comment

by:Supportonthespot
ID: 34899298
Scrolling down slightly it says the following

This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
0
 
LVL 4

Expert Comment

by:JayDiablo
ID: 34899333
Yeah, Zend Engine isn't Zend Optimizer though:

http://en.wikipedia.org/wiki/Zend_Engine

Zend Engine is used in all PHP deployments these days, but Zend Optimizer needs to be installed separately.

http://www.zend.com/en/products/guard/downloads
0
 
LVL 4

Author Comment

by:Supportonthespot
ID: 34902208
Ah that makes sense. However I also have ran through the optimiser download and install 4 times to no avail. I have checked that there is no extra php.ini files I also have seen a line of code refering to the ZEND optimiser in the php.ini file.

PHP is running fine in itself and is a supported version.

However the optimiser does not show up in the PHP  info, im running 2008 server SP2 with IIS7

Its clear optimiser is not installed properly. I even ran it with elevated permisions just in case. still no change. im wondering why the php.ini file refers to it and in all the correct install locations just does not show in the phpinfo
0
 
LVL 4

Expert Comment

by:JayDiablo
ID: 34902315
You may want to double check that PHP is trying to load that php.ini and not some other one on the system:

http://www.iis-aid.com/articles/how_to_guides/where_php_ini_is_loaded_from

And just to confirm, you've restarted the webserver after installing Optimizer right?
0
 
LVL 4

Author Comment

by:Supportonthespot
ID: 34902591
Im going to attempt this again in the morning. I completely removed PHP and ZEND optimiser and downloaded the Zend Server Community edition and exactly the same thing happened.

However this has now broken my sites so ill have to check if there is any further configuration I need to do.

Not the quickest installation this has taken 2 days to figure out.

And ive restarted the entire machine not just the web server. If i check out the info.php on my default internal site it tells me that i do have zend optimiser engine then when i load my template it tells me its not installed. ill work on it with fresh eyes in the morning

thanks
0
 
LVL 4

Author Comment

by:Supportonthespot
ID: 34905584
Ok well I decided I would take a completely brand new system and install the ZEND comunity server with Apache and lo and behold exactly the same when trying to run my flashmoto template. However checking info.php showed all the necessary was installed so I checked my template and it appears it required PHP 5.2.14 and optimiser.

So i went back to the drawing board and installed IIS7 and PHP 5.2.14 and then optimiser which claimed it installed perfectly but info.php shows its not installed.

I simply chose all the defaults. location of my PHP file which was c:\php, I scanned for extra rogue php files and there is none on the system in any other location I also chose the location of my system root which was changed to c:\inetpub\wwwroot

Installation completes but nothing shows on info.php that optimiser is installed.

Im starting to think im going mad.
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 
LVL 4

Expert Comment

by:JayDiablo
ID: 34906830
Have you tried the 5.2 build of Zend Server CE?

http://www.zend.com/en/products/server-ce/downloads
0
 
LVL 4

Author Comment

by:Supportonthespot
ID: 34908809
Ok so i completely built a new VM with 2008 SP2 No IIS and the 5.2 Build of Zend Server CE.

Installed my flash moto template and it tells me Zend Optimiser is not installed www.supportonthespot.co.uk

take a look at /info.php and its running

This ones completely got me
0
 
LVL 4

Author Comment

by:Supportonthespot
ID: 34909019
Well im getting somewhere. If i navigate to www.supportonthespot.co.uk/moto.html there is my lovely site. So something in the wwwroot directory is giving me greif
0
 
LVL 4

Expert Comment

by:JayDiablo
ID: 34909038
Googling around some and it seems that it's a possibility that the Flashmoto Templates were encoded with an older version of Zend Guard that the newer version of Zend Optimizer can't decode properly.  Here's a thread with very similar situation:

http://www.easyphpcalendar.com/forums/showthread.php?t=10118

Perhaps a compatible build of the ionCube Loader would work, or try a version of PHP taht is compatible with Zend Optimizer 3.x?
0
 
LVL 4

Accepted Solution

by:
JayDiablo earned 500 total points
ID: 34909057
Looks like you've got it solved...   if I hit your domain now, I get your site.
0
 
LVL 4

Author Comment

by:Supportonthespot
ID: 34909076
yeah I renamed index.php to index.old and renamed moto.html to index.html and when you hit the site perfect. however when it comes to the /admin part which is how to configure your site it still gets the same.

But for this particular issue i think its the Flashmoto guys issue so thank you for your time.

0
 
LVL 4

Author Closing Comment

by:Supportonthespot
ID: 34909082
Thankyou for your help
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

MS Access 2003 or later To MySQL Migration Project Hello All, this is my second article in the category of MS-OFFICE Automation. In internet I am not able to find any comprehensive resource on the Migration of MS Access back-end to MySQL so I fin…
The new Microsoft OS looks great, is easier than ever to upgrade to, it is even free.  So what's the catch?  If you don't change the privacy settings, Microsoft will, in accordance with the (EULA) you clicked okay to without reading, collect all the…
The viewer will learn how to use the =DISCRINV command to create a discrete random variable, use this command to model a set of probabilities and outcomes in a Monte Carlo simulation, and learn how to find the standard deviation of a set of probabil…
The viewer will learn how to use a discrete random variable to simulate the return on an investment over a period of years, create a Monte Carlo simulation using the discrete random variable, and create a graph to represent the possible returns over…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now