Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

VPN issue when connecting to work network

Posted on 2011-02-15
10
Medium Priority
?
414 Views
Last Modified: 2012-06-27
Hi,

I created a VPN connection to my work (successfully). After I did this, I cannot see any of the remote directories from my work server (nothing shows up in control panel, or networking -- anywhere). Additionally, I am unable to use the internet. When I disconnect from the VPN, everything is back to normal.

I am not sure what other relevant info I can give, please let me know. I would like to connect to my work through VPN and use the files there.

I have Windows 7 and Avast antivirus.

Thank you very much in advance!

Andrey
0
Comment
Question by:andreyman3d2k
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
10 Comments
 
LVL 34

Expert Comment

by:Paul MacDonald
ID: 34897158
Are you assigning DNS servers and a default gateway to your VPN users?
0
 
LVL 6

Author Comment

by:andreyman3d2k
ID: 34897197
I am the user. I am trying to connect to my work -- I am not sure what settings the IT at work has. I know I connected successfully (It accepted my username/pass, and the VPN shows up in my networks list) -- but then I get the problems I mentioned.

Andrey
0
 
LVL 34

Expert Comment

by:Paul MacDonald
ID: 34897209
I see.  Well the problem is likely on the other end.  In either case, your IT department can probably help you (and should be notified anyway in case this is an ongoing problem for other users).
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
LVL 6

Author Comment

by:andreyman3d2k
ID: 34897248
My IT department is 1 person, and we hardly ever use VPN. He has no idea.

Here's a clue: In my Avast, when I have the VPN disconnected, it says "currently connected to: Roadrunner blah blah (i.e. my home network). When I turn on the VPN it says connected to: the VPN. I think it's setting the VPN as some default.. is this possible? Any other ideas?
0
 
LVL 34

Expert Comment

by:Paul MacDonald
ID: 34897333
Not necessarily.  There IS a setting in the TCP/IP properties (under the Advanced settings) that tells the system to use the default gateway on the remote network.  This would stop your Internet connection from working properly if the VPN were misconfigured.  You can clear this checkbox, but it won't really fix the problem you're experiencing.  

If you know the IP addresses of the DNS servers and default gateway on the network you're connecting to, you can plug those in to the TCP/IP properties and you may see the problem resolved.  The caveat is, your IT person may be omitting those items for a reason.
0
 
LVL 6

Author Comment

by:andreyman3d2k
ID: 34897531
I am not sure what any of that means - a bit over my head. Again, the problem is not the VPN connection -- that works. The problem is that when I connect to the VPN my internet stop working. It's as if it replaces my normal connection with the VPN.
0
 
LVL 34

Accepted Solution

by:
Paul MacDonald earned 1800 total points
ID: 34897641
Your "Internet stops working" because all the data is going over the VPN and from there it doesn't know where to go.

This information will NOT harm your computer, but will change the way your VPN works and may violate your company's remote access policy (if it has one).  Fair warning:
Go to START -> CONNECT TO, then right-click on the VPN connection and select Properties you'll get the properties dialog for your VPN connection.  
On the Networking tab, you'll see an item for Internet Protocol Version 4.  Select it and click the Properties button.
On this tab, you'll see where you can specify the DNS servers to use on the remote network (which I mentioned above).  Generally, these items are all assigned by the VPN server (which is configured by your IT department).  I would avoid changing anything on this page right now.  What you want is to push the Advanced button at the bottom.
That brings up the Advanced TCP/IP Settings dialog.  On the IP Settings tab, uncheck the "Use default gateway on remote network" checkbox.  Your "Internet" will now work while you're connected to the VPN.  

This change will not fix the other items you're having trouble with (getting to your work server).  Those items will almost certainly require your IT person's intervention.
0
 
LVL 11

Assisted Solution

by:sysreq2000
sysreq2000 earned 200 total points
ID: 34897940
Do what Paulmacd suggests above, then if you still can't connect to your servers, find out from your IT person what the server IP addresses are, then add them to your hosts file:

winsows\system32\drivers\etc\hosts

It is just a text file that includes a sample of how to enter the server name and IP address. save the file making sure there is no extension, it has to be called just hosts. That should fix your problem. If not then I agree with Paulmacd and your IT person needs to do some troubleshooting for you.
0
 
LVL 11

Expert Comment

by:sysreq2000
ID: 34897953
sorry that should of course be windows not winsows  ;)
0
 
LVL 6

Author Comment

by:andreyman3d2k
ID: 34911170
Paulmacd, thanks -- that indeed solved the internet not working issue. I stop pursuing the matter further, will ask IT guy about it. Thanks a ton.

Andrey
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Originally, this post was published on Monitis Blog, you can check it here . It goes without saying that technology has transformed society and the very nature of how we live, work, and communicate in ways that would’ve been incomprehensible 5 ye…
During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Suggested Courses

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question