Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Digium TE122 E1 and Asterisk in Guatemala with Claro always in RED alarm

Posted on 2011-02-15
13
Medium Priority
?
2,127 Views
Last Modified: 2012-08-13
Hello, I've got this problem and maybe somebody has had the same, here are the details:
Asterisk =1.6.0.26
E1 card= Digium TE122PF
Dahdi Version =2.4.0
Country= Guatemala
Provider= Claro

E1 Settings given by claro:
cable= straight (we tested a crossover as well just in case)
Framing/Coding= CCS/hdb3 and CRC4 (claro says they need CRC4)
PRI_CPE on our side
Clock/Sync on their side (1)
Euro ISDN


So far all we've gotten is RED alarm, never a green alarm.

we've tried:
1- using straight and crossover (1-4 and 2-5) cables (provider says it should be straight)
2- card is good since we switched to a new one and still the same
3- provider (Claro) tests the connection and with their testers it works fine
4- changing framing to non crc4, clock in 0 or 1, isdn2 (just in case) and nothing still
RED alarm
5- we put the loopback with a straight cable and alarm goes green (OK)

Please, if anybody has had any experience with E1s in Guatemala (claro) let me know if you can.

thank you
0
Comment
Question by:darwin_roach
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 2
  • 2
13 Comments
 
LVL 2

Expert Comment

by:joshopkins
ID: 34899087
The cable should be a T1/E1 roll over cable.  We had the same issue and that fixed it for us.
0
 

Author Comment

by:darwin_roach
ID: 34900013
what type of cable is that please?
0
 

Author Comment

by:darwin_roach
ID: 34900062
I just saw it on a web page, it means pin 12345678 should go in the opposite direction on the other end, right? so on one side the order of the cables would be 12345678 and the other side would be 87654321, is that right?
0
Moving data to the cloud? Find out if you’re ready

Before moving to the cloud, it is important to carefully define your db needs, plan for the migration & understand prod. environment. This wp explains how to define what you need from a cloud provider, plan for the migration & what putting a cloud solution into practice entails.

 
LVL 2

Expert Comment

by:joshopkins
ID: 34900319
0
 

Author Comment

by:darwin_roach
ID: 34900362
thank you, I'll give it a try later today after I make the cable.
0
 

Author Comment

by:darwin_roach
ID: 34901530
I just installed the roll over cable and unfortunately it did not help, the alarm is still in RED, the device the carrier uses is a RAD, model: asmi-52l/e1/2w


any other ideas?
0
 

Author Comment

by:darwin_roach
ID: 34902094
I found something in the manual of the device recommending to use only 4 wire connector, right now we're using an 8 wire connector/cable, so we will try that tomorrow.

0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 34906029
Hi

make sure from your provider side by using a loopback on the RAD unit and let your provider check if it's looped or not,,
plus, use pins 12,45 and check ??
send more details about your:
/etc/asterisk/dahdi-channels.conf  and  /etc/dahdi/system.conf
0
 

Author Comment

by:darwin_roach
ID: 34906698
Actually I put Digium to work on this case and they say the card and configuration is OK, that the problem should be on the carrier's side or the connections, so I took a look at this device's manual and found that in appendix A about the pinouts they mention that if you have a E1/T1 connection you should use 4 wire cables only, because it seems that if you use a cable with all 8 wires then the RAD tries to use pin 7 for CPU ID and pin 8 for ground. I was using 8 wire cables all the time, so what I'll do today is try with a 4 wire cable only and see how this develops, hope this solves the issue, because it is driving me crazy.
I'll post the config files later if this solution doesn't help.

thank you.
0
 

Author Comment

by:darwin_roach
ID: 34907529
I just tested with both 4 wire cables, crossed over and straight thru, none of them solved the issue, here are my system.conf and dahdi-channels.conf, maybe you can see something I did not...

span = 1,1,0,ccs,hdb3,crc4
bchan = 1-15,17-31
loadzone = us
defaultzone = us



group=2
context=from-pstn
switchtype = euroisdn
signalling = pri_cpe
channel => 1-15,17-31
context = default
group = 63


thank you.
0
 
LVL 16

Expert Comment

by:memo_tnt
ID: 34913715
add this "dchan=16" to your system.conf

span = 1,1,0,ccs,hdb3,crc4
bchan = 1-15,17-31
dchan=16
loadzone = us
defaultzone = us


0
 

Accepted Solution

by:
darwin_roach earned 0 total points
ID: 34914558
Hello, thanks for the help, what we did yesterday was to call the carrier again for a checkup on the e1, they tested and effectively there was  a problem with the connection, it took them like 2 hours to solve the issue, once they did, the E1 was in OK alarm and it started working!.
thanks for the help.

for the record, these are the settings to work with Claro in Guatemala with Digum  TE122PF cards in a E1 enviroment:

System.conf

span = 1,1,0,ccs,hdb3,crc4
bchan = 1-15,17-31
dchan=16
loadzone = us
defaultzone = us

dahdi-channels.conf

switchtype = euroisdn
signalling = pri_cpe
channel => 1-15,17-31

Cable must be straight through (not cross over nor roll-over) and can be 8 wire cable  even if you're using the RAD model asmi-52l/e1/2w

thanks all for the help anyway.
0
 

Author Closing Comment

by:darwin_roach
ID: 34949635
I found the solution.
thanks
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hey there Heard about jingle, the add on for XMPP that enables point to point audio between two XMPP clients. No server config necessary. Actually quite a cool feature. However, how good is it if you can not use those voice capabilities to do a P…
Messaging apps are amazing tools with the power to do a lot of good, but the truth is the process of collaborating with coworkers requires relationships established through meaningful communication - the kind of communication that only happens face-…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question