Digium TE122 E1 and Asterisk in Guatemala with Claro always in RED alarm

Hello, I've got this problem and maybe somebody has had the same, here are the details:
Asterisk =1.6.0.26
E1 card= Digium TE122PF
Dahdi Version =2.4.0
Country= Guatemala
Provider= Claro

E1 Settings given by claro:
cable= straight (we tested a crossover as well just in case)
Framing/Coding= CCS/hdb3 and CRC4 (claro says they need CRC4)
PRI_CPE on our side
Clock/Sync on their side (1)
Euro ISDN


So far all we've gotten is RED alarm, never a green alarm.

we've tried:
1- using straight and crossover (1-4 and 2-5) cables (provider says it should be straight)
2- card is good since we switched to a new one and still the same
3- provider (Claro) tests the connection and with their testers it works fine
4- changing framing to non crc4, clock in 0 or 1, isdn2 (just in case) and nothing still
RED alarm
5- we put the loopback with a straight cable and alarm goes green (OK)

Please, if anybody has had any experience with E1s in Guatemala (claro) let me know if you can.

thank you
darwin_roachAsked:
Who is Participating?
 
darwin_roachAuthor Commented:
Hello, thanks for the help, what we did yesterday was to call the carrier again for a checkup on the e1, they tested and effectively there was  a problem with the connection, it took them like 2 hours to solve the issue, once they did, the E1 was in OK alarm and it started working!.
thanks for the help.

for the record, these are the settings to work with Claro in Guatemala with Digum  TE122PF cards in a E1 enviroment:

System.conf

span = 1,1,0,ccs,hdb3,crc4
bchan = 1-15,17-31
dchan=16
loadzone = us
defaultzone = us

dahdi-channels.conf

switchtype = euroisdn
signalling = pri_cpe
channel => 1-15,17-31

Cable must be straight through (not cross over nor roll-over) and can be 8 wire cable  even if you're using the RAD model asmi-52l/e1/2w

thanks all for the help anyway.
0
 
joshopkinsCommented:
The cable should be a T1/E1 roll over cable.  We had the same issue and that fixed it for us.
0
 
darwin_roachAuthor Commented:
what type of cable is that please?
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
darwin_roachAuthor Commented:
I just saw it on a web page, it means pin 12345678 should go in the opposite direction on the other end, right? so on one side the order of the cables would be 12345678 and the other side would be 87654321, is that right?
0
 
joshopkinsCommented:
0
 
darwin_roachAuthor Commented:
thank you, I'll give it a try later today after I make the cable.
0
 
darwin_roachAuthor Commented:
I just installed the roll over cable and unfortunately it did not help, the alarm is still in RED, the device the carrier uses is a RAD, model: asmi-52l/e1/2w


any other ideas?
0
 
darwin_roachAuthor Commented:
I found something in the manual of the device recommending to use only 4 wire connector, right now we're using an 8 wire connector/cable, so we will try that tomorrow.

0
 
memo_tntCommented:
Hi

make sure from your provider side by using a loopback on the RAD unit and let your provider check if it's looped or not,,
plus, use pins 12,45 and check ??
send more details about your:
/etc/asterisk/dahdi-channels.conf  and  /etc/dahdi/system.conf
0
 
darwin_roachAuthor Commented:
Actually I put Digium to work on this case and they say the card and configuration is OK, that the problem should be on the carrier's side or the connections, so I took a look at this device's manual and found that in appendix A about the pinouts they mention that if you have a E1/T1 connection you should use 4 wire cables only, because it seems that if you use a cable with all 8 wires then the RAD tries to use pin 7 for CPU ID and pin 8 for ground. I was using 8 wire cables all the time, so what I'll do today is try with a 4 wire cable only and see how this develops, hope this solves the issue, because it is driving me crazy.
I'll post the config files later if this solution doesn't help.

thank you.
0
 
darwin_roachAuthor Commented:
I just tested with both 4 wire cables, crossed over and straight thru, none of them solved the issue, here are my system.conf and dahdi-channels.conf, maybe you can see something I did not...

span = 1,1,0,ccs,hdb3,crc4
bchan = 1-15,17-31
loadzone = us
defaultzone = us



group=2
context=from-pstn
switchtype = euroisdn
signalling = pri_cpe
channel => 1-15,17-31
context = default
group = 63


thank you.
0
 
memo_tntCommented:
add this "dchan=16" to your system.conf

span = 1,1,0,ccs,hdb3,crc4
bchan = 1-15,17-31
dchan=16
loadzone = us
defaultzone = us


0
 
darwin_roachAuthor Commented:
I found the solution.
thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.