[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 690
  • Last Modified:

Zend Studio Linux Fedora 14 LXDE JVM error

Hi Experts!

I've a Zend Studio in my Fedora 14 LXDE. I was download the Zend Studio 32 bits, 8 version, most recient. When I run the app, shows me:

Failed to load the JNI shared library "/home/javiermorquecho/Downloads/ZendStudio/jre/bin/../lib/i386/client/libjvm.so".

I installed JRE and JDK in my computer.

In the directory /jre/bin/ I need to change permissons?

Thnx!
0
javiermorquecho
Asked:
javiermorquecho
  • 8
  • 4
  • 2
  • +1
1 Solution
 
CEHJCommented:
>>
I installed JRE and JDK in my computer.

In the directory /jre/bin/
>>

Not good. $JAVA_HOME should be something like

/usr/java/someversion

I'd suggest an uninstall then reinstall
0
 
javiermorquechoAuthor Commented:
Excuse me. I've Zend Studio in a directory the directory jre/bin
0
 
CEHJCommented:
Try setting and exporting ${JAVA_HOME} before starting Zend
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
javiermorquechoAuthor Commented:
I was setting and exporting ${JAVA_HOME}, before starting Zend, but Zend shows the same error. I use "yum install java" and "yum installgroup java development" and the behavior is the same.

Another idea?

Thnx a lot! :)
0
 
objectsCommented:
Thats right, JAVA_HOME won't make a difference. Its got nothing to do with what you are doing.

Are you running it on 32 or 64 bit java?

> /home/javiermorquecho/Downloads/ZendStudio/jre/bin/../lib/i386/client/libjvm.so

does this file exist?
and do you have access rights to read it?
0
 
javiermorquechoAuthor Commented:
Yes, I'm using java 32 bits.

The file:

/home/javiermorquecho/Downloads/ZendStudio/jre/bin/../lib/i386/client/libjvm.so

exist. I've access rights to read it.

Thnx alot! :)
0
 
objectsCommented:
how are you starting it up?
0
 
javiermorquechoAuthor Commented:
I start the app executing the file:

/home/javiermorquecho/Downloads/ZendStudio/ZendStudio
0
 
objectsCommented:
run it with the  -console -debug options
0
 
javiermorquechoAuthor Commented:
Thnx. I ran the command:

[javiermorquecho@localhost ZendStudio]$ ./ZendStudio -console -debug options
Start VM: -Xms128M
-Xmx512M
-XX:MaxPermSize=256m
-Djava.class.path=/home/javiermorquecho/Downloads/ZendStudio/plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-os linux
-ws gtk
-arch x86
-showsplash
-launcher /home/javiermorquecho/Downloads/ZendStudio/ZendStudio
-name Zend Studio
--launcher.library /home/javiermorquecho/Downloads/ZendStudio/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.1.R36x_v20100810/eclipse_1309.so
-startup /home/javiermorquecho/Downloads/ZendStudio/plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
-showlocation
-console
-debug options
-vm /home/javiermorquecho/Downloads/ZendStudio/jre/bin/../lib/i386/client/libjvm.so
-vmargs
-Xms128M
-Xmx512M
-XX:MaxPermSize=256m
-Djava.class.path=/home/javiermorquecho/Downloads/ZendStudio/plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
/home/javiermorquecho/Downloads/ZendStudio/jre/bin/../lib/i386/client/libjvm.so: cannot enable executable stack as shared object requires: Permission denied
0
 
objectsCommented:
do you have execute permissions on that file?
0
 
javiermorquechoAuthor Commented:
yes
0
 
javiermorquechoAuthor Commented:
Hi!

I installed JVM of the sun page, I followed the linux instructions (http://java.com/en/download/help/linux_install.xml#selfextracting). In other sense, I download Zend Studio ver 7.2 (old version), and the behavior is the same.

I used "yum  install java"and "yum  install java development".

I think, I use too much options. :(

Thnx a lot!
0
 
javiermorquechoAuthor Commented:
I resolve the trouble. The solution is:


SELinux is preventing /home/javiermorquecho/Downloads/ZendStudio/ZendStudio from using the execstack access on a process.

Plugin: catchall
you want to allow ZendStudio to have execstack access on the Unknown processIf you believe that ZendStudio should be allowed execstack access on processes labeled unconfined_t by default.
You should report this as a bug.
You can generate a local policy module to allow this access.
Allow this access for now by executing:
# grep ZendStudio /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp


I'm sorry. Points to me! LOL

Thnx! :)
0
 
Kevin CrossChief Technology OfficerCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 8
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now