Solved

Browsers will not load web pages- any suggestions please

Posted on 2011-02-15
26
1,170 Views
Last Modified: 2012-05-11
Hi,
I'm really stuck and would appreciate any help- neither Firefox or IE8 will load any webpages.
System details

Laptop running W7 professional,broadband cable via a netgear prosafe firewall.
There is no proxy involved.


Network and Sharing Center shows connections as local area connection ,and access type as Internet.

Neither IE8 or Firefox 3.6.13 will load any web pages
it doesn't seem to matter what the url is eg www.microsoft.com, google.co.uk, bbc.co.uk etc

In Firefox- message in tab- loading, but nothing loads,
In IE8, - title bar shows IE cannot disply the webpage, at the bottom, waiting for http:// etc

Diagnose connection problems does not result in any problem found


DHCP is enabled and valid address allocated to the laptop

Ping works ok both to local machines and dns server
nslookup returns correct details
Traceroute returns valid hops + details

so it looks as though the network card + cable is working ok.

All addons have been disabled
I've reduced the security settings in IE8 for the internet to medium, I've also reset the browser
under advanced settings and rebooted both browser and laptop.
I've tried disabling protected mode


Norton Internet security 2011 normally runs, but turning off the firewall and the a/v for
a few minutes has not effect. Norton updates do not work as it cannot find an internet connection.


Back to the command prompt, and I've run ipconfig /release and renew, also flushdns


sfc /scannow did not find any integrity problems

My desktop - XP professional runs through the same Netgear firewall, also on DHCP , Norton IS 2011, IE8 and Firefox run fine
I can ping the laptop from the desktop.

I'm stumped, please can anyone advise as I need internet access tomorrow when travelling
Thanks
0
Comment
Question by:techtramp
  • 13
  • 6
  • 5
  • +1
26 Comments
 
LVL 33

Expert Comment

by:paulmacd
ID: 34900507
Make sure the browsers don't have a proxy defined.  Sometimes malware changes those settings to inhibit removal.
0
 
LVL 9

Expert Comment

by:discgman
ID: 34900638
Either maleware or your internet service provider/your hardware (router,switch,wap).

You can call your isp and they can check from their side if they can reach your router and if their are no known outages in the area. If all is good there then move on to scanning for maleware.

If all was working fine then all of the sudden you cannot surf, my first thought is maleware. Scan using malwarebytes at www.malwarebytes.org and see if anything pops up. Also make sure to reset all browsers to the default settings.

If you find malware and malwarebytes or other software fails to clean, you can use combofix.exe from bleepingcomputer.com and it will do a complete clean.
0
 

Author Comment

by:techtramp
ID: 34901433
Thank you both for a quick response.
I think the router is ok as my desktop can access the internet without problem,
On the laptop both ie8 and Firefox  are set to automatically detect settings- no proxy and have been reset to default
I've done a check with technet's autorun but can't see anything obvious to cause problems
Malwarebytes quick scan hasn't shown up anything, but  I've known in the past for the full scan to pick up problems- so am running that now. (not up to date definitions as laptop internet is not available

Outlook 2010 can't access the server either, but ping, tracert etc still function ok

I'm sure it must be something simple that I've changed in error, but goodness knows what it is.
0
 
LVL 33

Expert Comment

by:paulmacd
ID: 34901486
When you ping, are you pinging a DNS name or an IP address?  That is, does the laptop have valid DNS server information?  The machine can be configured for DHCP but have hardcoded DNS server information.
0
 
LVL 22

Expert Comment

by:optoma
ID: 34901518
Can you post a hijackthis log. Run it as admin. Another option would be to use system restore to go back to a recent date known to work browsing wise
0
 
LVL 9

Expert Comment

by:discgman
ID: 34901665
Also make sure the host file didnt get changed on the pc. Located under c:\windows\system32\drivers\etc\
0
 

Author Comment

by:techtramp
ID: 34902237
Thanks for suggestions
PIng is ok for both IP address and name- used for the isp dns serve ip addressr and also for  named- www.bbc.co.uk

Hosts file only has example text- nothing else specified
Malwarebytes full scan hasn't shown any infections and only has a data folder on a second drive to scan.
Have downloaded hijackthis on the desktop but unfortunately have to close down now ready for tomorrow- I'll try a system restore then and let you know what happens.
Thanks again
0
 
LVL 33

Expert Comment

by:paulmacd
ID: 34906553
Ping works so name resolution is okay.  That maybe leaves something blocking port 80 on the laptop.  Do you have a firewall installed (or are you using Windows Firewall)?  Can you connect to a web site you know uses SSL?  That is, can you get your browser to load a page that isn't on port 80?  

An alternative test would be to open a command prompt and telnet to a web site on port 80 to see if you can connect that way (telnet www.google.com 80) then type something and press enter to see what happens.
0
 

Author Comment

by:techtramp
ID: 34911492
Tried several restore points- thought I'd created more during Feb but had to go back to mid Jan before I could get  the web browser pages to load up, windows updates to get from the server, or Norton Liveupdate to work. I usually log when I install new programs, but can't see or remember anything apart from installing Acronis ATI2010 apart from various updates.(Had to restore from a couple of weeks before Acronis so wasn't that.

paulmacd- only firewall was Norton NIS 2011 and I disabled that + the A/V without effect. Didn't try a site using ssl, or avoid port 80- I'll have to do some reading up on that +telnet- ages since I've used it.

I'll take a full drive C backup and then do all the updates and see if the webpage loading error repeats again and report back.
0
 
LVL 22

Expert Comment

by:optoma
ID: 34911614
Cool :) see you soon .
0
 

Author Comment

by:techtramp
ID: 34924938
The plot thickens!
restored and then found web pages loaded ok, rebooted, and now they don't. Running out of restore points to go back to.

Out of interest, just went on line using  a usb Vodafone broadband dongle- found network, could ping ok, but no joy with browsers- so that seems to knock out a problem with the ISP or my prosafe firewall + configuration. Seems to point to config problem somewhere

Now to try and restore the c: drive backup and see if the web pages load.

0
 
LVL 22

Expert Comment

by:optoma
ID: 34925172
If it worked and then stopped , maybe an update installed for windows , av product ? After your next step, and all fails again , run Norton removal tool and test. Make sure you have subscription info for av first to reinstall !
0
 

Author Comment

by:techtramp
ID: 34939455
Hmm,
restored drive from backup and still can't load web pages.
tried to do a W7 repair from CD- couldn't restore all files to original location- goodness knows why
sfc /scannow doesn't show up anything
access to the laptop from the xo desktop machine is very.very slow through network neighbourhood
Neither Thunderbird or Outlook collect/send mail-( using imap/pop3/smtp settings)
on a previous attempt- telnet got some response back, tried just now and just just cursor top left, with single underscore down page  where I had pressed enter.
Just got to find my Norton key and then I'll try to uninstall NIS
looked in programs and features- added HTTP features / health + daignostics / and will see if that helps tomorrow

Managed to get a hijackthis log from the system restore that initially gave web page loading before then stopping. Would this be of help still at this stage?

0
Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 33

Expert Comment

by:paulmacd
ID: 34939953
A better question might be: Is this machine worth fighting for?  Would it be easier at this point to just re-install the OS?
0
 

Author Comment

by:techtramp
ID: 34942550
Must admit, it's getting that way. Only trouble is I don't like getting beaten as the same problem may happen again and I'd like to know the cause.
0
 

Author Comment

by:techtramp
ID: 34947434
last attempt and tried disabling startup /services from msconfig
deselected all startup and all services apart from some that looked relevant. No browser load pages, dim screen etc- not unexpected. Enabled all startup and browsers worked. At the moment, enabling additional services by alphabet, i.e. a- c, currently up to K and browsers still loading web pages ,  NIS 2011 has allowed liveupdate to work- not risking m/s updates as yet.
I'll report back when I complete all the services re-enabled unless I find the one that's blocking the browser operations.
0
 
LVL 33

Expert Comment

by:paulmacd
ID: 34951533
Best of luck!
0
 

Accepted Solution

by:
techtramp earned 0 total points
ID: 34983659
End of the story- hope some things I tried may help others-

After enabling all MS services had tried enabling other services two or three at a time and thought had got it cracked- seems to be Bonjour/ google/ati that would be the problem- enabled, browsers failed to load, then disabled and still wouldn't load- didn't make sense- so problem elsewhere.
Finally enabled diagnostic startup only +reboot

(Had started to copy W7 SP1 over from desktop- 50secs for a 1 meg file
then crashed when disabling firewalls in case they were blocking file transfer)

Desktop switched off to avoid any conflicts from the local network side.

At this stage-
On laptop-
ie8 no internet connection- not surprised with minimal services running

enabled most of ms services I  thought could be relevant
reboot

 screen dim
both ie and firefox loaded pages ok

Needed genuine check + sp1 files- this time folder copied over from desktop in approx 5/6 mins for about 1.4Gb- more like it!

enabled power and print spooler

reboot
screen ok browsers ok

enabled all startup
reboot
ie firefox ok
created restore point after "most services + all startup- before rest of services"

enabled rest of services
reboot

ie firefox, both failed so looks as though one of the enabled services is the source of the problem.
SO-
system restore to revert to previous point prior to restoring rest of services
reboot

installed sp1
Laptop rebooted, - says security essentials service stopped
created restore point-"after installing sp and before enabling all services"
reboot
ie + firefox load ok
very slow eg loading browsers + updates text file
Enabled all services
Created restore point after enabling all services- before enabling normal startup
reboot

browsers both ok, files loads quickly
enabled normal startup
reboot

browsers ok
still ok a number of reboots- although the windows screen takes quite a time before getting to the logon screen
-------------------------------------------------
To review
So far so good- originally I thought that it was one of the services blocking the web page loading, but slowly enabling services didn't resolve the problem as the  likely suspects didn't work as  the browsers failed to loading pages once the service was disabled again.

Diagnostic startup followed by adding in sufficient services to enable internet access and web page downloads followed by installation of SP1 seems to have resolved the problem.

 I have not found the actual cause of the problem, or why a system restore to an earlier point allowed pages to load on a reboot, whilst a few minutes later they failed to load again.
Perhaps just installing SP1 would have resolved the problem but I don't intend to do another system restore and start trying all over again!

I don't think I can award any points as no solution has been found/ accepted, but my thanks to those who have made suggestions.

(Can I award some points for suggestions that I tried, even though they didn't resolve the problem)
0
 
LVL 22

Expert Comment

by:optoma
ID: 34984086
Nice feedback :) its cool, just close and accept your above comment.
0
 

Author Comment

by:techtramp
ID: 34984575
Looks as though I spoke too soon- not a browser page load problem, but my external   usb drives / usb flash drives no longer work after the sp1 install. Just seen another couple of references to this on forums- not terribly impressive with a new SP.
If this continues- I'll start a new thread when I get the chance-
(other device- mass storage with nice yellow exclamation mark- drivers installing ,then failed to install properly- even if uninstalled and refresh device.- also unknown device in usb controllers)
0
 

Author Comment

by:techtramp
ID: 34984588
One suggestion was to power off machine- disconnect battery and then retry.
Will try overnight and see what happens
0
 

Author Comment

by:techtramp
ID: 34984651
Found a reference to a similar usb problem on another forum- Vista I think (can't credit it  as used a different PC now closed down) they suggested powering off the machine, disconnecting the laptop battery as well as the psu and leaving for a while , the motherboard may then 'refresh' the usb ports when powered up. Seemed to work for some, but for others the probelm returned later

I've just tried it with an HP nx6325 laptop and found my usb flash drive and external usb drive are now recognised.

 There is still an error on a mass storage device, but that be for something else.

Hope this helps someone else.

Is this worth putting up for general information somewhere
0
 
LVL 22

Expert Comment

by:optoma
ID: 34984661
Try the battery steps and hold down on the power button for 40 secs as well when battery + ac adapter removed
0
 

Author Comment

by:techtramp
ID: 35012118
Thanks optoma- the previous method of power off + remove battery worked- I'll keep the 40 sec power button hold ready for backup method  in case in happens again!

I'll close the question tomorrow if no-one else has anything to add (take my last 'end of story' post as the solution)- and again, many thanks for your suggestions.
0
 
LVL 22

Expert Comment

by:optoma
ID: 35012256
No prob :)
0
 

Author Closing Comment

by:techtramp
ID: 35081094
Actual cause of problem not identified, just a way round it
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Bada platform is becoming more and more famous this days and people talking about same. Some friends included those who have bada OS mobile asked me "what is bada?"and "what its features?". That encouraged me to research and write this article. [st…
First some basics on Windows 7 Backup.  It has 2 components one is a file based backup which is stored in .zip files each zip is split at around 200 Megabytes and there is the Image Backup which is as the name implies a total image of the partition …
Windows 8 comes with a dramatically different user interface known as Metro. Notably missing from the new interface is a Start button and Start Menu. Many users do not like it, much preferring the interface of earlier versions — Windows 7, Windows X…
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now