Cannot use SSL port 443 From 2008 server Cannot connect to any ssl web site.

I have a very strange issue with a 2008 server I first noticed this problem when Mozy backup which is used for some files stopped working. I then found I could not reach any ssl site or even the internal interface of my sonicwall. I have run wireshark and found 443 bound to  the system process.  When I try and access a ssl site I can see a SYN going out to 443 then ,a return SYN with: Header checksum: 0x0000 [incorrect, should be 0x2dec] RST packet and so on. I have been trying to identify what on the server is causing this conflict.  Any Ideas?
Mike000001Asked:
Who is Participating?
 
it_saigeConnect With a Mentor DeveloperCommented:
Go to the command prompt on the server and type in the following:

netstat -aon | find ":443"

This will provide a list of the process' that are using 443 on the server.  The PID can be used to find the process specifically in Task Manager that is using the port in question.

If it turns out to be something like lsass.exe or svchost.exe or rundll.exe , then you will need to use processexplorer from the SysInternals Pack to really determine the application.

ProcessExplorer can be found here: http://technet.microsoft.com/en-us/sysinternals/bb896653

HTH,

-saige-
0
 
Paul MacDonaldDirector, Information SystemsCommented:
Might be malware, but more likely something in the Firewall?
0
 
Alan HardistyCo-OwnerCommented:
What router / firewall do you have?  Some grab port 443 for remote management of the router itself, so you may need to reconfigure the port for remote management if the router.

Test for port 443 on www.canyouseeme.org to see if it is open and listening.
0
 
Mike000001Author Commented:
Cant be the firewall because I would be able to access the inside interface via ssl
I also changed the owa port to 444 and tried stopping every service I could.


0
 
Paul MacDonaldConnect With a Mentor Director, Information SystemsCommented:
I'm wondering if the problem is on the server, not the Sonicwall.  Do you have the Windows Firewall turned off on the server?  Are you running anything in its place?
0
 
Alan HardistyCo-OwnerCommented:
Re-run the Fix My Network Wizard.
0
 
Mike000001Author Commented:
Everything points to the server it seems. I have the firewall off and symantec endpoint 12 disabled. IIS too
0
 
Mike000001Author Commented:
TCP    0.0.0.0:443            0.0.0.0:0              LISTENING       4
 TCP    [::]:443               [::]:0                 LISTENING       4

process 4 is system



0
 
Alan HardistyCo-OwnerCommented:
Have you re-run the fix my network wizard again yet?
0
 
Mike000001Author Commented:
Hello  

I have run network wizard repair

I used netsh to reset the tcp\IP config to the defaults, this worked

Seems something messed up the IP stack  http://support.microsoft.com/kb/299357

note the commands are different for 2008

0
 
Mike000001Author Commented:
I solved it myself
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.