Link to home
Start Free TrialLog in
Avatar of QPR
QPRFlag for New Zealand

asked on

401 error connecting to sharepoint via web service

I've created a web app which displays sharepoint data on web pages.
This has always worked fine. We upgraded the sharepoint instance to 2010 and all was well within the sharepoint front end.
I open the visual studio web project and change the web reference to point to the new sharepoint address.
I can run the project locally on my workstation (asp.net development server) but when I copy the changes to the web server I get 401 unauthorised access errors.
The IIS settings have not changed.
Windows authentication and impersonation is used (The web.config )
I have rebooted the web server and the sharepoint server on the network admins advice as a server somewhere had been demoted fom being a domain controller and <insert networky speak>

Any ideas?
Avatar of siteoutfitters
siteoutfitters
Flag of United States of America image

Do you receive this error message only if you try to browse the Web site directly on the server? If you browse the Web site from a client computer, the Web site works as expected please review this helpful link:
http://support.microsoft.com/kb/896861/en-us

If that's not helpful I will do some more checking for you.
Avatar of QPR

ASKER

If I browse to the URL from my workstation I get 401
If I RDP to the web server and then browse to the URL from there I get in fine!

This leads me to suspect that this server does not have delegation to the SP server but it did for the original. Will check this when I get back from a meeting I have to dash to. Thanks for the clue
When looking at the event viewer, what type of authentication are you using?
If you are using Kerberos (and changed the urls of the site) did you change the SPN's with ADSIEDIT?
Avatar of QPR

ASKER

siteoutfitters
The url http://support.microsoft.com/kb/896861/en-us doesn't apply as I have the oppsite situation.
I can browse the sire directly from the server but not from the client PC

Could the port number be something to do with it?
On the old 2007 server the SP site was found under the default port 80... on this new SP 2010 server the site lives in a site collection at port 47272
If you want to be sure about the ports extend the web app to a hostheader on port 80 add it to your hosts file and test local on your server. But i do not think the port is the problem. The web service, is it running in the vti bin of sp?
Avatar of QPR

ASKER

I have stopped the site on port 80, changed the SP site to use port 80, changed the url and it's still the same so, I agree, we can discount ports.
Yes I am pointing to the _vti_bin folder and to the asmx file

Everything points to delegation not being set up but the network admin assures me it's been done in AD
ASKER CERTIFIED SOLUTION
Avatar of QPR
QPR
Flag of New Zealand image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of QPR

ASKER

see comment