Solved

How would I create a shared calendar for my company?

Posted on 2011-02-15
32
2,432 Views
Last Modified: 2012-05-11
Hi,

We're running exchange 2003 on sbs 2k3 server with win 7 machines running office 2010.  How would I create a vacation/day off type calendar for everyone to share/view in my company? Would it be on the server end or the client machine end? Can i change read write and view permissions so that users can only see what pertains to them?

Thanks.
0
Comment
Question by:cllocc
  • 14
  • 13
  • 2
  • +2
32 Comments
 
LVL 4

Expert Comment

by:gwickert
ID: 34901605
I believe by default in office 2010 everyone can see each others calendar, however they only see their appointments as 'busy' time rather than see what the actual appointment is.  When you create the calendar (at the outlook client end) people should by default be able to see what parts are 'blocked' off - i.e. they will be able to see the holiday blocks, but not see any information other than 'busy' on that calendar

To make certain people see what they need (example: Person A to see holiday block A and it's details, B to see block B and its details etc) you would only invite person A to the appointment that represents holiday block A, B to block B etc.

I hope that makes sense - should be a start at least.
0
 
LVL 5

Accepted Solution

by:
Noduzz earned 500 total points
ID: 34901607
As long as you have a Public Folder Store (which you should) Open Outlook on any machine and go to the folders and expand public folders, then right click on All Public Folders and click new folder.  Then choose calendar and that should create a public calendar for you.
0
 
LVL 13

Expert Comment

by:connectex
ID: 34901620
Creating the calendar in Exchange is easy. Just create the calendar under public folders and assign users rights necessary. However, it doesn't have any approval process or will it only let uses see some of the items. If you want approvals there's a SharePoint template that supposely does it.
0
 
LVL 5

Expert Comment

by:Noduzz
ID: 34901644
What i described above would be on the server end, it stores it on the public folder store, you can change the permissions on the calendar itself so you could theoretically create different public calendars for differnet users.
0
 
LVL 11

Expert Comment

by:FastFngrz
ID: 34902655
You've got 'http://companyweb' already running -aka SharePoint Services. Go there (internet explorer please), there might already be a calendar list ready for you. If you want a specific one, make one under Site Actions-Create.

You can set the permissions very granularly.. For example: managers must approve before anyone else sees it (content approval), only the creator of an item may edit that item (managers excepted, of course). You can even use an Alert to notify the manager when a request has been posted!  Use the Actions-Connect to Outlook to use the whole thang from outlook.exe

Exchange public folders will work, but they are so... 90's!
0
 

Author Comment

by:cllocc
ID: 34906213
gwickert:
I hope that makes sense - should be a start at least.

Thanks for the suggestion, I will see if that can work out for us as a permanent solution.

Noduzz:
As long as you have a Public Folder Store (which you should) Open Outlook on any machine and go to the folders and expand public folders, then right click on All Public Folders and click new folder.  Then choose calendar and that should create a public calendar for you.

I tried that from my computer and it said I dont have permissions to create in the folder or any subfolders. I went into ESM and gave myself read and write permissions but that still didnt seem to do it.

You've got 'http://companyweb'  already running -aka SharePoint Services. Go there (internet explorer please), there might already be a calendar list ready for you. If you want a specific one, make one under Site Actions-Create.

I did see the option there to list the calendar in outlook.  Will users have full read and write permissions and will the calendar on outlook and on companyweb be synced? I originally thought of using this calendar but i read that that using the companyweb calendar has its disadvantages and its better to use a public calendar.  Also, the companyweb from sbs 2k3 seems nowhere near as polished as the newer sharepoint services.
0
 
LVL 11

Expert Comment

by:FastFngrz
ID: 34906514
True - SBS 2003 is only WSS 2.0 - and SharePoint Foundation is sexier, but you're not going to get that till you either upgrade to WSS 3.0 (a small challenge under SBS 2003) or  SharePoint Foundation, and that's not even in SBS 2008!

The calendar will be synced - in WSS 2.0 it's a 1-way, from SharePoint to Outlook.

I recommend you try both - a Public Folder -and- a SharePoint Calendar - twiddle around with it until you and your users decide which is better.  Beta test for a month or so.
0
 
LVL 5

Expert Comment

by:Noduzz
ID: 34906652
You should have access to create the calendar as long as you are a domain admin i believe, otherwise you may need to add yourself as an exchange admin if you are not one on the exchange server possibly but i think you should be able to as a domain admin.  
0
 
LVL 5

Expert Comment

by:Noduzz
ID: 34906663
try to give yourself full permissions not just read and write in the public folder store.
0
 

Author Comment

by:cllocc
ID: 34909659
Ok, on the server I went into ESM, administrative groups, folders, right click public folders, properties, security tab, clicked add then added my username, then  I click OK and check off all permission settings in the box below, then i click advanced permissions and in the permissions tab I'm set to have full control.  However, when I try to add a calendar from from workstation it keeps telling me i dont have privileges. Do i need to restart my machine and/or the server?
0
 
LVL 5

Expert Comment

by:Noduzz
ID: 34909825
add yourself to:

Administrative Groups>(Your Administrative Group)>Servers>(Your Server)>(Your Storage Group)>Public Folders Store
0
 

Author Comment

by:cllocc
ID: 34910240
I just added everyone since ideally we would like everyone to be able to edit the calendar. However, by adding everyone, will this be a security issue or is it okay to do so?
0
 

Author Comment

by:cllocc
ID: 34910272

add yourself to:

Administrative Groups>(Your Administrative Group)>Servers>(Your Server)>(Your Storage Group)>Public Folders Store

I added everyone and i added myself however both times I still received the do not have permissions error.
0
 
LVL 5

Expert Comment

by:Noduzz
ID: 34910560
K try this, go to the Public Folders in ESM (the original place you set the permissions) and Create a new public Folder, call it whatever you want, maybe calendars etc, then right click it and go to permissions and client permissions and try to create a calendar in that folder in outlook, let me know the results.
0
 

Author Comment

by:cllocc
ID: 34910613
Sorry Im new to ESM but would i right click public folders then click create full-text index to create a new folder? I can't seem to find any create a new folder option in the right click menu or the menu for ESM
0
Why do Marketing keep bothering you?

Is your marketing department constantly asking for new email signature updates? Are they requesting a different design for every department? Do they need yet another banner added? Don’t let it get you down! There is an easy way to manage all of these requests...

 
LVL 5

Expert Comment

by:Noduzz
ID: 34910715
No go to Administrative Groups>(Your Administrative Group)>Folders>Public Folder to create the new folder.
0
 

Author Comment

by:cllocc
ID: 34915870
I don't have the option to create a new public folder.  Also, public folders do not show up in our outlook client which seems to make me think they are disabled?
0
 

Author Comment

by:cllocc
ID: 34915981
Noduzz:
K try this, go to the Public Folders in ESM (the original place you set the permissions) and Create a new public Folder, call it whatever you want, maybe calendars etc, then right click it and go to permissions and client permissions and try to create a calendar in that folder in outlook, let me know the results.

Ok, I was able to create a new folder in public folders in ESM. I added everyone to have full control in client permissions. However, neither public folders or that folder shows up in my outlook client.  Also, when I try to add a new calendar, I get the same permissions error
0
 

Author Comment

by:cllocc
ID: 34916502
I recommend you try both - a Public Folder -and- a SharePoint Calendar - twiddle around with it until you and your users decide which is better.  Beta test for a month or so.

tried out the calendar on wss 2.0 its not bad i guess but one way sync is kind of annoying.  I also gave up on public folders for the time being and decided to see if I could share my calendar and let others have full rights over it.  At least that way, multiple users can add their own appointments.

Will try to see if I can get public folders working.
0
 
LVL 5

Expert Comment

by:Noduzz
ID: 34916690
Ok try this:

http://www.msexchange.org/tutorials/PFMIGRATE.html

follow the instruction under "Who can create public folders?" this will verify if you have permissions to add public folders.
0
 

Author Comment

by:cllocc
ID: 34916988
Ok, I'm able to create public folders and calendars however when I create a test calendar in my oulook client and add it to a public folder hit ok, nothing shows up on the left pane.  Only my local and shared calendars stay with no option to choose the public folder calendars I had just created/
0
 
LVL 5

Expert Comment

by:Noduzz
ID: 34917416
Are you creating the calendar under the All Public Folders?
0
 
LVL 5

Expert Comment

by:Noduzz
ID: 34917441
Also did you give yourself full permissions under the administrative group?
0
 

Author Comment

by:cllocc
ID: 34919502
yes and yes.  I can create folders now from my outlook client. however, those folders dont show up in my outlook so the only way I can tell if I created a folder is if I go to create a new folder and see my existing folder in the list. so i made some progress but still not satisfactory.
0
 

Author Comment

by:cllocc
ID: 34919550
ok i found the issue.  By default public folders wasn't showing up in my folders list on the left pane but there were these tiny icons on the bottom of the left pane and one of them said folder list, so i clicked that and voila public folders showed up. Now that I can see them, I can play around with them. How can i edit read and write permissions per user on these public calendars? is it in the same security tab in ESM that i set my permissions at?
0
 
LVL 5

Expert Comment

by:Noduzz
ID: 34919603
You should be able to right click the calendar in outlook now and click properties and then go to the permissions tab to change settings per user.
0
 

Author Comment

by:cllocc
ID: 34920062
Great, its finally working. Now, how do I show this in the folder list that originally shows in the left pane? Right now the only way to get to the public folders is to click the folder list on the bottom of the left pane. I already tried adding the calendar and its parent folder as favorites but that didnt seem to show up. Right now, when I click on Mail in the left pane to see me mailbox, the only folders i see are my inbox, drafts, sent items, deleted items, junk email, outbox, rss feeds, search folders, spam mail, and personal folders.  But cant seem to figure out how to put public folders there.
0
 
LVL 5

Expert Comment

by:Noduzz
ID: 34920354
Well i think unfortunatley that is a feature of office 2010, but that being said what you can do is access the calendar when you click on the calendar button in the let pane and then where it says other calendars you can add the calendar there by checking it, otherwise if you click on the little folder it should keep open your email and the public folders and will stay like that even when you close and reopen outlook.
0
 

Author Comment

by:cllocc
ID: 34920494
awesome, thanks.
0
 
LVL 5

Expert Comment

by:Noduzz
ID: 34920601
Why was my answer not the accepted solution?  I thought that was the route you were going?
0
 

Author Comment

by:cllocc
ID: 34920873
put in a request for attention to award you full points. After it worked, I kinda just clicked away to close the question and let our department heads know about the resolution. But, you should get the full points since you fully resolved my problem as is evident from our posts.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now