Solved

Changing Forest Domain to point to external DNS servers, but keeping internal DC

Posted on 2011-02-15
8
379 Views
Last Modified: 2012-05-11
Hey guys, initally setting up my server, I made the mistake of calling my forest tree my external domain (domain.com).. I have all the workstations setup to point to that DC, and have reconfigured all their settings, and setup emails..

Now I realized that the DNS points to the DC when we punch in the address on IE.. and this won't work because the website is hosted externally at another company..

What is the best thing to do for this situation? Is there anyway I can rename the forest, without having to re-configure the settings/re-adding all the workstations back to the domain?

Any help is appreciated.

Thanks.
0
Comment
Question by:barbs1
  • 3
  • 3
  • 2
8 Comments
 
LVL 13

Expert Comment

by:kdearing
ID: 34901752
Add an entry in your server's DNS for www.domain.com and point it to the external address.
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 34902010
Go into your DNS forward lookup zone add an "A" record called www pointing to the external IP address of your website
0
 

Author Comment

by:barbs1
ID: 34902202
This works, but when I punch in just "dustcontrol.ca" without the www it still points back to IIS.. any solutions?
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 34902242
No, this is one of the down falls of having the same name internal and external. You can setup a IIS redirect on all of your Domain Controllers which redirect the request to external website
0
 
LVL 59

Accepted Solution

by:
Darius Ghassem earned 500 total points
ID: 34902255
0
 

Author Comment

by:barbs1
ID: 34902276
How would I set that? There is only one domain controller on the network.
0
 
LVL 13

Expert Comment

by:kdearing
ID: 34902414
Go into IIS on the server.
Default web site | right-click | Properties
Change the directory to the external web site.
0
 

Author Comment

by:barbs1
ID: 34902439
No, I found it, turns out HTTP Redirect isn't automatically enabled on IIS7, and needs to be added as a feature.
0

Featured Post

How our DevOps Teams Maximize Uptime

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us. Read the use case whitepaper.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Preface There are many applications where some computing systems need have their system clocks running synchronized within a small margin and eventually need to be in sync with the global time. There are different solutions for this, i.e. the W3…
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

679 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question