Solved

configure IIS for cgi

Posted on 2011-02-15
7
1,919 Views
Last Modified: 2013-12-25
I am getting an error when trying to run a perl script. I put a file called task1.cgi in the directory
C:\inetpub\wwwroot
then I tried to run it by going to www.mydomain.com/task1.cgi but I get an error message (see code below) which says
Error Summary
HTTP Error 403.19 - Forbidden
The configured user for this application pool does not have sufficient privileges to run CGI applications.

It mentions something later on in the message about doing something for the anyomous user but I cannot find reference to that user in %windir%\System32\Secpol.msc

Any help would be appreciated.
HTTP Error 403.19 - Forbidden
The configured user for this application pool does not have sufficient privileges to run CGI applications.
Detailed Error Information
Module	CgiModule
Notification	ExecuteRequestHandler
Handler	CGI as Perl64
Error Code	0x80070522
Requested URL	http://www.chatminer.com:80/task1.cgi
Physical Path	C:\HostingSpaces\getready\chatminer.com\wwwroot\task1.cgi
Logon Method	Anonymous
Logon User	Anonymous
Most likely causes:
CGI applications are launched as the authenticated user, if the site has anonymous authentication configured, the application may be launched as the anonymous user account.
If CreateProcessAsUser is true, then CGI applications are launched as the authenticated user.
If CreateProcessAsUser is false, then CGI applications are launched as the process identity.
The user account under which the application pool is configured to run does not have the following privileges:
Replace a process level token - SE_ASSIGNPRIMARYTOKEN_NAME.
Adjust memory quotas for a process - SE_INCREASE_QUOTA_NAME.
Things you can try:
If the CGI application is launched as the anonymous user, you can set the IIS configuration property, called CreateProcessAsUser, to False. This setting launches the CGI application as the application pool identity.
Add the necessary privileges to the user account the application pool is running as by completing the following:
Open the Local Security Policy settings MMC. Start %windir%\System32\Secpol.msc.
Expand the Local Policies node and then click User Rights Assignment.
In the right-hand pane, double-click Adjust memory quotas for a process.
Add the application pool identity to this user right and then click OK.
In the-right hand pane, double-click Replace a process token.
Add the application pool identity to this user right and then click OK.
Restart IIS for the changes to take effect.

Open in new window

0
Comment
Question by:onyourmark
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
7 Comments
 
LVL 16

Expert Comment

by:sjklein42
ID: 34903305
0
 
LVL 9

Accepted Solution

by:
shalabhsharma earned 500 total points
ID: 34903356
1. Open "Local Security Settings" MMC snap-in (Start -> Administrative Tools -> Local Security Policy).

2. Navigate to "Security Settings -> Local Policies -> User Rights Assignments":

3. Add "IIS_WPG" group to the following policies:

    *     Adjust memory quotas for a process
    *     Generate security audits
    *     Log on as a service
    *     Replace a process-level token

4. Close MMC snap-in.

5. Restart IIS (Start -> Run... -> iisreset).
0
 

Author Comment

by:onyourmark
ID: 34903398
hi. I don't see how to add IIS_WPG. Please see attached screen shots. Thank you. first second
0
How our DevOps Teams Maximize Uptime

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us. Read the use case whitepaper.

 

Author Comment

by:onyourmark
ID: 34905012
Hi. I get the message "Name Not Found" when I put IIS_WPG at the object name.
0
 
LVL 9

Assisted Solution

by:shalabhsharma
shalabhsharma earned 500 total points
ID: 34905550
Click on object type select group

Ok

Now enter IIS_wpg
0
 

Author Comment

by:onyourmark
ID: 34905826
I already tried that. It did not work. Thanks
0
 
LVL 9

Assisted Solution

by:shalabhsharma
shalabhsharma earned 500 total points
ID: 34905876
you have ii6 or iis7
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Batch, VBS, and scripts in general are incredibly useful for repetitive tasks.  Some tasks can take a while to complete and it can be annoying to check back only to discover that your script finished 5 minutes ago.  Some scripts may complete nearly …
Active Directory replication delay is the cause to many problems.  Here is a super easy script to force Active Directory replication to all sites with by using an elevated PowerShell command prompt, and a tool to verify your changes.
Learn the basics of lists in Python. Lists, as their name suggests, are a means for ordering and storing values. : Lists are declared using brackets; for example: t = [1, 2, 3]: Lists may contain a mix of data types; for example: t = ['string', 1, T…
Learn the basics of if, else, and elif statements in Python 2.7. Use "if" statements to test a specified condition.: The structure of an if statement is as follows: (CODE) Use "else" statements to allow the execution of an alternative, if the …

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question