Solved

Office 2010 gets Access Denied saving files

Posted on 2011-02-15
25
3,791 Views
Last Modified: 2012-05-11
SBS2008, patched up to date. A shared folder with loads of subfolders has permissions set for a user group so that they may open and change/save files, but cannot delete the files or folders, or move files or folders.

The user group has Read & Execute, Read & Write permissions only. All the clients are Win 7 or XP with Office 2003. This works.

New PCs with Office 2010 cannot save files (Word & Excel). They get an error message "Access Denied. Contact Your Administrator".

Seems to be an Office 2010 issue, as they can open Word docs in Wordpad and save them OK.

If I give the user group the Modify permission then they can save OK, but can also move & delete files.

Can anyone suggest why Office 2010 would cause this behaviour?
0
Comment
Question by:snooflehammer
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 5
  • 4
  • +3
25 Comments
 
LVL 13

Expert Comment

by:connectex
ID: 34903577
Sounds like it's creating a temporary file. It could be creating a file under a temporary name and then renaming it once the save/update completes. This is a safer way as it doesn't overwrite the original file until it's sure the new content has been saved. But it doesn't work in locked down folders.
0
 
LVL 13

Expert Comment

by:connectex
ID: 34903579
You can confirm this behavior by using Sysinternals Process Monitor to review the application file calls.
0
 

Author Comment

by:snooflehammer
ID: 34903605
Sounds like you'r eon the money, but do you know how to stop this behaviour?
0
Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

 
LVL 13

Expert Comment

by:connectex
ID: 34903617
Unless Microsoft has an option or registry change that resets it back to how older versions of Office do it, I doubt you can. I'm not aware of any way off hand. Like I mentioned saving to a temp file is "safer' and most people would prefer safer.
0
 
LVL 13

Expert Comment

by:connectex
ID: 34903970
I foudn this article: http://support.microsoft.com/kb/211632

It says:

Word gains significant performance speed by placing the temporary file in the same directory as the saved file. If Word placed the temporary file elsewhere, it would have to use the MS-DOS COPY command to move the temporary file from the other directory to the saved location. By leaving the temporary file in the same directory as the saved document file, Word can use the MS-DOS MOVE command to quickly designate the temporary file as the saved document.
0
 

Author Comment

by:snooflehammer
ID: 34904000
Thanks, but I don't see how this helps resolve the issue, i.e. I need to prevent moves & deletions while allowing saves
0
 
LVL 13

Expert Comment

by:connectex
ID: 34904006
From what I read they claim it's a hard coded to use the final save location. So I really doubt there's a way to change it. You'd have to complain to Microsoft about it. And even if they said ok, it would take a while for them to fix it. I think you'll have to change your rights settings or avoid Office 2010.
0
 
LVL 1

Expert Comment

by:Cats_Eye
ID: 34904060
Ok, this may sound strange but I had the same thing but it's gone now.  What happened is, my PC got struck by lightning.  My hard drive was fine so I put it into a case.   I then had to "Take Ownership" of the files.

Moved the files onto new PC and took ownership again.  Not had a problem since!
I can only think that is what sorted it out.  Perhaps I am wrong.  But I don't think there is any harm in trying it ;-)

I'm running Windows 7 Pro with Office 2010 with all updates installed :)
0
 

Author Comment

by:snooflehammer
ID: 34904092
OK. So let me get this straight: You want me to get the Small Business Server 2008 box struck by lightning, and go from there? And that will fix the permissions so that files can't be deleted, but temp files can be?

Excellent.

I'm just off to put the server on the roof, as there's some weather rolling in...
0
 
LVL 13

Expert Comment

by:connectex
ID: 34904095
Well, he mentioned taking ownership of the files. But owner is allowed to do anything to the files so they'd be able to delete or rename them too.
0
 
LVL 1

Expert Comment

by:Cats_Eye
ID: 34904146
Oops.  My bad.  Apologies
0
 
LVL 4

Expert Comment

by:wylie_uk
ID: 34907332
alow owner/creator the permision to delete files from this folder only. this wil solve your issue

the downside is that users can delete file they have created (but only their files and not other peoples)
but to me it makes good sense to have it this way.
0
 
LVL 13

Expert Comment

by:connectex
ID: 34907425
But based on my post 34903970 this means that people will only be able to edit their own files. Not one that was already created by another user. That's not going to be of much for a folder shared with several users.
0
 
LVL 4

Expert Comment

by:wylie_uk
ID: 34911021
negative

leave all the other security in place so people can edit thier own files and other peoples, and just add owner/creator can del files to the mix


so then people can create files and del the files they create, and also edit other peoples but not del other peoples.
0
 

Author Comment

by:snooflehammer
ID: 34911049
Creator/Owener already has Full Control. Still have original problem, i.e. I need to prevent moves & deletions while allowing saves
0
 
LVL 13

Expert Comment

by:connectex
ID: 34911076
I think your fighting a losing battle. I advised earlier to less the rights or avoid Office 2010 installations. Another option is to have a staging area with more rights and then move the files to the final area at the end of the day.
0
 
LVL 4

Expert Comment

by:wylie_uk
ID: 34911086
ok..... bizarre.. open a word document, go find the temp file, look at the security and find out who it lists as the current owner.
0
 

Author Comment

by:snooflehammer
ID: 34911239
The temp file list all the users of the folder EXCEPT Creator/Owner - WTF?
0
 
LVL 4

Expert Comment

by:wylie_uk
ID: 34911815
on file

properties>security>advanced>owner tab>current owner field.
0
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 500 total points
ID: 34947996
The problem has to do with how Office 2007 and later versions handles the temp files it creates during document editing.  If you've denied "modify" for users, I would suspect that you might have a bunch of .tmp files scattered around your shared folder because they can't be deleted automatically the way they are supposed to.  (the temp files that begin with ~ are system files which usually ARE deleted automatically though).  

Also, I would suspect that you might have trouble creating and saving a NEW document (especially an Excel doc) using Office 2003, however you CAN modify and save an existing document with Office 2003.

It seems to me that trying to prevent anyone from moving or deleting files from a directory that they are also allowed to write to is your primary problem.  I wonder why you are wanting to prevent this, because allowing someone to write to that directory would allow them to fully change a document or even save a blank document over the one that's already there effectively doing the same thing as moving or deleting it.  Have you had this problem in the past?  

There is something you can do so you don't have to worry about these things anymore:  Make sure that Shadow Copies are enabled on drive containing the shared folder.  This way with default shadow copy settings users can recover previous versions of any document changed within the last 30 days.  Or by looking at the previous version of the parent folder, any document moved within the last 30 days can be restored to it's rightful location.

Jeff
TechSoEasy



0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 35166362
snooflehammer never responded to my comment.  I believe I effectively summarized the situation and provided a viable solution.

Jeff
TechSoEasy
0
 
LVL 59

Expert Comment

by:LeeTutor
ID: 35252686
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.
0

Featured Post

Turn Insights Into Action

You’ve already invested in ITSM tools, chat applications, automation utilities, and more. Fortify these solutions with intelligent communications so you can drive business processes forward.

With xMatters, you'll never miss a beat.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article descibes how to create a connection between Excel and SAP and how to move data from Excel to SAP or the other way around.
How to get Spreadsheet Compare 2016 working with the 64 bit version of Office 2016
This video shows where to find templates, what they are used for, and how to create and save a custom template using Microsoft Word.
The viewer will learn how to simulate a series of sales calls dependent on a single skill level and learn how to simulate a series of sales calls dependent on two skill levels. Simulating Independent Sales Calls: Enter .75 into cell C2 – “skill leve…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question