Solved

SERV-U   configuration with Linksys router e2000

Posted on 2011-02-15
8
682 Views
Last Modified: 2012-05-11
I have been over and over the instructons provided by rhinosoft and am unable to get serv-u to work through our router,  I havew put the serv-u machine in the DMZ and it works great, locally it works great. However as soon as it is behind the firewall i cant connect. I have tried a dlink and couldnt ,  thinking a newer router might be the trick i put the linksys in place.

I have opened ports for ftp(2011) and pasv(5000-5004), I get authed promted by either by IP or fqdn, but  doesnt seem to pass.  Feeling like im missing something obvious
seaweed
0
Comment
Question by:seaweed27
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
8 Comments
 
LVL 16

Expert Comment

by:AlexPace
ID: 34908609
You'll need the help of an FTP client capable of producing a protocol-level log.  If you have that go ahead and post the log.  If not, do this:

1. Download and install the eval version of Robo-FTP client.

2. Open the program and type this:  TRACELOG "help_me.log" /debug

3. Now type the following (substituting your information)
FTPLOGON "ftp.mydomain.com" /user="myusername" /pw="mypassword"

It should still fail to connect but it will create a protocol-level log that shows the problem.  Look in the Robo-FTP install folder for "help_me.log" and paste the contents here... actually for your own security make sure your password is not in the log before you post it.
0
 

Author Comment

by:seaweed27
ID: 34910884
thank alex, i can follow those instructions. Ill get back to you later this evening.
0
 

Author Comment

by:seaweed27
ID: 34912179
The first attempt fqdn of server- get promted with IE/FF, but never fully connect times out
The second is my home-  I can pass auth and access files everyway i have tried
The third is by ip address of the server - get promted with IE/FF, but never fully connect times out

Hope this helps cause i still feel lost. I though maybe dns but both names resolve to the correct ip address??


Wed Feb 16 18:11:40  => *Logging on to <ftp2.server.com:2011> as FTP.
Wed Feb 16 18:11:40  => Connection object created
Wed Feb 16 18:11:40  => Connection object destroyed
Wed Feb 16 18:11:40  => Connection thread(0x268) reset correctly
Wed Feb 16 18:11:40  => wodFtpDLX.dll version 3.0.9.618, wodCertifcate.dll version (null)
Wed Feb 16 18:11:40  => Logging on...
Wed Feb 16 18:11:40  => Connecting to "ftp2.server.com:2011"...
Wed Feb 16 18:11:40  => Status: Connecting to server
Wed Feb 16 18:11:40  => Status: Disconnected from server
Wed Feb 16 18:11:40  => Error: Host not found. (11001)
Wed Feb 16 18:11:40  => wodFtpDLX.dll version 3.0.9.618, wodCertifcate.dll version (null)
Wed Feb 16 18:11:40  => Logging on...
Wed Feb 16 18:11:40  => Connecting to "ftp2.fserver:2011"...
Wed Feb 16 18:11:40  => Status: Connecting to server
Wed Feb 16 18:11:40  => Status: Disconnected from server
Wed Feb 16 18:11:40  => Error: Host not found. (11001)
Wed Feb 16 18:11:40  => Error: connection to "ftp2.server:2011" failed
Wed Feb 16 18:14:25  => Error: Could not read settings for site myhome.no-ip.info:220 from registry: ServerName: QueryString size failed: The handle is invalid.
Wed Feb 16 18:14:25  => *Logging on to <myhome.no-ip.info:220> as FTP.
Wed Feb 16 18:14:25  => Connection object created
Wed Feb 16 18:14:25  => Connection object destroyed
Wed Feb 16 18:14:25  => Connection thread(0x328) reset correctly
Wed Feb 16 18:14:25  => wodFtpDLX.dll version 3.0.9.618, wodCertifcate.dll version (null)
Wed Feb 16 18:14:25  => Logging on...
Wed Feb 16 18:14:25  => Connecting to "myhome.no-ip.info:220"...
Wed Feb 16 18:14:25  => Status: Connecting to server
Wed Feb 16 18:14:25  => Status: Disconnected from server
Wed Feb 16 18:14:25  => Error: Host not found. (11001)
Wed Feb 16 18:14:25  => wodFtpDLX.dll version 3.0.9.618, wodCertifcate.dll version (null)
Wed Feb 16 18:14:25  => Logging on...
Wed Feb 16 18:14:25  => Connecting to "myhome.no-ip.info:220"...
Wed Feb 16 18:14:25  => Status: Connecting to server
Wed Feb 16 18:14:25  => Status: Disconnected from server
Wed Feb 16 18:14:25  => Error: Host not found. (11001)
Wed Feb 16 18:14:25  => Error: connection to "myhome.no-ip.info:220" failed
Wed Feb 16 18:23:51  => Error: Could not read settings for site x.x.x.x:2011 from registry: ServerName: QueryString size failed: The handle is invalid.
Wed Feb 16 18:23:51  => *Logging on to <x.x.x.x:2011> as FTP.
Wed Feb 16 18:23:51  => Connection object created
Wed Feb 16 18:23:51  => Connection object destroyed
Wed Feb 16 18:23:51  => Connection thread(0x368) reset correctly
Wed Feb 16 18:23:51  => wodFtpDLX.dll version 3.0.9.618, wodCertifcate.dll version (null)
Wed Feb 16 18:23:51  => Logging on...
Wed Feb 16 18:23:51  => Connecting to "x.x.x.x:2011"...
Wed Feb 16 18:23:51  => Status: Connecting to server
Wed Feb 16 18:23:51  => Status: Disconnected from server
Wed Feb 16 18:23:51  => Error: Host not found. (11001)
Wed Feb 16 18:23:51  => wodFtpDLX.dll version 3.0.9.618, wodCertifcate.dll version (null)
Wed Feb 16 18:23:51  => Logging on...
Wed Feb 16 18:23:51  => Connecting to "x.x.x.x:2011"...
Wed Feb 16 18:23:51  => Status: Connecting to server
Wed Feb 16 18:23:51  => Status: Disconnected from server
Wed Feb 16 18:23:51  => Error: Host not found. (11001)
Wed Feb 16 18:23:51  => Error: connection to "x.x.x.x:2011" failed
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 16

Accepted Solution

by:
AlexPace earned 500 total points
ID: 34912384
I'm sorry I forgot to mention that you need to use the /port option to specify a non-standard port in Robo-FTP rather than doing the little thing with the colon at the end of the address like you do with the command line client.

So please try this:  (modify as necessary)
FTPLOGON "ftp.mydomain.com" /user="myusername" /pw="mypassword" /port=2011


.... and post the new log.
0
 

Author Comment

by:seaweed27
ID: 34912441
Ok I made some change to pasv ports and ftp port. Now i can access from IE7 and FF but not from
IE 8?

Any ideas
0
 

Author Comment

by:seaweed27
ID: 34912647
I was wrong, an old filezilla server was runing, I uninstalled and lost ability to connect alltogether again

Robo-FTP(4536) v3.7.8.1 TRACE LOG FILE        [ SN: *EVAL* ]

Wed Feb 16 20:07:37  => OS: WIN.NETSRV
Wed Feb 16 20:07:37  => UserName: User
Wed Feb 16 20:08:29  => ****> CMD:        FTPLOGON "ftp2.server.com" /user="username" /pw="********" /port=2011
Wed Feb 16 20:08:29  => Error: Could not read settings for site ftp2.server.com from registry: ServerName: QueryString size failed: The handle is invalid.
Wed Feb 16 20:08:29  => *Logging on to <ftp2.server.com> as FTP.
Wed Feb 16 20:08:29  => --> starting LogonProc
Wed Feb 16 20:08:29  => --> CommonLogonProc:
Wed Feb 16 20:08:29  => --> starting CommonwodDLXThread
Wed Feb 16 20:08:29  => Connection object created
Wed Feb 16 20:08:29  => Connection object destroyed
Wed Feb 16 20:08:29  => Connection thread(0x214) reset correctly
Wed Feb 16 20:08:29  => wodFtpDLX.dll version 3.0.9.618, wodCertifcate.dll version (null)
Wed Feb 16 20:08:29  => Logging on...
Wed Feb 16 20:08:29  => Connecting to "ftp2.server.com"...
Wed Feb 16 20:08:29  => Status: Connecting to server
Wed Feb 16 20:08:30  => Status: Disconnected from server
Wed Feb 16 20:08:30  => Error: The requested connection has been refused by the remote host. (10061)
Wed Feb 16 20:08:30  => wodFtpDLX.dll version 3.0.9.618, wodCertifcate.dll version (null)
Wed Feb 16 20:08:30  => Logging on...
Wed Feb 16 20:08:30  => Connecting to "ftp2.server.com"...
Wed Feb 16 20:08:30  => Status: Connecting to server
Wed Feb 16 20:08:31  => Status: Disconnected from server
Wed Feb 16 20:08:31  => Error: The requested connection has been refused by the remote host. (10061)
Wed Feb 16 20:08:31  => Error: connection to "ftp2.server.com" failed
Wed Feb 16 20:08:31  => --> CommonFTPShutdown: 1
0
 

Author Comment

by:seaweed27
ID: 34913175
well Its working everywhere but my IE browser, but thats a battle for another day.
you advice regarding robo ftp was allowed me to see that the wrong server/serice was answering.
Thank you for helping.

Seaweeed
0
 
LVL 16

Expert Comment

by:AlexPace
ID: 34913346
That error message "requested connection has been refused by the remote host" means the remote server won't talk on that port.  So you don't even get get a chance to try the username and password. Are you sure about 2011?
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Router question 6 258
Is Fedora an appropriate distro for the environment. 7 93
Boot Camp 3 60
Cisco router is restricting wireless bandwidth download and upload speed 38 51
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question