Solved

how to set  soft limit as unlimited for stacksize in linux

Posted on 2011-02-15
8
1,509 Views
Last Modified: 2013-12-15
i want to set stack size limit to unlimited for soft limit for particular user on RHEL5.3

i set to hard limit to unlimited and it's showing if i give ulimit -Hs but if i set unlimited or any other value for soft limit in /etc/security/limits.conf it's not getting reflected.
i closed the session and re-opened it also.

0
Comment
Question by:manean
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 34904392
Hi,

could it be that there is a ulimit command in the user's .profile resetting the limit to the old value?

What is the immediate effect of "ulimit -Ss unlimted"? Check with "ulimit -Ss"!

wmp
0
 
LVL 68

Accepted Solution

by:
woolmilkporc earned 500 total points
ID: 34904421
... and is there a /etc/security/limits.d/ directory? If so, what's in there?

Further, please try "-1" instead of "unlimited" in limits.conf. Some OS'es don't suppoert "unlimited".
Also remember that you'll have to set both hard and soft values in limits.conf.

wmp
0
 

Assisted Solution

by:manean
manean earned 0 total points
ID: 34904554
Hi

there is no ulimit command in user profile.
after logging in i have set  " ulimit -s unlimited " and it's showing stack size as unlimited, but if open new session it's going to old setting.
i have set up value for both soft and hard limit, but hard limit only permenatly getting reflected but not
soft limit.

/etc/security/limits.d is empty.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 14

Expert Comment

by:Monis Monther
ID: 34904799
Set it under user's home dir .bashrc file.

/home/username/.bashrc

This will enable the ulimit in both logon and nologon Terminals.

0
 
LVL 10

Expert Comment

by:Martin_J_Parker
ID: 35213830
What have you actually got in the /etc/security/limits.conf file?

You need 2 lines in there as follows:
* soft core unlimited
* hard core unlimited
0
 

Author Comment

by:manean
ID: 35868347
its working now.
0
 
LVL 10

Expert Comment

by:Martin_J_Parker
ID: 35877146
Glad to hear it's working but please do tell us what the solution was. It may benefit others with the same problem in the future.
0
 

Author Closing Comment

by:manean
ID: 35892817
Its working.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
awk file 6 96
lunix and unix command 21 111
CentOS 7 Linux for HP DL380 G4 32Bits 7 71
edit firefox cookie settings via shell script on ubuntu 14? 1 32
You ever wonder how to backup Linux system files just like Windows System Restore?  Well you can use Timeshift in Linux to perform those similar action.  This tutorial will show you how to backup your system files and keep regular intervals. Note…
Hello EE, Today we will learn how to send all your network traffic through Tor which is useful to get around censorship and being tracked all together to a certain degree. This article assumes you will be using Linux, have a minimal knowledge of …
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question