Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Graphical mode for remote connection

Posted on 2011-02-15
17
Medium Priority
?
613 Views
Last Modified: 2013-12-06
Currently, my Linux server has enabled ssh but I couldn't only connect it using text mode. Is it possible to enable the graphical support for all remote connection, while keeping the default graphical mode in the console ?

Thanks
0
Comment
Question by:AXISHK
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 7
17 Comments
 
LVL 12

Expert Comment

by:upanwar
ID: 34904350
You can either configure VNC server on your system and then connect your linux box through VNC Viewer or you can just use x-manager to run graphical application from your server.

http://www.netsarang.com/tutorial/xmanager/3121/Connecting_and_executing_remote_X_application_with_Xstart

0
 
LVL 12

Expert Comment

by:upanwar
ID: 34904354
to configure VNC server just follow the URL:

http://www.walkernews.net/2007/07/05/how-to-setup-linux-vnc-server/
0
 
LVL 9

Expert Comment

by:abolinhas
ID: 34905698
0
Get your Disaster Recovery as a Service basics

Disaster Recovery as a Service is one go-to solution that revolutionizes DR planning. Implementing DRaaS could be an efficient process, easily accessible to non-DR experts. Learn about monitoring, testing, executing failovers and failbacks to ensure a "healthy" DR environment.

 

Author Comment

by:AXISHK
ID: 34912980
I have start the VNC and on my Window, I could connect to the Linux. However, it doesn't startup with graphical mode.

Even though I have killed the window session and try to start in graphical mode using "startx". It doesn't help.

I have also modifed the configuration under /too/.vnc/xstartup file, and replace but doesn't help. Any further advise ?

twn & 

   with

gnome-session --sm-disable
gnome-session

0
 

Author Comment

by:AXISHK
ID: 34913069
Hi,

Edit the $HOM/.vnc/xstartup and fix the problem. However, I still have some issue.

It only works for the first time connecting to from Window. When I logoff from VNC viewer and connect again. The graphical mode appears but no icon on the desktop can be used. I could only get the graphical mode enable by killing the session on the server and run the "vncserver" again. Any idea what's wrong ?

Thanks



0
 

Author Comment

by:AXISHK
ID: 34913097
Play around with VNC Viewer and find a fix for this. Actually, I need to click the "cross" button on the window right hand size, rather than log off from the System menu.

Is it expected to do in this way ? All VNC session share the same password, correct ?
0
 

Author Comment

by:AXISHK
ID: 34913122
One more thing, how to enable vncserver will be started everytime when I reboot the Linux. Use the command chkconfig to add to start at every reboot but doesn't help.

Tks
0
 

Author Comment

by:AXISHK
ID: 34913137
Sorry, could get the vncserver start automatically after reboot.  Only leave the reply logoff issue on my previous thread.

Tks
0
 
LVL 12

Expert Comment

by:upanwar
ID: 34913426
I have always used close button instead of logging off, because I was using vnc to manage redhat directory server, so I have not notice this issue.

But today by 3:00 PM IST I will check and get back to you.

0
 

Author Comment

by:AXISHK
ID: 34913560
Tks.

Just one another issue, the vncserver couldn't start even though I have put it under chkconfig:
    vncserver       0:off   1:off   2:on    3:on    4:on    5:on    6:off

Hence, I need to type 'vncserver" on the server before I could use VNC for remote client. Any idea ?

thanks again.
0
 
LVL 12

Expert Comment

by:upanwar
ID: 34914066
0
 
LVL 12

Expert Comment

by:upanwar
ID: 34914110
Once you log off and login to your vnc session just execute the command xterm, your issue should be fixed.
0
 

Author Comment

by:AXISHK
ID: 34914158
chkconfig --level 5 vncserver on

Already put the command on the server. Reboot but it doesn't help...

0
 
LVL 12

Expert Comment

by:upanwar
ID: 34914472
Have you set this

VNCSERVERS="1:root"

in file /etc/init.d/vncserver.

 
0
 

Author Comment

by:AXISHK
ID: 34914511
Yes, that's work.

So, it is recommended to disconnect remote session with "cross" button, rather than logoff ? If yes, I could mark the point.

Tks
0
 
LVL 12

Accepted Solution

by:
upanwar earned 2000 total points
ID: 34914525
Yeah that whoild be great or after logging off and logging in you can try to execute xterm on command prompt which you can open by right click.

0
 

Author Closing Comment

by:AXISHK
ID: 34914549
Tls
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In order for businesses to be compliant with certain information security laws in some countries, you need to be able to prove that a user (which user it was becomes important to the business to take action against the user after an event has occurr…
This document is written for Red Hat Enterprise Linux AS release 4 and ORACLE 10g.  Earlier releases can be installed using this document as well however there are some additional steps for packages to be installed see Metalink. Disclaimer: I hav…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question