Video editing software for G4

Hi experts,

I wonder if there is any good video editing software that can easily import from a videocamera through Firewire on a G4 mac.
OSX ver. 10.5.8

I tried installing iMovie but it requires better mac and won't run on my G4. I tried google it, but don't find anything
LVL 10
MadjaxAsked:
Who is Participating?
 
MadjaxConnect With a Mentor Author Commented:
I checked FCE and doesnt support my cam which is a Canon MV950 (mini DV)
0
 
jhyieslaCommented:
Have you taken a look at Final Cut Express?

http://www.apple.com/finalcutexpress/specs.html
0
 
MadjaxAuthor Commented:
thanks but little too expensive for average home user. Got anything else?
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
jhyieslaCommented:
What's your budget?  FCE is only $200.

My son uses the professional version, which is definitely too heavy for the home user - more like $1200.

I'll ask him if there is anything else he can recommend.
0
 
MadjaxAuthor Commented:
It's like 50 dollars ;-)
0
 
jhyieslaCommented:
I've never used this, but it sounds like it might get you want you want.

http://download.cnet.com/Avid-Xpress-Pro/3000-18515_4-10771963.html

0
 
Tom GrellCOMMUNICATIONS SPECIALISTCommented:
I do not believe Avid Xpress Pro is being sold anymore, although you may find a copy on eBay. Avid's current consumer level video editors are Windows only. You may find something here:
http://www.moviesmac.com/tutorial/free-mac-video-editors.html
0
 
jhyieslaCommented:
The link is a free download from CNet and it is for Mac. I've not downloaded it as I have no need for it, but it seems legitimate.
0
 
Tom GrellCOMMUNICATIONS SPECIALISTCommented:
It is a valid link to a free download, but it is a trial version of a maintenance update to an expensive, pro level software program. Google "Free Mac Video Software" to find low cost programs. It may take a while to find something that has the features you want and that will run on your G4.
0
 
MadjaxAuthor Commented:
Checked Avid Express Pro and it couldnt be installed in 10.5.8

any other suggestions on video software for a Canon MV950 on a G4 with 10.5.8?
0
 
MadjaxAuthor Commented:
Solved this myself. None of the apps suggested could support my cam. I modified the iMovie package instead with Hexeditor (according to a google link) so I could install it on my G4 mac. Worked perfectly after.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.