Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

trunking  between Huawei S3900 and Cisco catalyst 3750

Posted on 2011-02-16
6
Medium Priority
?
5,557 Views
Last Modified: 2012-05-11
One of my edge Huawei S3900 stack switches  is dead, I am going to replace it with a Cisco switch Catalyst 3750 series PoE-48 via a trunk link  with GE fiber port on both ends, please see the diagram below.
                                  trunk                     trunk
   Core switchrouter<----------S3900<--------------->Cisco Catlyst 3750

I haven’t touch Cisco switch for many years, I would like to ask the following questions:

1.)      Do I need to take any precaution before connecting this Cisco switch into my Huawei network? Only one link between S3900 and C3750, so I don't need worry anout STP? Do I need to worry about Default vlan regarding trunking port?
2.)      I need to use different trucking protocol e.g. 802.1Q etc to interconnect these two switches (S3900 and Catalyst 3750), please see the following configuration:
 
For C3750:
 
switchport trunk encapsulation dot1q
switchport trunk native vlan (What you want)
switchport trunk allowed vlan (VLANs required)
switchport mode trunk
spanning-tree portfast trunk

For S3900:

 port link-type trunk
 port trunk permit vlan all

Do you think the configurations above are right?

Do I need to manually enter Duplex and speed options ?       


3.)If the configurations are not right, then what are the commands for trucking port/link should I use on the Cisco switch (it uses IOS software) and Huawei switch?  Procedures of the commands would be really helpful !

Any information and help would be much appreciated.

Thanks

Regards

John


 
0
Comment
Question by:mbsadmin1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 8

Expert Comment

by:SeeMeShakinMyHead
ID: 34905433
being a trunk like, I would manually set port speed and duplex.  I do that for all network devices.  Also, looks like you are allowing all vlans so you can eliminate the sw tr al vl xxx command as without this command, it will trunk all VLANS.  As for native VLAN, you can leave this blank and it will trunk VLAN 1 natively by default.  Not sure what VLAN S3900 uses.  However, you can connect the 3750 to the S3900 and run term mon on a telnet/ssh session (or is consoled, you don't need this command to see session output), and you will see if the native vlan matches or not and adjust from there.  I would also disable DTP (Dynamic Trunking Protocol) as well.  Other than that, its pretty simple.
0
 

Author Comment

by:mbsadmin1
ID: 34948017
Hi SeeMeShakinMyHead,

Thanks for youe help it's appreciated.
I got it wirking by using the following:

 For Cisco catalyst 3750 :
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast trunk

For Huawei S3900:
interface GigabitEthernet1/1/1
 port link-type trunk
 port trunk permit vlan all

Also I make sure the new Cisco switch is not going to competing for root switch when it is in our live network, so I did the following on this cisco switch:
Switch(config)#spanning-tree mst 1-4094 priority 61440

Now I have another question: what are the configurations/commands to configure port of Cisco Catalyst 3750 for VoIP (equivalent to the configurations on the port on Huawei S3900):

For S3900:
interface Ethernet1/0/2
 poe enable
 port link-type hybrid
 port hybrid vlan 8 tagged
 port hybrid vlan 100 untagged
 undo port hybrid vlan 1
 port hybrid pvid vlan 100
 priority trust

* vlan 8 is for VoIP, vlan 100 is for staff PCs/laptops, Vlan1 is default vlan

What are the equivalent commands on port of Cisco catalyst 3750 for VoIP and PCs?

Any information and help would be much appreciated.

Thanks

Regards

John
0
 

Accepted Solution

by:
mbsadmin1 earned 0 total points
ID: 34948808
Cisco Catalyst uplink :
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk

Alcatel VoIP (IP Touch 4018) in connected to :
interface FastEthernet1/0/2
switchport access vlan 100
switchport mode access
switchport voice vlan 8
spanning-tree portfast

Are these settings okay?

No qos settings for both interfaces above.

Any information and help would be much appreciated

Thanks

Regards

John
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 8

Expert Comment

by:SeeMeShakinMyHead
ID: 34950611
put this on the interface.  The switch will automatically configure QoS queues, policy-maps and class-maps for this.
 
 mls qos trust device cisco-phone
 mls qos trust cos
 auto qos voip cisco-phone
0
 

Author Comment

by:mbsadmin1
ID: 34956269
what "the interface" ? uplink interface? or the interface the VoIP phone is going to be connected to?

Also, I use  Alcatel VoIP (IP Touch 4018) instead of Cisco VoIP phone, do I still need to use "mls qos trust device cisco-phone" or "auto qos voip cisco-phone" ?

I configured "auto qos voip trust" only on both interfaces by following:

http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_example09186a0080722cdb.shtml

Any information and help would be much appreciated.

Thanks

Regards

John
 
0
 

Author Closing Comment

by:mbsadmin1
ID: 35067609
Thanks for youe advice, Now Cisco is connected to Huawei switch.

Wireless, VoIP and Data are working.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question