Link to home
Start Free TrialLog in
Avatar of Sumanbabu
Sumanbabu

asked on

403 - Forbidden error

Hello friends,

I am new to PHP world. I have gone through the below link and setup and lighthttpd and PHP server in windows XP.
http://www.winstonyw.com/2008/05/28/installing-lighttpd-and-php-on-windows/ 
After successfully restarting the server I can able to see the home page(index.html).
lastly i put testing.php in C:\Program Files\LightTPD\htdocs and after restarting the server i opened the browser and http://localhost/testing.php is giving "403 - Forbidden" error.

Please help me.
Avatar of andreizz
andreizz
Flag of Romania image

This may be from your .htaccess configuration, please post that so we can see.
You can find it in htdocs, it may be hidden.
ASKER CERTIFIED SOLUTION
Avatar of andreizz
andreizz
Flag of Romania image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Sumanbabu
Sumanbabu

ASKER

.htaccess is not there in C:\Program Files\LightTPD\htdocs
as per requirement i need to use only LightHttpd :(
Check to see if the folder and file are not read-only, and search for the .htaccess file.
Put a txt file in the htdocs folder and try to access that.
yes, I created "hi.txt" and I am able to access http://localhost/hi.txt and can see the out put.
i just noticed while starting the lightHttpd i got the below warning

WARNING: unknown config-key: cgi.assign (ignored)

i have added the line "
cgi.assign = ( ".php" => "C:/php/php-cgi.exe" )" at the end of lighttpd-inc.conf
Thanks for your cooperation @andreizz.

 I deleted "mod_cgi" earlier, i put it back. Its working fine.

No problem, good luck!
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial