Link to home
Start Free TrialLog in
Avatar of marcus_w
marcus_w

asked on

In "Deleting Browser History" in IE8 everything is greyed out

Hi there

We have a Windows Server 2008 Domain Controller and I want to make sure, that a group of users is able to delete their browsing history themselves. Either all in once or just parts of it i.e. temporary internet files. They should also be able to keep the cookies. The clients run on WinXP SP3.

But somehow I cannot manage it to work. My settings are like this:

 User generated image
but still everything is greyed out?!

User generated image
What am I doing wrong?

Thanks for your help.
Avatar of andreizz
andreizz
Flag of Romania image

What you did enabled the "Delete browsing history" window to display, now change the options with Prevent *something* also to disable, that might work.
Avatar of Amit
Is this a User or Computer configuration.

Move user or computer object the OU where you have applied it.
ASKER CERTIFIED SOLUTION
Avatar of Amit
Amit
Flag of India image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of marcus_w
marcus_w

ASKER

It is a user configuration and the object is applied to the appropriate ou. As a test I tried out another internet explorer gp setting: I disabled "disable autocomplete for forms" and this worked immediately.

Thanks for the link. I will read that one now.

@andreizz: I already tried that without success.

Make sure that you open gpmc.msc and not gpedit.msc (which is local).
Right click and edit, and then:
+User configuration
+Policies
+Administrative Templates
+Windows Component
+Internet Explorer
+Delete private browsing
I always open the Group Policy Management Editor on the Domain Controller to change Group Policies.
Marcus. Thanks for the update that you were able to make it work. Please let me know, if you need further
help
Hhm... I could not make it work so far. Did I say so?
NP....you can test it
I really tested quite a lot of settings before asking here.

Now I read the text in the link. It is about Windows Server 2003 but I have Windows Server 2008 so it's a bit different on my server. Nevertheless, I did what the link proposed still with no success. That's what I tested now.

1. I disabled "Display Changing Temporary Internet Files and Settings within Group Policy" so that user should be able to modify these values.
2. I disabled "Turn Off Delete Browsing History Functionality" so that users should be able to delete their browsing history
3. I disabled "Disable Configuring History" so that users should be able to change these settings.

Still everything is greyed out!?
 
Now got to user machine and run below command from cmd prompt

gpresult

Now verify, whether the policy you have created is applying at user end or not.

Secondly, check from gpmc console, whether this policy is showing as winning or not.
Secondly, logoff/login back at user end.
I checked again if the policy is applying - it is. As I wrote before, I tested this other internet explorer setting for the forms with success. only the delete browsing story won't work for me...

And of course I do a log off / log on at the user end after changing the gp settings.

What do you mean with "showing as winning"?

Can you give a same try with Computer Configuration.
Well, now it get's really strange. When I took my laptop out of the docking station and put it on another one it suddenly worked. Nothing was greyed out anymore. I logged off again and put it back on the original docking station and still it worked.

Now just as an additional test I logged in on my Windows 7 Test-Client with the same account and there all the options in Deleting Browsing history are still greyed out....??

I am really confused.

Now it seems that the problem is solved on the XP's but not on the windows 7. What should I do regarding the accepted solution?
Its on you to decide, if Expert Exchange is able to help you. From starting we are concentrating on GPO part. Which now you said is fine. Now it comes down to Win 7.

I am guessing, it could be due to OS version issue. I assume you have 64bit.
No. It's 32-bit version. Hhm... strange but ok. I will check that later. I'm glad it's working on our XP clients.

Thank you all for your help!