Link to home
Start Free TrialLog in
Avatar of dibowers
dibowers

asked on

Windows XP machine fails to reconnect to mapped drive on Windows 2003 server

I have a Windows XP sp3 machine that has a mapped drive to a folder on a Windows 2003 server.  The server also has 2 printers attached that are shared by all.  On reboot this particular Win XP machine doesn't reconnect to the mapped drive and isn't allowed access to the printers.  If you double click on the share a log in screen comes up asking for the password (the login id is already filled in)  Once the password is entered all is good until next reboot.  I disconnected the mapped drive and added it again checking the remember password box.  I have also gone to "manage my network passwords" for the user entered the login in information.  When the machine is rebooted the information that was entered in "manage my network passwords" is gone.  For some reason this information is not being saved and is lost at every reboot.  Any help finding a permanent fix for this problem will greatly be appreciated.  
Avatar of TheAnvilGroup
TheAnvilGroup
Flag of United Kingdom of Great Britain and Northern Ireland image

Sounds like the PC isnt connected to the domain correctly. I would remove it from the domain. (make sure you know the local password first) delete the computer account (making sure you know the OU it was stored in) then re add the computer to the domain.
Avatar of dibowers
dibowers

ASKER

The office is running as a workgroup in a peer to peer setting
Is the XP PC the Professional edition or Home edition? Ive seen in the past Home edition versions connected to a network share this way. If that is the case, disconnect the share, make the workgroup name the same as your domain name and create the user within active directory. re-map the share with the new user credentials and you should be all set.
Just caught your post. Create a user account on the PC that is acting as the 'server' and use those same credentials to map your share. remember to tick the option to remember your credentials.
ASKER CERTIFIED SOLUTION
Avatar of rabindrajha
rabindrajha
Flag of India image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
you can make a bat file thats includ the username and password
put it in the startup on the pc every logon it will map the drive and give access to other pc.
Danny: Running XP Professional sp3.  I'm not sure I know what you mean by "Create a user account on the PC that is acting as the 'server' and use those same credentials to map your share"

Rabindrajah - I will use your suggestion as a last resort bc not real keen on having password visible but it will be better than nothing...
Are you definitely running a server based network here? If you have a 2003 server you would most likely be using Active Directory within a domain, the pc would be joined to that domain and you would map a network drive logged on with the credentials of an active directory user account.

If you run a P2P workgroup, the PC or server that is hosting the folder would need to have a user account created for say 'user a' and the pc that is connecting to the folder would also need an account for 'user a' with the same credentials (username and password)

hope that helps a little
Definetely P2P workgroup.  The box running 2003 server has a user account and password - no active directory or domain setup.  When setting up the mapped folder on the box running XP Pro, I first have to connect to the box running 2003 server using it's login creditials and I check the box that says remember password.  I can then map a drive to the box running 2003 server and check reconnect at log in.  However after a reboot it doesn't reconnect automactically at log in until I enter the password for the box running 2003 server.  Hope this makes sense...
Thats makes sense, is the XP pro PC in the same workgroup as the server?

Something doesn't quite match here. I'd say that the workgroup isnt the same or that you will have to use the 'connect using different credentials' method. If you were to map the drive with a user account that matches that of the server (which im guessing your not) everything would work fine.

Try to map the drive using the 'connect using different credentials' method. Enter the user account for the server when doing so and make sure you check re-connect at logon and remember my credentials.
Yes definetely the same workgroup.  I will trying doing as you suggest but it will be lunchtime before I can get access to that machine again.  I will keep you updated.
Sorry to say that this didn't work either.  Upon reboot the drive was no longer connected.  If if click on the mapped drive it asks for the password after entering the password the drive is reconnected.  I tried creating the net use batch file and that doesn't seem to work either.  I saw the batch file run/flash on the screen during set up but the drive was still not reconnected.  it is possible though that I don't have the batch file written correctly.
you might be putting the username instead of computername\username
i am not sure, whether it will work for you or not you may give a try... i assume that your all system in workgroup, so you are able to browse all the system on server system. now go to the folder on server system, give the permission like...
first choose location and then choose the particular system, and then it should show the user from that system, add the user in that folder.

hope it should work for you.
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial