Link to home
Create AccountLog in
Avatar of sasllc
sasllcFlag for United States of America

asked on

Having to log in to shared Win 7 computer each time

I have set up a small Win 7 Pro network for the customer.  Computer WS2 has it's C drive shared, where they have some files accesed by other computers.  Then, I have connected Computer WS9 to WS2 and mapped it as drive F.  While I was doing the connection, it required me to log in to WS2, so I did so, using a login name of 'Main' and a password of 'mara'--which is the system login on WS2--and it worked fine.  I also told it to automatically reconnect WS9.

The problem is this: Anytime I reboot WS9, it does not automatically reconnect to WS2.  I can click on the shortcut to "C on WS2", but it makes me login again as 'Main' and 'mara'.  I have repeatedly checked the box saying to remember my credentials, but it doesn't help.

The box actually says something like:  

Windows Security
Enter your password to connect to WS2

It also shows "Domain: WS9"...but of course I'm not using a domain.  This is just a simple file sharing setup with two Win7 computers.

I DID notice that if WS9 is up and running and connected to WS2, and then I reboot WS2, I can still access the WS2 share from WS9 without having to rekey my credentials.  But if I REBOOT WS9, that's when I have to rekey credentials to access WS2.

What am I missing here?  Is there a Win 7 setting I can do on WS2 and/or WS9 to make it remember my credentials?

ASKER CERTIFIED SOLUTION
Avatar of CrowaX
CrowaX
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I didn't take into account which computer is being specified in the login processes, the "domain" as you say. If the above works, that is good. If it wouldn't, replace the second and third line with this line:

net use Z: \\WS2\sharename /user:WS2\Main mara

If that doesnt work, then change the /user:WS2\Main part to  /user:WS9\Main

It depends which computer the actual username is a part of. For example, if you created the username "Main" on WS2, then you would use WS2. If you created it on WS9, then you would use WS9.
Avatar of sasllc

ASKER

I ended up using the first example, lines 1 and 3, and that 'saved the day' while I was on-site, thank you.

Is all this 'normal' with Win 7 Pro networks?  Is there a setting in Win 7 Pro that will prevent the need to log in each time--for the other computers connecting with the shared computer?  

I've seen something on the web about a 'credentials manager' in Win 7 that may address this issue--but I can't tell for sure if it will solve the problem, nor exactly how to use it in a case like this one above.  Any idea?

It's not normal for domain based networks which the logged in user has rights to the computer. It is normal when trying to log onto a computer that your username does not have rights to. I've even seen this in XP which is where my first script came from.

I've never tried the 'credentials manager' before, but I added our computer name and password, and it still prompted for a password when logging in. But the box was different, as it had the credential name already filled in.
Avatar of sasllc

ASKER

One more thought--that I can't easily test at the customer site without taking a chance of messing things up.

What about the idea of adding a user named WS9 on the WS2 computer?  Would doing this make the WS2 computer always think that WS9 was legit--and solve the login credentials problem?  

I would hate to have to add a user on WS2 for each computer that would ever log in, only because the WS2 operator would have to pick from a list of users--and find WS2--when starting up the computer (I assume).  But, if by adding all the user(s) it would negate the need for the batch file in startup, then it might be worth it.

So does this sound workable, and are there any downsides to doing it this way?

I dont think that would be a problem. On my home Media Center computer, I could not access the media for some reason, so I made a second user on there with the same name and password as my computer username and I got access. But I did not use it to map drives. It is certianly worth a shot and seems like it would work.
Avatar of sasllc

ASKER

FYI, I found that my last suggestion did work.  I added a "user" on WS2 for every computer that was going to connect.  The downside, of course, is that ALL the users I set up appear on the WS2 desktop when they log in in the morning.