Solved

ASA 5505 Version 8.3 and ASDM version 6.3 showing NO ROUTE TO HOST on PING

Posted on 2011-02-16
21
2,810 Views
Last Modified: 2012-05-11
Hi Guys,

I am totally new to Cisco and have had help in setting up a new Cisco ASA 5005 from another post in EE and have had it checked by a Cisco guy who has confirmed it looks ok with the Rules etc however we still have no Internet connection.
I have tried to PING the Google DNS servers of 8.8.8.8 but no matter which Interface i select (we have Inside, outsdie and DMZ) it just shows 'No route to host 8.8.8.8' Success rate is 0 percent (0/1)
Is there anything i need to set up on the Interfaces at all ?

Thanks
0
Comment
Question by:Netexperts
  • 9
  • 8
  • 3
  • +1
21 Comments
 
LVL 1

Author Comment

by:Netexperts
ID: 34907649
Just to add that i can ping the WAN IP successfully from the Cisco if that helps
0
 
LVL 18

Expert Comment

by:jmeggers
ID: 34908028
Have you configured a default route on the ASA?

route outside 0.0.0.0 0.0.0.0 <ISP address>
0
 
LVL 1

Author Comment

by:Netexperts
ID: 34908075
I've just added a static route as:
Interface Outside
IP Address 0.0.0.0
Netmask 0.0.0.0
Gateway (WAN IP)
Metric 1  

and it now doesn't show the 'No route...' error although now just shows
 'Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
  ?????
Success rate is 0 percent (0/5)

0
 
LVL 18

Expert Comment

by:jmeggers
ID: 34908197
ICMP is not stateful and the ASA may not be allowing replies in.  Configure "icmp permit any Outside" to allow external hosts to ping the ASA.  You can also enable application inspection of the ICMP traffic by adding ICMP to the inspect list in the global policy at the bottom of the CLI config.
0
 
LVL 18

Expert Comment

by:jmeggers
ID: 34908266
Just checked my ASA config.  I have the policy inspection configured but not the 'icmp permit any outside' and I can ping Google DNS.  Try adding the application inspection:

policy-map global_policy
 class inspection_default
  inspect icmp
0
 
LVL 57

Expert Comment

by:Pete Long
ID: 34908504
>> have the policy inspection configured but not the 'icmp permit any outside'

ICMP is allowed for connected networks by default:)

do you get the same result from ping 4.2.2.2 that's what I usually test with?

http://www.petenetlive.com/KB/Article/0000351.htm


Pete
0
 
LVL 1

Author Comment

by:Netexperts
ID: 34908570
Can you give me the command to add the application inspection ?
0
 
LVL 1

Expert Comment

by:alex_firewall_guy
ID: 34916000
policy-map global_policy
 class inspection_default
  inspect icmp
0
 
LVL 1

Expert Comment

by:alex_firewall_guy
ID: 34916026
We also use the following commands

icmp unreachable rate-limit 1 burst-size 1
icmp permit host 4.2.2.2 internet
icmp permit any echo-reply internet
icmp permit any time-exceeded internet
icmp permit any unreachable internet
icmp deny any internet
icmp permit any inside
0
 
LVL 1

Expert Comment

by:alex_firewall_guy
ID: 34951311
Any luck yet?
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 1

Author Comment

by:Netexperts
ID: 34952784
Still having the same problem but we can do a TCP packet trace on the inside interface from an internal address to an external IP successfully but the same trace on the outside interface fails with the error "(acl-drop) Flow is denied by configured rule"

I've attached a screenshot of the access rules as they show in the ASDM.  Is there anything obviously wrong?

Thanks Access list screenshot
0
 
LVL 1

Expert Comment

by:alex_firewall_guy
ID: 34953113
you have an implied ACL allowing outbound traffic (inside to any less secure interface)

You don't have any explicit ACLs that would allow you to initiate traffic from the outside coming back in.

Are you now able to do the pings that you couldn't do as part of your original post?
0
 
LVL 1

Author Comment

by:Netexperts
ID: 34953285
No, the ping to 8.8.8.8 still fails for all interfaces but now we get a timeout error rather than a no route error.

Sorry this is really basic but how do I setup explicit ACLs to get the traffic coming back in?
0
 
LVL 1

Expert Comment

by:alex_firewall_guy
ID: 34954033
do have access to the CLI on the ASA or are you strictly using ASDM?

If you have CLI access, issue a "show running-config" and capture that output and post it here (remember to remove your passwords and sanitize it before posting it).  Once you have that posted, I should be able to help a little better.  I am concerned that your ping still isn't working.  If you have a default route out your wan interface and you setup the icmp commands like I posted previously, you should be able to ping from the firewall to 8.8.8.8 without any problems.  I took a blank 5505 and slapped an IP on it, a default route on it, the icmp commands like I posted previously and connected it to my internet pipe and can ping from the ASA to 8.8.8.8 so I am confused why that still isn't working for you.  
0
 
LVL 1

Author Comment

by:Netexperts
ID: 34959203
We've got CLI access as well, the running config is below. I'm sure it's something we've already put in that's causing the problem but can't see itfor looking.

ASA Version 8.3(1)
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.200.10 255.255.255.0

interface Vlan2
 nameif outside
 security-level 0
 ip address <Outside IP> 255.255.255.0

interface Vlan5
 nameif dmz
 security-level 50
 ip address 10.10.10.10 255.255.255.252

interface Ethernet0/0
switchport access vlan 2

interface Ethernet0/1

interface Ethernet0/2

interface Ethernet0/3

interface Ethernet0/4

interface Ethernet0/5

interface Ethernet0/6

interface Ethernet0/7

no ftp mode passive
object network obj_any
subnet 0.0.0.0 0.0.0.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp permit host 8.8.8.8 inside
icmp permit any inside
icmp permit any echo-reply outside
icmp permit host 8.8.8.8 outside
icmp permit any time-exceeded outside
icmp permit any unreachable outside
icmp deny any outside
no asdm history enable
arp timeout 14400
nat (inside,outside) source dynamic any interface

object network obj_any
nat (inside,outside) dynamic interface
route outside 0.0.0.0 0.0.0.0 <Outside IP> 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy

http server enable
http 192.168.200.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet 192.168.200.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside

dhcpd address 192.168.200.14-192.168.200.254 inside
dhcpd enable inside

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn

class-map inspection_default
 match default-inspection-traffic

policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect icmp

service-policy global_policy global
prompt hostname context
Cryptochecksum:cf41b3bd093af3edee533d833b512bb7
: end
0
 
LVL 1

Expert Comment

by:alex_firewall_guy
ID: 34960550
as long as by outside ip on this line

route outside 0.0.0.0 0.0.0.0 <Outside IP> 1

you mean the ip of your next hop (your internet edge router, your dsl modem, your cable modem, etc) and not the outside ip of the ASA that you configured for the interface vlan 2 in this section,

interface Vlan2
 nameif outside
 security-level 0
 ip address <Outside IP> 255.255.255.0

you should be able to ping from the ASA to 8.8.8.8 for certain and to just about anything else based upon the icmp you have allowed on your outside interface with these two commands

icmp permit any echo-reply outside
icmp permit host 8.8.8.8 outside

your nat config and the lack of access-list entries and access-groups could cause issues getting traffic through the ASA but those things won't cause you any concern with step one which would be to just get a ping from the ASA to 8.8.8.8 or to any other ip address outside your ASA to succeed.

I applied your same config as you have here on a 5505 using one of my public addresses as the vlan 2 address and using my test bench internet edge router as the destination on the route statement and was able to ping 8.8.8.8.  If you have the default route set right for the next hop, then it may something configured on your upstream (your edge router, your dsl modem, your cable modem, etc) that is causing you these headaches.

Let me know if any of this helps or not and good luck :)

 
0
 
LVL 1

Author Comment

by:Netexperts
ID: 34960851
Thanks Alex,

I had the same IP in the route as on the outside interface, putting the next Ip of the next hop has fixed the ping issue and that part's now working.  

I'll have a look at the NAT and access rules now.
0
 
LVL 1

Accepted Solution

by:
alex_firewall_guy earned 500 total points
ID: 34960892
Glad that worked :)  As long as this thread is getting, you may want to mark this one as completed and start a fresh thread if you need help with the access-lists later on.
0
 
LVL 1

Author Comment

by:Netexperts
ID: 34961632
The new rules are giving web access, looks like we're there.
Thanks for help
0
 
LVL 1

Author Closing Comment

by:Netexperts
ID: 34961647
Alex the firewall guy got us to the root of the problem which helped us fix the general access issues.

Polite, helpful and knowledgeable
0
 
LVL 1

Expert Comment

by:alex_firewall_guy
ID: 34961674
Thanks for the kind words.  I am just glad I was able to help.  :)
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

This article assumes you have at least one Cisco ASA or PIX configured with working internet and a non-dynamic, public, address on the outside interface. If you need instructions on how to enable your device for internet, or basic configuration info…
Have you experienced traffic destined through a Cisco ASA firewall disappears and you do not know if the traffic stops in the firewall or somewhere else? The solution is the capture feature. This feature was released in 6.2(1) and works in all firew…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now