Solved

Outlook 2010 Contacts Autocomplete Issues

Posted on 2011-02-16
17
1,217 Views
Last Modified: 2012-05-11
Hello,

We recently migrated a handful of people using Mozillia Thunderbird email to Exchange Server 2010 and Outlook 2010 and am having troubles with contacts not auto populating when you type a new email.

We exported each thunderbird client email contacts to CSV format. Then , in outlook we used File/Open/Import in outlook 2010 to bring the csv contacts in to Outlook.

The contacts now appear in  the address book under email address/contacts. and they appear when you click "contacts" in the left pane in outlook.

The problem is that the autocomplete for these contacts does not function when I type in the To field when tying an email. Only the local domain contacts in the  global address list appear.

I can manaully select all these contacts and put them in the To field and hit ctrlK to resolve all the names. This will make autocomplete function fine for all contacts until the employee closes outlook.

Once outlook is closed and reopened, the contacts no longer autocomplete.

Any ideas on how to resolve this?
0
Comment
Question by:miteldatanet
17 Comments
 
LVL 6

Expert Comment

by:rnicolaus
Comment Utility
You need to build the NK2 file - where Outlook stores Autocomplete info.  It will build over time.  If you want to edit it - there is a 14 day free trial of a tool here:

http://www.nirsoft.net/utils/outlook_nk2_edit.html

0
 

Author Comment

by:miteldatanet
Comment Utility
rnicolaus

Are you sure about this? I dont think Outlook 2010 stores this information in the NK2 format like 2007 and prior. I believe outlook 2010 stores this info in the "suggested contacts" folder from what I gather.

0
 
LVL 6

Expert Comment

by:rnicolaus
Comment Utility
I last used it on 2010 beta - so I think that it went to production using NK2.
0
 

Author Comment

by:miteldatanet
Comment Utility
One followup.

I was incorrect in saying the global address list populates automatically.

It seems like only emails that have been previously sent will autocomplete.

I noticed the emails that autocomplete do appear in the "suggested contacts" folder.

I manually tried to copy a few contacts from "comtacts" to "sugested contacts" in outlook but that is still a no go. All my contacts appear in "suggested contacts" but only the contacts I have sent emails to will autopopulate.
0
 

Author Comment

by:miteldatanet
Comment Utility
I still believe the NK2 assumption in 2010 is incorrect.

http://www.windowsitpro.com/article/outlook/Outlook-2010-AutoComplete-Cache-and-Suggested-Contacts.aspx

Seached the web for  "outlook 2010 no nk2"   and found many similar resources.
0
 

Author Comment

by:miteldatanet
Comment Utility
I verifed there is no NK2 file in Outlook 2010.

To reiterate, I can create a new email in outlook, enter all of my contacts in the To field, and then close that email without sending. At this point autocomplete functions as I would expect. I can start typing in the To field and my contacts begin to appear.

Until... I close outlook.

The next time I restart, autocomplete only works for individuals I have actually sent an email to. It will not autocomplete my entire contact list like it did before I closed outlook last.
0
 
LVL 6

Expert Comment

by:rnicolaus
Comment Utility
You are correct - sorry for the mislead.  But this is an idea, create the NK2 file with the tool I linked to, then import it - here's how:

http://clintboessen.blogspot.com/2010/05/how-to-import-nk2-files-into-outlook.html
0
 

Author Comment

by:miteldatanet
Comment Utility
I tried this and it is still not functioning. The contacts appear in the "Suggested Contacts" but those suggested contacts do not autocomplete until I manually emaila contact first.

I have been reading it may be related to a Stream_Autocomplete*.dat file, but I am not seeing this file anywhere on the PCs file system.

Thanks again.

0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:miteldatanet
Comment Utility
I am still looking for a resolution on this item.

The same behavior persists. The auto suggesting of email addresses does not work in outlook after the client is closed. It seems to completely clear the cache.

I open outlook and add all my contacts to the To: field in an email.

I then close the email and open a new blank email. I start typing an email address and the auto suggest works at this time.

For example. I type   jd in the TO: field and it suggests

jdoe
jdallas
jdavis
and so on.

However, this is all lost the instant I close outlook. When I open the client again, absolutely no email addresses are auto suggessted.

This behavior is site wide. Outlook 2010 running on XP . Exchange 2010.

Any thoughts? Thanks!
0
 

Author Comment

by:miteldatanet
Comment Utility
I am stumped as why everythin works perfectly as expected as long as outlook stays open. I just need to find out what gets populated when I add addresses to the TO field and why they get cleared out when I close the Outlook client.

Thanks!
0
 
LVL 6

Expert Comment

by:rnicolaus
Comment Utility
Coincidentally just had this issue at a site and this solved it:

On each machine
1. Empty Auto Complete (important step to refresh the Stream_Autocomplete data file)
2. Exit Outlook
3. Restart Outlook
4. Start new message and enter e-mail address
5. Exit Outlook again, and it should work.
0
 

Author Comment

by:miteldatanet
Comment Utility
rnicolaus,

This did not do anything. The same problem persists.

I have seen a few posts regarding the "Stream_Autocomplete" data file but I do not see this file anywhere on any of the computers here.
0
 

Author Comment

by:miteldatanet
Comment Utility
One note. The OS on all PCs is Windows XP
0
 

Accepted Solution

by:
miteldatanet earned 0 total points
Comment Utility
I just uninstalled Office 2010 and installed a copy of Office 2007 on a PC and the autocomplete function works perfectly in 2007.

I am guessing this has to do with 2007 using the .nk2 file for autocompletion.

Now, I just need to find why this does not function in 2010. If it has something to do with the stream_autocomplete file, why does this file not appear on any of my xp machines?

thanks
0
 

Author Closing Comment

by:miteldatanet
Comment Utility
No answer found.
0
 

Expert Comment

by:roarkexpert
Comment Utility
I had this issue.
I would copy all the contacts from the old .NK2 file into the suggested contacts, and then I would put them in the "To:" field of a new email. This worked until I closed Outlook, they would all be gone, even though the contacts were still in "Suggested Contacts". I tried everything.

Then I changed some settings in the IMAP settings (I changed Outgoing SMTP port from 25 to 999), this way when I sent a message, it would get stuck in the Outbox.
Repeat the past steps, copy all the contacts into the "To:" field, hit "Send"! The message to all your contacts is stuck in your Outbox. Delete it.
Now, fix your settings back to the proper settings (change SMTP port back to 25, in my case).
Restart Outlook.

All contacts remain in autocomplete cache!
0
 

Expert Comment

by:paddygreenhood
Comment Utility
the expert comment from roarexpert contains the fix for this and should be the accepted answer.
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now