Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1465
  • Last Modified:

The following organization just rejected your message

Hi, we have a situation where two different companies both have SBS 2007 servers.  

When Company B tries to send to Company A, they get a bounce back (see attached)

Mail in the opposite direction works fine.  

We've disabled spam filters on Company A, and don't see any obvious cause of this problem.  Mail flow was fine up until recently, and no settings have been changed on either server in the last few months, and this problem developed last week.  We even looked at Windows Updates, and don't see any that came down at roughly the time this started.

Thanks for any advice


Delivery has failed to these recipients or distribution lists:

Your message wasn't delivered because of security policies. Microsoft Exchange will not try to redeliver this message for you. Please provide the following diagnostic text to your system administrator.
 
The following organization rejected your message: 
CompanyAServer.CompanyADomain.local

Diagnostic information for administrators:
Generating server: CompanyBServer.CompanyBDomain.local

CompanyAServer.CompanyADomain.local #530 5.7.1 Client was not authenticated ##

Open in new window

0
compsol1993
Asked:
compsol1993
  • 3
  • 3
1 Solution
 
Alan HardistyCo-OwnerCommented:
It sounds like the Anonymous Users Access has been removed from Company A's Windows SBS Internet Receive Connector.

That will cause all manner of mail-flow issues including not receiving any mail!
0
 
compsol1993Author Commented:
Thanks for the response

I checked and Anonymous access is still allowed.

Under Authentication, only TLS is checked.  Is this correct?

Any other thoughts?
0
 
Alan HardistyCo-OwnerCommented:
TLS and Anonymous is all that should be enabled on the default Receive Connector.

Is there another connector configured just for Company B?  If so, the auth / permission groups might not be configured properly.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
compsol1993Author Commented:
No, but this is odd -- after your last email, I created a connector and set it up just for them.  On that one, I matched the auth/permissions settings exactly to the default one, and now mail is flowing fine for everybody.

I'm not sure why or how this could have happened.  Any thoughts?
0
 
Alan HardistyCo-OwnerCommented:
Remotely no!  Please run the following from the Exchange Management Shell and post the output for review (you can hide the incriminating info if you like):

get-receiveconnector | fl
0
 
compsol1993Author Commented:
Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now