Solved

Windows 2003 Server - Default Users Folders and login scirpting

Posted on 2011-02-16
31
340 Views
Last Modified: 2012-05-11
We have added Active Directory to our W2003 Server and all ready created our users. We want to set the default user to another drive for space. In the properties of each user we have pointed each to the correct drive and path per user. We have shared the folder and created each user name, as well.

I have tried a couple of options on login script commands to add the user folder but am having no luck using.....

/profilepath  or   /profilepath

Would it be easier just to map the drive?
What is the correct variable for the username?
How do we make it so the user only has permission to their folder?

Regards
0
Comment
Question by:Harold
  • 17
  • 14
31 Comments
 
LVL 21

Expert Comment

by:snusgubben
ID: 34908945
0
 
LVL 1

Author Comment

by:Harold
ID: 34909187
"Are you talking about home folder?"  If referring to the Home directory as the Users home directory yes.

I thought when you created users intially it created, user directories but I never found all the directories for as many users as I created. Therefore I had created a \\server\users\usernames path for each user.
0
 
LVL 21

Expert Comment

by:snusgubben
ID: 34909308
If you set the share and NTFS permissions correctly, the home folder will be created when you create the user, and set the home folder like \\server\share\%username%. This is described in the link above.

You don't need to create i.e. a logon script mapping to get this folder. AD will handle this.
0
 
LVL 1

Author Comment

by:Harold
ID: 34909408
Does it matter what I call the directory name or does it have to be called HOME?
0
 
LVL 1

Author Comment

by:Harold
ID: 34909590
"You don't need to create i.e. a logon script mapping to get this folder. AD will handle this."  How is the drive going to be mapped so the can set it in a application as the default location to save?
0
 
LVL 21

Expert Comment

by:snusgubben
ID: 34909805
You can call it whatever you want, but it's always nice to give it a describing name.


In the blog entry they used H: as the letter:

http://blogs.technet.com/blogfiles/askds/WindowsLiveWriter/Automaticcreationofuserfoldersforhomero_1018F/image_8.png

When this user logs on, he will get a mapping H:\%username%
0
 
LVL 1

Author Comment

by:Harold
ID: 34916410
The mapping is mapped to.....

H:\Home$      which then shows all the users folders. It does not go to the specific users folder.
0
 
LVL 21

Expert Comment

by:snusgubben
ID: 34916684
Do you have Win7 clients?
0
 
LVL 1

Author Comment

by:Harold
ID: 34916762
Yes. 1, the rest XP Pro.

One thing I have notice, is in the Directory path on the user config. when I put the path \\server\Home$\%UserName%...it always replaces the %username% with the username instead of the leaving variable.
0
 
LVL 21

Expert Comment

by:snusgubben
ID: 34916804
Does it map it like that on both Win 7 and Win XP?

Like you say: \\server\share

and not like it should: \\server\share\%username%


...it always replaces the %username% with the username instead of the leaving variable.

That is normal and correct behavior. %username% is a variable.
0
 
LVL 1

Author Comment

by:Harold
ID: 34917682
I'll try the Windows 7 machine, but the Home directory is not being "mapped" or setup when the user logs in.
0
 
LVL 21

Expert Comment

by:snusgubben
ID: 34918068
On the Win 7, verify in Disc Management (compmgmt.msc) that the letter you sat on the Home folder is not occupied by i.e. a SD card reader or similar.

Do you use a logon script?
0
 
LVL 1

Author Comment

by:Harold
ID: 34918086
No machine XP nor Windows 7 is mapping the user home directory. I'm lost.
0
 
LVL 21

Expert Comment

by:snusgubben
ID: 34918207
You said in http:#34916410

The mapping is mapped to.....

H:\Home$      which then shows all the users folders. It does not go to the specific users folder.


Is this what the users are seeing, or is not the H:\ mapped at all in Explorer?
0
 
LVL 1

Author Comment

by:Harold
ID: 34918465
This is what I get when I issue the following......

Yes it was working and the folder would map to U: and you would see all th euser folders. Now it will not even map.

net use u: /home
System error 53 has occurred.

The network path was not found.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 21

Expert Comment

by:snusgubben
ID: 34918593
Do you use a logon script? If yes, can you copy the content here?
0
 
LVL 1

Author Comment

by:Harold
ID: 34918635
REM:  User drive mappings
net use o: /delete
net use o: \\iconserver\data

rem net use u: /delete
rem /profilepath:\\zippy\profile
0
 
LVL 21

Expert Comment

by:snusgubben
ID: 34918700
So these two lines is the one you use?

net use o: /delete
net use o: \\iconserver\data

(Just make sure this one don't come into play as Win 7 will lose the home mapping. rem net use u: /delete)

Can you post a screenshot of the profile tab of one user?
0
 
LVL 1

Author Comment

by:Harold
ID: 34918811
Yes currently only mapping, as I want the system to handle the home directory mapping, I HOPE!


screenshot.bmp
0
 
LVL 1

Author Comment

by:Harold
ID: 34918971
I also tried typing this in the Address: bar of My Computer and it fails to work either.....

\\server\share\%username%
0
 
LVL 21

Expert Comment

by:snusgubben
ID: 34919035
Do you assign D: to the home folder? Make sure it's not taken by the DVD/CD.

If you logon on with "crichard", "Start" -> Run -> "\\iconserver\Home$\crichard"
any luck with that?
0
 
LVL 1

Author Comment

by:Harold
ID: 34920245
I am not at there office now, but if I log in remotely and issue the command at the server, it opens a window to the folder of the user testing.
0
 
LVL 21

Expert Comment

by:snusgubben
ID: 34920320
Then we can assume permissions is correct.

It looks fishy to assign D: to the home folder. Most computers already have this mapped to their CD/DVD drive. Can you try to change it to i.e

N:

0
 
LVL 1

Author Comment

by:Harold
ID: 34920378
When I was at there office earlier, I had changed the users profile, that I was working with and it made no difference.

Mapped the data drive but no user/Home mapping.
0
 
LVL 1

Author Comment

by:Harold
ID: 34920477
I just added the following to the login.bat file and it works. I would like for it to work the way we have been trying but if it is flaky now, who knows when it my fail.

Unless you have any other ideas, I'll just give you the points, since you have been working with me.

What do you think?
0
 
LVL 21

Expert Comment

by:snusgubben
ID: 34920560
Did you test on both XP and Win 7?

Try making a GPO and link it to a test OU where you place the computer object of the computer you are testing on:

Computer Configuration -> Administrative Templates -> System ->  Logon -> Always wait for the network at computer startup and logon

Set it to Enabled.
0
 
LVL 21

Accepted Solution

by:
snusgubben earned 250 total points
ID: 34920596
Setting this in a logon script may work, but it's not a good solution.

If you i.e.

net use H: /del
net use H: \\server\home$\%username%
net use H: /Home

it might work on XP, but you can see some problems on Win 7.
0
 
LVL 1

Author Comment

by:Harold
ID: 34921170
This I did, with no change...."Computer Configuration -> Administrative Templates -> System ->  Logon -> Always wait for the network at computer startup and logon
Set it to Enabled. "

Then I found where I could do mappings in GPO, but when I try to navigate to the option on my server, it was not there. So then I something else to work, got the DLLs registered and still no option to set mappings in GPO. Then I was really aggravated.

That's when I said h... with it, I'll map the damn thing and be done with it.
0
 
LVL 21

Expert Comment

by:snusgubben
ID: 34921400
hehe...
0
 
LVL 1

Author Comment

by:Harold
ID: 34921465
I have setup the lo gin script and I'll check with the client in the morning. If all goes well, we'll call this even.

Regards
0
 
LVL 1

Author Closing Comment

by:Harold
ID: 35033230
I ended up just using the mapping...
net use H: \\server\home$\%username%

No problems, as of yet.

Regards
0

Featured Post

Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

Join & Write a Comment

Installing a printer using group policy preferences is not that hard let’s take a look at it. First lets open up your group policy console and edit the policy you want to add it to. I recommend creating a new policy for each printer makes it a l…
Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now