Solved

Intel 5500 / 5600 CPU - Always stuck at 1.7 GHz

Posted on 2011-02-16
6
903 Views
Last Modified: 2013-12-10
I have several Dell servers (R410, R710 and R910 models) with some running Windows Server 2003 and other running Windows 2008 Server, all 64 bit.

What I have noticed is that even under heavy application load, the CPU clock speed of each of the cores (I use TMonitor to view) is stuck at just below 1.7GHz, even though the CPUs are rated at 2.13 GHz, and 2.4 GHz + turbo (each machine has 2 CPUs, with some machines having E5620 and other machines having E5506).

I get much better performance from the same exact apps on my older X5160 machines as those CPUs idle at 2.0GHz but immediately ramp up to their rated 3.0GHz speeds when my apps run.

Example: On an X5160 at 3.00 GHz machine processing a  bulk email list to 50,000 recipients finishes processing in one third the time compared to  2.4 GHz E5620 machine which never leaves the 1.7GHz processor idle core speed.

Now, my question: Is there any way to disable the processor idle/sleep modes on these newer Intel E5506 / E5620 chips so that I can have them running at their rated speed?
0
Comment
Question by:gordonlee
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 39

Expert Comment

by:Philip Elder
ID: 34913665
In the BIOS there will be a number of settings such as C3 State. Make sure that they are enabled along with Intel's Turbo Boost settings.

CPUz may be a better tool to check the status of the cores.

Intel also has a utility for this purpose:
http://www.intel.com/p/en_US/support/highlights/processors/toolspiu

Philip
0
 
LVL 55

Accepted Solution

by:
andyalder earned 500 total points
ID: 34915122
Perhaps it's something else that's the bottleneck, for example if you had a 1Gb NIC connection on the old box and a 10Mb NIC on the new ones the job would take longer to process and the CPU wouldn't have to ramp up because it would not have much work to do, similarly the older boxes might have faster disks.

Does perfmon show the CPUs %processor time to be high when running the job?
0
 

Author Comment

by:gordonlee
ID: 34916058
MPECSInc:

Isn't that the issue? The C3 state is the CPU "sleep state" and it allows one or more cores to enter sleep states so that other cores can go into Turbo Boost. But my problem is that I can't get the CPU to even budge from sleep state or even approach their rated, non-turbo speed. (E5506 doesn't support turbo / E5620 does)


andyalder:

Actually, the apps run on RAM Disks. All machines have 1Gb NIC. The older boxes have the same 15K RPM SCSI HDDs.


So these don't seem to be the issue, but thank you both for your replies.

0
The Ultimate Checklist to Optimize Your Website

Websites are getting bigger and complicated by the day. Video, images, custom fonts are all great for showcasing your product/service. But the price to pay in terms of reduced page load times and ultimately, decreased sales, can lead to some difficult decisions about what to cut.

 
LVL 39

Expert Comment

by:Philip Elder
ID: 34918761
Make sure that the BIOS and firmware are up to date on the server board.

The BIOS settings can be tuned to allow or disallow the various CPU features.

Run the Dell diagnostic utilities to make sure that there are no conflicts happening. If dual CPU, if the CPUs are different in their stepping and family all sorts of odd behaviours can be had. Make sure the CPUs are identical.

Philip
0
 
LVL 69

Expert Comment

by:Callandor
ID: 34938846
>Is there any way to disable the processor idle/sleep modes on these newer Intel E5506 / E5620 chips so that I can have them running at their rated speed?

I would recommend resetting the BIOS to get everything into the default state.  You can do this by moving a jumper on the motherboard (usually near the CMOS battery and has three pins with a shorting block) from the Normal position (1-2) to the Clear position (2-3) and then back to Normal.  You can also remove the CMOS battery for 10 min after removing all power.  If your motherboard recognizes your cpu, it should run at the correct speed at default settings.
0
 

Author Closing Comment

by:gordonlee
ID: 35060924
Turns out that the issue is that for some reason it takes a LOT of computation to even budge the processors on these new 5500 series CPUs.
0

Featured Post

Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Moving your enterprise fax infrastructure from in-house fax machines and servers to the cloud makes sense — from both an efficiency and productivity standpoint. But does migrating to a cloud fax solution mean you will no longer be able to send or re…
Or at least that’s the word according to a new blog from Tech Target on AWS’s new Managed Services (MS) offering. According to the blog, AWS is launching their AWS MS program to expedite the adoption of cloud by Fortune 1000 and Global 2000 companie…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
This is my first video review of Microsoft Bookings, I will be doing a part two with a bit more information, but wanted to get this out to you folks.

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question