Link to home
Start Free TrialLog in
Avatar of Carla Romere
Carla RomereFlag for United States of America

asked on

Unknown Database Connector Error

I have several reports that just randomly seem to break with the "Unknown Dtabase Connector Error". I think I've found the problem, but can't figure out how to resolve it.

The ODBC connector on every machine that modifies this report, should be named Ross_Data. On all the machines I use, it is correct. However, I discovered this morning when I opened a report after another user opened it, the ODBC is looking for ROSS_DATA now.

I've tried logging off the server, rebooting my PC but I can't get it to look for Ross_Data instead of ROSS_DATA. I also tried resetting the datasource location. All to no avail. How can I get it to forget ROSS_DATA exists and force it to look at Ross_Data?
Avatar of Mike McCracken
Mike McCracken

How are you running the reports?

If you can open the report in Crystal you could use the SET DATASOURCE LOCATION to redirect it to the correct ODBC.  You might need to change that one users ODBC

mlmcc
Avatar of Carla Romere

ASKER

I have looked at every machine that I know of that has ever opened this report and they are all correctly set to Ross_Data. I have used the set datasource location twice now and it *looks* like it takes, but then as soon as I go to preview the report, it goes back to ROSS_DATA and blows up again.
Ok I got the ODBC connector corrected finally back to Ross_Data, but I'm still getting the Unknown Database Connector Error.
I don't know.  I don't use ODBC connections very often and most of the time when I do they report is being run on 1 machine so we change it on that machine and don't have issues.

mlmcc
ASKER CERTIFIED SOLUTION
Avatar of Carla Romere
Carla Romere
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
I didn't do anything to resolve the issue it just seemed to resolve on its own.