OO SCalsc Conditional formatting is not working as anticipated.

I have these cells in row 69:
   W         X     Y        Z
-44.21      0      0      -42.34

I want to conditionally format the cell in W69 if Z69 < 0 AND W69 < Z69

This formula works:
(Z69 < 0) AND (W69 < Z69)

 But when I copy the cell 'W69' (CTRL+C) and then paste special to cell W70 (ALT+SHIFT+V and only select 'Formats" the cell is not highlighted even through the condition is true. I can double check that the paste was valid (Format-Cond. Formatting) and the formula is correct.

What is going on? Why is the formula not working?

LVL 1
John_2357Asked:
Who is Participating?
 
ltlbearand3Connect With a Mentor Commented:
John_2357,

You might look at upgrading OOo as the current version is 3.3, but I doubt that will help.  It is hard to say what is causing you problem without looking at the spreadsheet.  It could be a Macro, hidden value, etc.  It will depend on what all you have on that sheet on how you want to proceed.  One suggestion is to open up a new Calc document.  Then in your all document, click on any cell and press Cntrl-A (For Select All) and then Cntrl-C (For copy).  In the new document select past special (Cntrl-Shft-V which is what I assume you are doing and not Alt-Shft-V as you listed above since that opens the view menu).  Then in the list Text, Number, Date & time, Formulas.  Now add your conditional formatting back into W69 and then copy to the other cells you need.  

Another suggestion is to right click on cell W70 and click default formatting.  Then copy W69 and paste special into W70.

-Bear
0
 
ltlbearand3Commented:
Those steps should work and are working on my copy of CALC.  I am wondering if the formula is not working on line 70.  Can you post the values in Cells W & Z on line 70?  Or maybe even post your sheet?  What version of OOo Calc are you using?

-Bear
0
 
John_2357Author Commented:
W70 is   -23.1 and Z70 is -18.34
I inserted another new worksheet after the sheet causing the problem, it seems that the new sheet inherited the formatting from the previous sheet. I typed in some random numbers so that the formula would  be true and agaIN ROW 69 WORKS AND ROW 70 does not. The spreadsheet is too big to post, I am sorry.

Is there a setting that can be un-checked so that new sheets do not inherit the previous sheet formats/formulas etc?  Is there or can there be hidden formulas/formats that are somehow over-riding the ones I set? I am using OpenOffice.org 3.1.1  OOO310m19 (Build:9420)

Thank you for your help.
0
 
John_2357Author Commented:
Creating a new workbook solved the problem. I would like to know why the old workbook generated the headaches. However I do not have the time to worry about it. Thank you for your help.
0
 
ltlbearand3Commented:
I glad you got it fixed.  The only way to determine the original problem is for us to look at the sheet.  By the way, before closing questions, I suggest you look at the following article to get a feel for use of EE's grading system.  
http://www.experts-exchange.com/Community_Support/General/A_2786-How-do-I-close-a-question-at-Experts-Exchange.html?sfQueryTermInfo=1+30+answer+rate

-Bear
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.