Link to home
Start Free TrialLog in
Avatar of lapucca
lapucca

asked on

Error connecting to my local sql express 2005

I'm on xp, asp.net 3.5.  Error screen attached.  How to fix this?
Thanks.
sqlerr.JPG
Avatar of lapucca
lapucca

ASKER

Here are my connection strings.
  <add name="core" connectionString="Data Source=.\SQLEXPRESS;user id=xxx;password=yyy;Initial Catalog=tecore_Core"/>
  <add name="master" connectionString="Data Source=.\SQLEXPRESS;user id=xxx;password=yyy;Initial Catalog=tecore_Master"/>
  <add name="web" connectionString="Data Source=.\SQLEXPRESS;user id=xxx;password=yyy;Initial Catalog=tecore_Web"/>  
try using 'local' instead of the . on my local installs I actually have named installs such as SQL2005, SQL2008, etc... When you installed did you install it as "default"? If so then simply use "Data Source=local;..."
Avatar of lapucca

ASKER

The original connection string used localhost.  I changed it to local and still getting the same error screen.  Thank you.
ASKER CERTIFIED SOLUTION
Avatar of BurnieP
BurnieP
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of lapucca

ASKER

Apparently I instlled it as a named instance.  I had to put macineName\sqlName in connection string to make it work.  It won't work with local when it's a named instance.  Thank you.