Link to home
Start Free TrialLog in
Avatar of james_axton

asked on

Unable to delete files with improper characters in XP

We've got a machine with a couple of files that have a dot in the name that are unable to be deleted.  We've tried all the variations of "\\?\" found in this article and its comments.  We also tried booting into UBCD and attempting a delete that way, and chkdsk also passed with no errors.  So far everything has failed.  

Any attempt to delete or rename the file is met with a "cannot read from the source file or disk" message.  This problem clearly stems from an improper file name but we can't figure out how to get rid of them.  Any help would be appreciated.  
Avatar of rabindrajha
Flag of India image

use ubuntu live cd, boot the machine and delete....
have you tried deleting them from dos using their 8.3 filename equivalent?
Avatar of james_axton


Richard2k4, yes.  We ran dir /x /a against it and tried del and del "\\?\" with that.  Neither worked.

Cause 5 or 6 I think is your issue.
Avatar of ☠ MASQ ☠
☠ MASQ ☠

Link to home
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
MASQUERAID, the files are locked by anything.  Will that still get them out?
Do you mean "aren't"?
I've not had it fail on me yet.  If it doesn't do it directly it adds a right-click context menu which you can use which avoids explorer complaining about file naming errors.
Yes I left a word out, sorry.  We'll give Unlocker a try in an hour or so and I'll report back here.
Safe Mode and Unlocker did the trick where numerous variations of "\\?\" failed.  Thank you!