Solved

Port 8080 Not Listening

Posted on 2011-02-16
9
2,519 Views
Last Modified: 2012-06-27
I downloaded Tomcat 6, unzipped it, set JAVA_HOME and ran the startup.bat on a XP machine.

Oops! Google Chrome could not connect to localhost:8080
Did you mean: localhost-­8080.­com

I then went into Windows Firewall and made 8080 an exception, but it made no difference.
Running a netstat -a | grep 8080 comes back with only a prompt.
What do I need to do to start 8080 to listening?
0
Comment
Question by:xoxomos
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
9 Comments
 
LVL 9

Expert Comment

by:meko72
ID: 34910643
If this is an webserver for the outside to see make sure you have port 8080 opened on your router or port fowarded to your server's IP address.
0
 

Author Comment

by:xoxomos
ID: 34912057
If I understand you correctly, right now I would be content with just http://localhost:8080
0
 

Author Comment

by:xoxomos
ID: 34912063
I looked in the server.xml

 <Connector port="2011" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8443" />
    <!-- A "Connector" using the shared thread pool-->
    <!--
    <Connector executor="tomcatThreadPool"
               port="8080" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8443" />

If I use http://localhost:2011, everything comes up fine.
0
Building an interactive eFuture classroom

Watch and learn how ATEN provided a total control system solution including seamless switching matrix switch, HDBaseT extenders, PDU, lighting control to build an interactive eFuture classroom.

 

Author Comment

by:xoxomos
ID: 34912065
But the readme said use localhost:8080.
0
 

Author Comment

by:xoxomos
ID: 34912517
Actually only the index page comes up.  None of the links ever arrive anywhere.
0
 
LVL 7

Expert Comment

by:techsathish
ID: 34913859
<Connector port="2011" protocol="HTTP/1.1"
               connectionTimeout="20000"
               redirectPort="8443" />

Change port no. to 8080 and then try it..
0
 

Author Comment

by:xoxomos
ID: 34918193
Yes, i tried that.  The index.htm appears, but none of the links work after that.  I loaded Tomcat 5.5 on another machine and it works as the RUNNING.txt states without any bit twiddling at all.
0
 

Accepted Solution

by:
xoxomos earned 0 total points
ID: 35048040
I downloaded a fresh Tomcat6 after which initial install proceeded as expected.
0
 

Author Closing Comment

by:xoxomos
ID: 35106975
Install worked after fresh download.
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question