Solved

Cisco 861 Router, anyone have a sample config to get me started

Posted on 2011-02-16
14
1,763 Views
Last Modified: 2016-06-02
We have 2 networks on site we want to be able to talk to each other.
 Wan side = 172.174.1.0  and Lan side = 10.0.0.0

We have 2 networks that I want to put this router between so I can communicate between.

Does anyoune have a config using nat that I can use for a starting point.

Thanks
0
Comment
Question by:ParadiseFound
  • 4
  • 4
  • 3
  • +2
14 Comments
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 34910567
Hi,

please show the blank config....
and I tell you the required commands!

Best regards,
Istvan
0
 
LVL 4

Expert Comment

by:RobertParten
ID: 34910590
Can you clarify a little more?


WAN (172.174.1.0)  <=========>  [[[((((())))]]] <=======>   LAN (10.0.0.0) - Comptuers behind here

Are you just simply stating that you are working with two groups of computers (subnets) and want to put a router between them to they can communicate back and forth? Are you going to need a default route to the Internet?
0
 
LVL 3

Accepted Solution

by:
Rick_at_ptscinti earned 200 total points
ID: 34910875
interface Fastethernet 4
    ip nat outside

interface Vlan 1
    ip nat inside

ip access-list extended matchall
 permit ip any any

ip nat source list matchall interface Fastethernet 4 overload


(this assumes FastEthernet 4 is public and Vlan 1 is private)
0
 
LVL 34

Assisted Solution

by:Istvan Kalmar
Istvan Kalmar earned 100 total points
ID: 34911043
0
 

Author Comment

by:ParadiseFound
ID: 34911874
Robert - Yes we are just connecting 2 private networks together. Our internet goes to out pix and out.
0
 
LVL 3

Expert Comment

by:Rick_at_ptscinti
ID: 34912191
You asked for an example with NAT, but if you are connecting 2 private networks then you typically wouldn't use NAT.

What kind of telecomm connection do you have between the two sites?  Which is end has the PIX on it?  

If you are connecting with MPLS the config will be real basic, but you will need a couple simple route statements to direct the traffic.
0
 

Author Comment

by:ParadiseFound
ID: 34912615
The 2 networks are both local (actually 1 is on vlan 1001 and the other is vlan 10.

I have 2 switch ports set one with each vlan.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 3

Expert Comment

by:Rick_at_ptscinti
ID: 34915881
The router is always aware of locally connected networks, so you should be able to talk between them without doing anything else.  

You would need to assign the vlan to a port but it sound like you have already done this.  Do you have IP addresses set on the vlan interface?

interface vlan 1001
   ip address 172.174.1.1 255.255.255.0
   no shutdown

interface vlan 10
   ip address 10.0.0.1 255.255.255.0
   no shutdown

on your switch ports:

interface Fastethernet 1
   switchport access vlan 1
   no shutdown

0
 
LVL 4

Assisted Solution

by:RobertParten
RobertParten earned 200 total points
ID: 34915970
Sounds like you need a router on a stick to route between these two subnets

I assume dot1q encapsulation

interface fa 0/0.10
encapsulation dot1q 10
ip address 10.0.0.2 255.255.255.0


interface fa 0/0.11
encapsulation do1q 1001
ip address 172.174.1.2 255.255.255.0

Essentially you have ONE link to the routers FA interface 0/0 and that will now have forwarding logic to route between VLAN's on the same physical connection.

Good luck.
0
 
LVL 3

Expert Comment

by:Rick_at_ptscinti
ID: 34916242
Robert's comment is true if you are using a single interface on the router.  Since this is an 861 you should have enough ports to put the different networks on different physical ports.

If you are trying to have both networks on the same switching equipment then you will need to have the vlans built on the switches and trunking enabled on the uplink to the router.
0
 
LVL 4

Expert Comment

by:RobertParten
ID: 34916299
As Rick stated, setup your VLANS on the switches and for each interface you want to use setup trunking. Routers DO NOT negotiate trunking so you will have to set the switchport interface on the switch to:

switchport mode trunk

For each interface apply the same commands as above replacing the interface numbers with the correct ones from your 861.
0
 
LVL 4

Expert Comment

by:RobertParten
ID: 34916321
0
 

Author Comment

by:ParadiseFound
ID: 34916587
Thanks guys, I will try this after lunch and see what happens.
0
 

Expert Comment

by:Murty Kodukula
ID: 41632424
i am also having similar issue.  i have two vlans configured with vlan 1 as 10.50.42.0 and vlan 2 as197.100.100.0 and my wan side is 192.168.175.0.  i would like to access the systems in vlan2  through vlan1's ip.  that is the requirement of my software.  can any one send me the sample config.

thaks in advance
Murty
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
How to configure AT&T Netgate with Sonicwall Firewall 24 44
Multicast in a layer 2 to layer 3 migration 1 52
EIGRP Multicast vs Unicast 7 57
iPad Won't Connect 16 76
While it is possible to put two routes in place with the secondary having a higher metric, this may not always work. In the event of a failure that does not bring down the physical interface on the router the primary route is not removed. There is a…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now