Solved

Workaround Linking a spreadsheet with a alphanumeric field

Posted on 2011-02-16
14
236 Views
Last Modified: 2012-06-27
Hello,  We really would like to link a spreadsheet but because of Microsoft default rules, I think the only workaround is to import the spreadsheet.  Do you have a solution that is transparent to the user?  FYI...I prefer linking since that spreadsheet has many changes and I don't want to write code every month.
0
Comment
Question by:CFMI
  • 6
  • 5
  • 3
14 Comments
 
LVL 11

Expert Comment

by:RgGray3
ID: 34910751
I am not sure if linking to a spreadsheet is an orphaned feature in 2007...  but I do it in 2003.

Does it need to be linked for edit/update or for viewing only?
0
 
LVL 1

Author Comment

by:CFMI
ID: 34910812
The spreadsheet is xlsx (2007); viewing only but transferring the data and sometimes it reveals #NUM...
0
 
LVL 7

Expert Comment

by:andymacf
ID: 34910942
You can link to a spreadsheet by clicking the External Data, Import, More.  Select ODBC Database, Link to the datasource by creating a linked table.  The click the Machine Data Source tab, and create a new link to your excel spreadsheet.  This works really well, I'm assuming this is what you are trying to do.
0
 
LVL 7

Expert Comment

by:andymacf
ID: 34910951
I meant to add, that this is completely transparent to users
0
 
LVL 11

Expert Comment

by:RgGray3
ID: 34911648
If forget If it is displaying #NUM indicates a non numeric data in an expected numeric field... or...

Make the field bigger... wider...

I am NOT a big Excel user but I believe that is what happens when it can not display the WHOLE value...    rather than give you a partial number it puts in #NUM

0
 
LVL 11

Expert Comment

by:RgGray3
ID: 34911670
err....   I forget not If forget...   Fat & sloppy fingers
0
 
LVL 1

Author Comment

by:CFMI
ID: 34915654
Hello, I tried to follow the instructions and I have accomplished this before linking SQL Server tables but for an Excel spreadsheet, I receive an error message:  You cannot use ODBC to Import from, Export to, or Link an external Microsoft  Office Access or ISAM database table to your database.  Hopefully, I am missing a step?
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 7

Expert Comment

by:andymacf
ID: 34915960
Dear CFMI
Apologies I have misguided you. The correct way to link is as follow:
In the Import area, click Excel, when the new window opens browse for your file then select 'Link to the data source .......'. You will then be asked what sheets you want to link to and follow the prompts. Your linked table will then appear at the bottom of the table view screen and can be used as a source
Andy
0
 
LVL 1

Author Comment

by:CFMI
ID: 34916314
Hello, I can import which allows me to modify the field definitions but when you LINK, a screen appears asking about Headers then a screen appears to Name the file - there isn't a Link option to modify field definitions.  Please HELP...
0
 
LVL 1

Author Comment

by:CFMI
ID: 34916499
Hello, my current workaround is to have the user insert a new column and use this statement:  =TEXT(L2,"00000") to modify Alphanumeric fields to text since Linking believes it is a Numeric field.
However, the user always needs to do this action and I was hoping for a better automated way.
Please HELP...
0
 
LVL 7

Expert Comment

by:andymacf
ID: 34920572
Are you able to post a stripped down version of both of your files so that we can see what you are trying to achieve
0
 
LVL 1

Author Comment

by:CFMI
ID: 34926574
Hello,  I really appreciate your help with the attached spreadsheet.
Beeline-Milestone-Invoice.xls
0
 
LVL 7

Accepted Solution

by:
andymacf earned 500 total points
ID: 34927982
I think I have managed to get this to work.

What you need to do is highlight your column, 'Cost Center', then right click somewhere on the highlighted area and go to 'Format Cells', then choose 'text'. Click 'OK'.  Now create your link in access and it should work fine.

Cheers
Andy
0
 
LVL 1

Author Closing Comment

by:CFMI
ID: 34950975
Perfect, you are a genius!!!
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
VBA pass value between two fields different tables 10 38
Sub Reports 8 23
Search Form not Querying 2 11
Find missing numbers in Access Table PrimaryKey 9 12
When you are entering numbers in a speadsheet, and don't remember what 6×7 is, you just type “=6*7" instead. It works in every cell! This is not so in Access. To enter the elusive 42 in a text box, you have to find a calculator, and then copy the re…
In Debugging – Part 1, you learned the basics of the debugging process. You learned how to avoid bugs, as well as how to utilize the Immediate window in the debugging process. This article takes things to the next level by showing you how you can us…
In Microsoft Access, learn how to “cascade” or have the displayed data of one combo control depend upon what’s entered in another. Base the dependent combo on a query for its row source: Add a reference to the first combo on the form as criteria i…
In Microsoft Access, learn different ways of passing a string value within a string argument. Also learn what a “Type Mis-match” error is about.

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now