• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 958
  • Last Modified:

Auth.net XML HTTPS post error

I'm trying to make a https xml post on a newly created server. I have this script working on the original server, however it errors out on the new one.

I'm thinking it has something to do with the presence of an SSL cert assoicated with the box. However I'm not sure, since that type of server administration is a bit new to me.

Here is the error I'm getting.

msxml3.dll error '80072f0d'

The certificate authority is invalid or incorrect

/catalogs/object_testing/authorizeNetSCCtesting.asp, line 152

            xmlhttp.open "POST",sURL,false
            
            xmlhttp.setRequestHeader "Content-Type", "application/x-www-form-urlencoded"
            xmlhttp.send sPost <---- error here

and here is the url i'm trying to post to ...
sURL = "https://certification.authorize.net/gateway/transact.dll"
0
rdunn5162
Asked:
rdunn5162
  • 3
3 Solutions
 
BigRatCommented:
I have had problems with msxml3 and https. I downloaded the 6.0 version of the dll and the problem went away.

HTH
0
 
rdunn5162Author Commented:
Here is the link to the files BigRat is saying to download just to help anyone else reading this.

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=993c0bcf-3bcf-4009-be21-27e85e1857b1

I will get back on whether this resolves my issue.
0
 
rdunn5162Author Commented:
I got the issue resolved internally. The problem was related to the security related to the virtual environment we have moved the system to.
0
 
rdunn5162Author Commented:
Internal problem
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now