Link to home
Create AccountLog in
Avatar of RRafuls
RRafulsFlag for United States of America

asked on

Toshiba bios password

I have a laptop my friends asked me to fix. It asks for a boot/bios password. They did not set it. It is a known issue by Toshiba. They have a Satellite S215-S7444. It appears to be this problem with the bios.

http://www.techsupportforum.com/forums/f108/toshiba-laptops-password-problem-364309.html

They released a patch, friends didnt apply it, and extended the warranty to the end of 2010. It says that it can be fixed in a day at a service center with-out any parts.

I have already opened the computer and removed (desoldered) the battery and it DID reset the bios but it did NOT remove the password.

I was wondering if there was anything else I could try.

Avatar of sevlahpt
sevlahpt
Flag of Portugal image

Check if that computer has TPM.
If it does, the password is in TPM, and you can only remove the password by removing the TPM Chip, wich is not easy.
If its only a BIOS password, its very strange that you get battery off and still keeps it, so just call Toshiba and try to get some tip from them.
Hope it helps.
Unless there was a jumper on the board or perhaps a circuit to "bridge" to close it I am unsure.
Avatar of Mattrw
Mattrw

Hi you will need to flash the BIOS with the latest release of Toshiba's BIOS compatible with your particular model.  This will not affect the O/S of the files and folders on the Laptop, but you will need burning software / facilities on the computer.

1.  Download the self extracting BIOS update from this link:  http://bit.ly/hc9CEe

2.  Select Downloads from top left.  Select All Catergories and refine to BIOS.


3.  Click the link and Download Now.


4.  Double click the downloaded file and let it self extract to a new folder.


5. A window will pop-up asking you to select method of installation.  Select the top one CD-ROM.  Your burning software should launch to create the image to burn the files to CD.

6.  Boot the Laptop with the CD loaded and let it boot to CD-ROM to flash (update) the BIOS.   User generated image User generated image User generated image
Let me know how you get on.

Original Link:  http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=SB&os=&category=&moid=1852729&rpn=PSAFGU&modelFilter=A215-S7444&selCategory=2756709&selFamily=1073768663
Avatar of RRafuls

ASKER

According to what I have found, It is stored in EEPROM with the bios so the password remains valid even if the battery is removed. I know there is a way to do it as Toshiba themselves said it can be done in a day with no parts. they just dont say how.
Avatar of RRafuls

ASKER

You cannot boot the computer. How can I update the bios?
You have tried the password

Toshiba

right?
Long shot as well, press and hold down key as you power up the system?
Avatar of RRafuls

ASKER

I tried booting with left shift key in and toshiba, Toshiba and TOSHIBA as the PW. no dice.
The only things i imagine Toshiba can do is:
1 - Enter master password (backdoor) and you get a clean BIOS or
2 - Clear eeprom, and that you can do with UV light after desoldering it.
Still i dont recomend it, and i check in Toshiba forums, that Toshiba actually solves this problems as if the laptop was in warranty.
My opinion, just call their support line and try to get it fixed as it is a Vendor Fault.
Avatar of RRafuls

ASKER

I am going to try calling them tonight and see if I can get anywhere with them.
Avatar of nobus
what Toshiba says :
DISABLE/CLEAR
Not Registered This is the default when the system is shipped. The following procedure will disable/clear a BIOS password which will allow the user to cold boot or reset without the requirement of a Password:  
Power up computer from off condition with ESC key depressed. The unit will prompt "Password = " 
Enter the correct password, press ENTER. Unit will display "Valid password entered, system is now starting up. Check system. Then press (F1) key"  
Press the F1 key. This will put the unit into the BIOS setup screen.  
Using the arrow or tab keys move to the password field, highlight REGISTERED.  
Press the SPACEBAR, enter the correct password, press ENTER. At this time
the password field will change to NOT REGISTERED  
 
from :http://askiris.toshiba.com/ToshibaTCL/search.do;jsessionid=A8083D54D2C171C9355740FA6C2A02ED?cmd=displayKC&docType=kc&externalId=http--web1toshibaca-support-TechSupport-TSBs-ALL--TSB000593htm&sliceId=&dialogID=114474125&stateId=1%200%20114472796
Avatar of RRafuls

ASKER

That only works if you know/entered the password yourself. They did not. it was an error in the bios that the computer thinks there is one.
ASKER CERTIFIED SOLUTION
Avatar of RRafuls
RRafuls
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Nice one. As i said, usually Toshiba fix this kind of problems with no charge, because they know its their fault!
Avatar of RRafuls

ASKER

That's why I own/ recommend them.
well  - if they caused the problem, the least they can do is fix it...
Avatar of RRafuls

ASKER

Agreed
Avatar of RRafuls

ASKER

The manufacturer fixed after I pursuaded them