Solved

Subversion: How to get data into the repo?

Posted on 2011-02-16
5
436 Views
Last Modified: 2013-11-25
I have setup a subversion server (Linux... public server). I have done the initial svnadmin create /var/svn/repos to create the root of the repos.

I have a set of code that lives on my Windows machine, that I would like to upload as revision 1 to the svn server.

I have the gnu version of svn for windows installed, so I have all the command line functions.

How do I upload, from my Windows machine, the initial version of this code base?
0
Comment
Question by:DrDamnit
  • 3
  • 2
5 Comments
 
LVL 9

Expert Comment

by:AriMc
ID: 34911757
I'd highly recommend using TortoiseSVN on Windows (http://tortoisesvn.tigris.org/), but for the command line version this should work:

- CD to your code directory in a command prompt
- Issue command "svn add mynewfile"
- Issue command "svn commit mynewfile"

0
 
LVL 32

Author Comment

by:DrDamnit
ID: 34912026
I believe that is what I downloaded. It ended up being frm Sourceforge, right? I want the one that acts and works identical to the linux version. What I have seems to do the trick.

Here's as far as I have gotten.

I created the repo called eiscp. No problem there. I configured svnserve (passwd file and svnserve.conf inside the repo).

No, from the windows box, I get this:
C:\www\clients>svn import . svn://svn.mydomain.com/eiscp -m "First Import"
Authentication realm: <svn://svn.mydomain.com:3690> 0d9941bf-a383-48b6-92a5-de7a0f9c2570
Password for 'michael': *********
Authentication realm: <svn://svn.mydomain.com:3690> 0d9941bf-a383-48b6-92a5-de7a0f9c2570

What am I doing wrong here?

0
 
LVL 32

Author Comment

by:DrDamnit
ID: 34912036
Sorry... hit submit too quickly.

It doesn't accept my user pass, even though it is clearly (and properly) setup in the passwd file under the repo.
0
 
LVL 9

Accepted Solution

by:
AriMc earned 500 total points
ID: 34912098
Ok, sounds like your SVN-server is responding and attempting to do the thing. Looks weird assuming your passwd and svnserve.conf are correct. Did you also give yourself permissions in the authz configuration file?

You could also try the command line options;

   --username USER
   --password PASS


0
 
LVL 32

Author Comment

by:DrDamnit
ID: 34912274
OK... a little more progress....

I changed my svnserve.conf file to this:
[general]
anon-access = write
auth-access = write

and ran:

svn import . svn://svn.mydomain.com/eiscp -m "First Import"

That worked.

Then I started to give you copious amounts of information and realized I had mispelled my username in svnserve.conf. It appears to be all good now.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When working in a large software development team, whether you have many developers working on the same projects, or your project is linked to other projects; it is very important that developers regularly perform "get latest" to ensure that the cha…
Article by: gr8gonzo
Git can be a complicated version control system for beginners, but it definitely is one of the best ones out there. Since this article assumes that you're starting at square one, it will skip over things that Git -can- do and will focus on the typic…

679 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question