Solved

Unable to remove ISA 2004 Firewall Client from Windows 7 Pro x64

Posted on 2011-02-16
14
1,414 Views
Last Modified: 2012-05-11
Installed ISA Firewall Client from MS KB 929556 on Windows 7 Pro x64. Things fine at first. I suspected a problem, so I want to uninstall, but uninstaller gives me message, "Firewall Client cannot be installed on computers running a 64-bit Windows operating system." Is there a documented way to manually uninistall I haven't found yet?
0
Comment
Question by:ByteCafeSupport
14 Comments
 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 34913799
Never heard of that message - will investigate.
0
 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 34936321
You can try this link to see if you can remove it following this guide
http://support.microsoft.com/kb/290301

0
 

Author Comment

by:ByteCafeSupport
ID: 34960785
Computer is out of office at the moment, so I haven't been able to try this.
0
Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 34964014
No problem :)
0
 

Author Comment

by:ByteCafeSupport
ID: 34981098
Windows Installer CleanUp Utility is no longer available from Microsoft, so not sure I can do that at this time.

The problem I was trying to resolve by reinstall is that the proxy settings that were handed out by ISA are stuck on. So, when offsite, cannot access web with IE because it can't reach the proxy server. I've removed proxy settings (because with Firewall Client, it's not needed) from Firewall Client config of ISA server and browser configuration is enabled on client, but it won't update to remove proxy. Should I start a new question for this specifically? It's in the plans to replace ISA with another device in the next few months, so I will need to remove it eventually.
0
 
LVL 23

Expert Comment

by:Suliman Abu Kharroub
ID: 34984843
0
 

Author Comment

by:ByteCafeSupport
ID: 35010897
Sulimanw, checked wpad setup and found wpad in DNS as A record. Removed and created CNAME with FQDN. Will see if this changes anything.

Will likely start case with Microsoft on uninstall issue.
0
 

Author Comment

by:ByteCafeSupport
ID: 35130513
Update -
Working with Microsoft support on this. Checking msiinstaller logs from uninstall attempt, version shows 4.0.3440 (which is the older version of Firewall Client running on XP computers and not supported on Windows 7) rather than 4.0.3442.654 that the client shows on General tab of configuration. That older version was likely attempted to be installed by GPO before a WMI filter was put in place to keep it from installing on Windows 7, and is likely the cause of the problem. If that's true, this will only affect pre-filter clients, but I haven't been able to verify that yet.
0
 

Author Comment

by:ByteCafeSupport
ID: 35366135
I have found this problem caused by installing version 4.0.3442.654 over 4.0.3440. I was able to uninstall from a Windows 7 x64 computer that only had the older version installed by GPO. Because I removed it first, I was able to install the new version and have no problems with it.

I am still working with Microsoft Support to figure out how to uninstall on the affected computers.
0
 
LVL 51

Expert Comment

by:Keith Alabaster
ID: 35407511
Last comment was on the 11th April, 5 days ago so please leave it alone. Np point PAQ'ing it until the results from the MS investigation are given.
0
 

Accepted Solution

by:
ee_auto earned 0 total points
ID: 35439060
Question PAQ'd and stored in the solution database.
0
 

Author Comment

by:ByteCafeSupport
ID: 35689640
Have worked on removal with Microsoft. Up front, they told me they didn't have a solution, but called it a workaround to try manual removal. We removed all registry keys (or just the values in a few instances) where "Firewall Client" was found. On reboot, system would not come up normally. Had to boot into safe mode and use system restore to restore point I created right before we started to get system back up. At this point, because I have found my own workaround to resolve the symptoms, I will stop working on this.

To recap:
When users out of office, unable to use IE because proxy was stuck on. Turned proxy setting off in firewall client config in ISA, but didn't update. Logged in as another user (administrator in this instance) and FWC settings updated and were still correct when going back as original user, taking care of the symptom. Wanted to uninstall FWC and reinstall but got message that 64-bit is not supported at uninstall. Client and Programs and features show version 4.0.3442, but event logs from unisntall show version 4.0.3440. Systems were, for a while, in the scope of a GPO that pushes out version 4.0.3440, which I know does not support 64-bit. In trying to duplicate this, all I get in trying to push the old version out is a RSOP telling me it can't install on 64-bit, so I don't know how this even happened in the first place. Worked with Micsrosoft support on manual removal, but computer would not boot. With symptoms resolved, will leave it how it is and disable from starting when it is no longer needed.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

OfficeMate Freezes on login or does not load after login credentials are input.
By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
This Micro Tutorial will give you a introduction in two parts how to utilize Windows Live Movie Maker to its maximum editing capability. This will be demonstrated using Windows Live Movie Maker on Windows 7 operating system.

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question