Solved

Cisco Call Manager 4.1 connected to Asterisk via Sip trunk for Voicemail & Auto Attendant

Posted on 2011-02-16
3
2,887 Views
Last Modified: 2012-05-11
I'm having problems intergrating Cisco Call Manager 4.1 and Asterisk together using a sip trunk. The call manager is in a office  and the asterisk box is being hosted online in a data center with a public ip. There is no firewall in front of the cme only standard nat

outgoing calls from cme to asterisk rights. But going calls from asterisk to cme is the problem. I post my cme and asterisk config below.

My main sip-ua is working fine. Incoming call on dial-peer voice 200 voip is working and outgoing calls to  dial-peer voice 201 voip is working.

My asterisk incoming dial peer 211 is down dose not process incoming calls correclty. My outgoing asterisk dial peer 210 works I can contact voice mail and auto-attendent.

But return calls from asterisk back to cme dose not work. I receive a "All Circuits are Busy" message.

Any suggestion will help. Thanks again.




My CME config.

R1>en
Password:
R1#sh run
Building configuration...

Current configuration : 13472 bytes
!
! Last configuration change at 22:15:46 Pacific Mon Feb 14 2011 by mdyer
! NVRAM config last updated at 20:49:27 Pacific Mon Feb 14 2011 by mdyer
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging buffered 4096
enable secret 5 $1$XvCD$2Hm2wLmAFOizex4Xv0uPb.
!
aaa new-model
!
!
!
!
aaa session-id common
clock timezone Pacific -8
clock summer-time pacific recurring
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.8.1 192.168.8.15
ip dhcp excluded-address 192.168.8.10
ip dhcp excluded-address 192.168.8.231
!
ip dhcp pool VOIP
  network 10.1.8.0 255.255.255.0
  option 150 ip 10.1.8.1
  default-router 10.1.8.1
  lease 7
!
ip dhcp pool DATA
  network 192.168.8.0 255.255.255.0
  default-router 192.168.8.1
  dns-server 00.00
  option 66 ip 192.168.8.1
  lease 7
!
!
no ip domain lookup


!
multilink bundle-name authenticated
!
!
!
voice rtp send-recv
!
voice service pots

voice service voip
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol pass-through g711ulaw
sip
 bind control source-interface FastEthernet0/1
 bind media source-interface FastEthernet0/1
 registrar server expires max 3600 min 3600
 no call service stop
!
!
voice class codec 1
codec preference 1 g711ulaw
!
!
!
!
!
!
!
!
!
!
!
!
voice translation-rule 3
rule 1 /^71370000/ /2/ <--Translation for 28 did to internal extenstions
rule 3 /7147630000/ /4000/ <--Main 800 number
!
!
voice translation-profile IncomingCalls
translate called 3
!
!
!
!
!
!

log config
 hidekeys
!

interface Loopback0
ip address 10.1.9.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
ip nat inside
ip virtual-reassembly
speed 100
full-duplex
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 10.1.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/0.3
encapsulation dot1Q 3 native
ip address 192.168.8.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1
description External WAN Connection
ip address 38.96.00.00 255.255.255.248
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 38.96.00.00
!
!
ip http server
no ip http secure-server
ip nat pool WANPOOL 00.00 prefix-length 29
ip nat inside source list 10 pool WANPOOL overload

access-list 10 permit 192.168.8.0 0.0.0.255
access-list 10 permit 10.1.8.0 0.0.0.255
!
!
!
!
tftp-server flash:P00308010200.bin
tftp-server flash:P00308010200.loads
tftp-server flash:P00308010200.sb2
tftp-server flash:P00308010200.sbn
tftp-server flash:music-on-hold.au
!
control-plane
!
!
!
ccm-manager music-on-hold
!
!
!
!
dial-peer voice 201 voip
description *** SIP-TRUNK (OUT) ***
destination-pattern 9[0-1][2-9]..[2-9]......
voice-class codec 1
session protocol sipv2
session target dns:abc.abc
dtmf-relay sip-notify rtp-nte
!
dial-peer voice 210 voip
description Voice mail dial peer
destination-pattern 3...  <---Asterisk extenstion start at 3200
session protocol sipv2
session target ipv4:173.231.00.00
session transport udp
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 211 voip
description *** Asterisk-SIP-TRUNK (IN) ***
translation-profile incoming IncomingCalls
 dtmf-relay rtp-nte
codec g711ulaw
session protocol sipv2
session target ipv4:173.231.00.00
incoming called-number 2..  <-- CME extension start at 200
no vad
!
dial-peer voice 200 voip
description *** SIP-TRUNK (IN) ***
translation-profile incoming IncomingCalls
voice-class codec 1
session protocol sipv2
session target dns:abc.abcnet
incoming called-number .%
no vad
!

sip-ua
credentials username 0000  password 0000 realm asterisk
authentication username 0000 password 7 0000 realm asterisk
retry invite 2
retry register 3
timers connect 100
mwi-server ipv4:173.231.00.00 expires 86400 port 5060 transport tcp
registrar dns:abc.net expires 3600
registrar dns:abc.net expires 3600 secondary
sip-server dns:abc.nett
 host-registrar
!
!
!
telephony-service
load 7960-7940 P00308010200
max-ephones 35
max-dn 35
ip source-address 10.1.9.1 port 2000
timeouts interdigit 4
system message
max-conferences 4 gain -6
call-forward pattern .T
call-forward system redirecting-expanded
moh flash:music-on-hold.au
multicast moh 239.1.0.0 port 16384
transfer-system full-consult dss
transfer-pattern .T
secondary-dialtone 9
directory last-name-first
create cnf-files version-stamp 7960 Feb 14 2011 11:03:00
!
!
ephone-template  5
softkeys idle  Newcall Cfwdall Pickup
softkeys seized  Endcall Cfwdall Pickup
softkeys alerting  Endcall
softkeys connected  Endcall Hold Park Trnsfer Confrn
softkeys ringing  Answer
type 7960
!

ephone-dn  1  dual-line
number 714-798-0000
label Etx 231
description 714-798-0000
name Etx 231
call-forward busy 3231
call-forward noan 3231 timeout 25
!
!

!
!
ephone-dn  35
number 4000
call-forward busy 3200
call-forward noan 3200 timeout 18
!
!
ephone  1
device-security-mode none
mac-address A8B1.D41E.DC31
ephone-template 5
type 7960
button  1:35



!
line con 0
line aux 0
line vty 0 4

transport preferred ssh
transport input ssh
!
ntp clock-period 17208406

!
end


Config on my asterisk box.

Trunk Name: 17thStreet

type=friend
qualify=yes
nat=yes
insecure=very
host=38.96.00.00 <-- IP of cme
fromdomain=38.96.00.00 <--IP of cme
dtmf=rfc2833
disallow=all
context=from-internal
canreinvite=no
allow=ulaw


USER Context  38.96.00.00 <--IP of cme

type=friend
qualify=yes
nat=yes
insecure=very
host=38.96.00.00
fromdomain=38.96.00.00
dtmf=rfc2833
disallow=all
context=from-internal
canreinvite=no
allow=ulaw

Outbound Routes

Dial Patterns: 2XX <--Extension for cme

Trunk Sequence:   SIP/17thStreet


** I don't have smd installed on the router all config is being done in ios.

When I try to dial a cme extension from a Xlite softphone connect to the asterisk box I receive an "All circuits is busing" from asterisk.

I did a show sip peers on asterisk and it display:

17thStreet                 38.96.00.00        N      5060     UNREACHABLE
0
Comment
Question by:MikeLeePIT
  • 2
3 Comments
 
LVL 6

Expert Comment

by:mark_06
Comment Utility
First off you want to put an ACL on the WAN connection, otherwise anyone can connect to your CME and place calls via SIP.

Can you provide a SIP debug of an unsuccessful call from the Asterisk box and from CME

Asterisk - sip set debug on

CME - debug ccsip messges

This will let me know whats happening!

0
 
LVL 6

Accepted Solution

by:
mark_06 earned 500 total points
Comment Utility
Sorry thats  CME - debug ccsip messages
0
 

Author Closing Comment

by:MikeLeePIT
Comment Utility
This command allowed me to monitor the sip truck and correct the problem with incoming calls
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Suggested Solutions

Hey there Heard about jingle, the add on for XMPP that enables point to point audio between two XMPP clients. No server config necessary. Actually quite a cool feature. However, how good is it if you can not use those voice capabilities to do a P…
Moving your enterprise fax infrastructure from in-house fax machines and servers to the cloud makes sense — from both an efficiency and productivity standpoint. But does migrating to a cloud fax solution mean you will no longer be able to send or re…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now