Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 766
  • Last Modified:

Need to open Firefox without it starting at most recent url

I navigated by to a website by clicking a link.  Immediately an alert box appeared, saying something like "Mozilla security has detected [something or other] and wil now perform a scan".
Since clicking OK can enable the malware, I immediately closed Firefox with task manager.  I was unable to close the window in the usual way.
I opened Firefox again, only to see the same warning but this time the "scan" processs seemed to be starting on its own.  I closed the window again with task manager.
I have had this problem before when my computer has hing or restarted on its own (about once a month) - Firefox starts with previously open tabs re-opening.  Since one of the websites may have had something to do with the problem, I want to disable this feature.  HOWEVER -  at this point I cannot open Firefox to make the changes, even if Knew what they were.  In fact, even if such an option is available (never open previously opened tabs).
QUESTION 1: How do I open Firefox without this process continuing?
QUESTION 2: How do I configure Firefox not to try to open previously open tabs after a forced shutdown or reboot?
While waiting for an effective answer, I guess I will just use MSIE.
0
gbad00
Asked:
gbad00
2 Solutions
 
mooodiecrCommented:
Try ... Tools-> Options -> General -> When Firefox starts, set that to "Show my homepage"
0
 
AriMcCommented:
Try starting the browser from command line like this:

   "c:\Program Files\....\firefox.exe" about:blank


0
 
gbad00Author Commented:
To AriMc: Yes! starting from C: prompt with about:blank switch gave me a clean browser, although there were 2 tabs - the one NOT opened offered to restore last session!

To mooodiecr: Not helpful! I already had it set to start at "about: blank".  I tried starting at "my homepage" and I made that my own website. I went to another website, and then tested fix by closing in usual way and reopening.  It reopened to my website as expected.
Then I opened it again, went to same site, and shut it down with task  Manager.  It reopened to last visited site (same as it has always done), NOT to "my homepage".
I still need to fix this - or is this an unfixable Firefox bug?
I notice that MSIE ASKS the user, rather than just restore tabs.
0
Threat Trends for MSPs to Watch

See the findings.
Despite its humble beginnings, phishing has come a long way since those first crudely constructed emails. Today, phishing sites can appear and disappear in the length of a coffee break, and it takes more than a little know-how to keep your clients secure.

 
gbad00Author Commented:
BTW, AriMC: I am familiar with Command prompt syntax and commands, from old DOS days. But when offering such a solution, you should give the complete procedure.  Of course, simply typing your syntax
c:\Program Files\....\firefox.exe" about:blank
or even c:\Program Files\Mozilla Firefox\firefox.exe" about:blank
just elicits an error msg
How many average users know C: commands these days?
0
 
aleghartCommented:
> How many average users know C: commands these days?

Define "average".  Here at EE, probably more than you can shake a stick at.  :)

I can force quit FF from TaskMgr and it will launch with blank tab, as expected.  So, I can't say that it's a FF bug.  Only one data point though.  Vanilla install of FF 3.6.13 with basic settings.
FF
0
 
gbad00Author Commented:
aleghart:
Well, it won't do it for me. I set Start to "show a blank page" - again - that's where I had it to begin with when I had all that trouble. I have Show download window UNchecked, and Save file to to"ask me" which is what I need to do my work.
Launched FF, went to yahoo finance, then quit with Task Manager. Restart firefox, and it opens to yahoo finance, just as it was - NOT blank page.
So - any ideas?  Are there any other settings that would affect this?
I have same version I think:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
0
 
gbad00Author Commented:
PS: I also have Spybot, Zonealarm, and Norton Antivirus, if that means anything.
0
 
bz43Commented:
I assume you're using Windows XP because it says "Windows NT 5.1". Is that correct?

Have you tried "Firefox Safe Mode": http://goo.gl/F4UMA
0
 
gbad00Author Commented:
bz43:
Sorry to take so long to respond. I have Windows XP Pro SP3.
I will try the Safe Mode when I get a few minutes this evening. Problem is, I don't know what changes in the settings I am supposed to make. The current settings seem to be all that is available to produce the result I want.  However, setting this configuration in safe mode is what is needed.

to AriMc:
Your answer was a perfect partial solution and I will award partial points for it as soon as I get the rest of the problem solved - or give up on it.  Thanks.
0
 
gbad00Author Commented:
My apologies to all for taking so long to close this question. The broader question of Firefox wanting to start with tabs that were open before a forced close or a system hang seems to have been rendered moot by a recent Firefox upgrade.  Under such circumstances, the browser upon restarting asks whether the user wants to open previously opened tabs - or not.
Sometimes if you wait, evolution provides the answer.
0
 
gbad00Author Commented:
The other, larger half of the question was not answered by me or any of the experts. It appears to have come along as part of a Firefox version upgrade.  In any case, I no longer experience the problem, so why go on about it? What the underlying process was causing the behavior of Firefox, I will never know.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now