Solved

even through wars are deployed correctly in th ear ;but not able to access second war .

Posted on 2011-02-16
11
811 Views
Last Modified: 2013-12-11
we have 2 wars in a ear.even though ear is  deployed correctly ;but not able to access second war .i.we. WeatherWebContentWeb when i hit http://localhost:9080/WeatherWebContentWeb
getting below message 'The webpage cannot be found'

[2/16/11 20:56:52:498 IST] 0000003b WebGroup      A   SRVE0169I: Loading Web Module: WeatherWeb.
[2/16/11 20:56:52:451 IST] 0000003b VirtualHost   I   SRVE0250I: Web Module WeatherWeb has been bound to default_host[*:9080,*:80,*:9443,*:5060,*:5061,*:443].
[2/16/11 20:56:52:498 IST] 0000003b WebGroup      A   SRVE0169I: Loading Web Module: WeatherWebContentWeb.
[2/16/11 20:56:52:529 IST] 0000003b VirtualHost   I   SRVE0250I: Web Module WeatherWebContentWeb has been bound to default_host[*:9080,*:80,*:9443,*:5060,*:5061,*:443].
[2/16/11 20:56:52:529 IST] 0000003b ApplicationMg A   WSVR0221I: Application started: Weather
0
Comment
Question by:chaitu chaitu
11 Comments
 
LVL 20

Author Comment

by:chaitu chaitu
ID: 34913721
am getting this error.how to resolve this?

A WebGroup/Virtual Host to handle /WeatherWebContentWeb has not been defined.
0
 

Expert Comment

by:RishiBang
ID: 34913978
Hi chaituu,

You can check the following things

1) The Application deployed correctly. I mean all configuration dependencies are satisfied (Datasources, Security etc.,)
2) After starting the server take a look at the end of SystemOut.log to check for the message "Application XYZ Started successfully"

Attach the error logs if you can.

Thanks,
Rishi
0
 
LVL 20

Author Comment

by:chaitu chaitu
ID: 34914106
please ignore my last comment.
see my application.xml

  <display-name>Weather</display-name>
  <module>
    <web>
      <web-uri>WeatherWeb.war</web-uri>
      <context-root>/WeatherWeb</context-root>
    </web>
  </module>
  <module>
    <web>
      <web-uri>WeatherWebContentWeb .war</web-uri>
      <context-root>/WeatherWebContentWeb </context-root>
    </web>
  </module>
</application>

when i access http://localhost:9080/WeatherWeb its coming.
http://localhost:9080/WeatherWebContentWeb not coming.

if i see my first comment application has started sucessfully

Application started: Weather

0
 
LVL 20

Author Comment

by:chaitu chaitu
ID: 34914170
strange.

we have only static content(js files,images ,css,some html files etc..) in WeatherWebContentWeb  war.

i have created sample test.jsp and placed in WeatherWebContentWeb  and accessed
http://localhost:9080/WeatherWebContentWeb/index.jsp then page is coming but when i try to acess some gif file that is placed in the same context and same folder http://localhost:9080/WeatherWebContentWeb/cardt.gif its not coming.....
0
 
LVL 1

Expert Comment

by:gavin_si
ID: 34914604
Hi,

Have you tried regenerating with web server plug-ins from the admin console?

Gavin
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 20

Author Comment

by:chaitu chaitu
ID: 34914827
plugin-cfg.xml

      below contents were there in above xml file;

      <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/WeatherWebContentWeb/*.jsp"/>
      <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/WeatherWebContentWeb/*.jsv"/>
      <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/WeatherWebContentWeb/*.jsw"/>
      <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/WeatherWebContentWeb/j_security_check"/>
      <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/WeatherWebContentWeb/ibm_security_logout"/>
      <Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/WeatherWebContentWeb/servlet/*">

will this issue resolved if i add like this;after adding if i try to regenerating with web server plug-ins from the admin console then old xml file is again coming back..


<Uri AffinityCookie="JSESSIONID" AffinityURLIdentifier="jsessionid" Name="/WeatherWebContentWeb/*">
0
 
LVL 1

Expert Comment

by:gavin_si
ID: 34914960

I dont think so. You should never have to alter the plug-ins file by hand.

Do you get a 404 or a 500 error?

0
 
LVL 20

Author Comment

by:chaitu chaitu
ID: 34914997
i am getting HTTP 404 not found error.

http://publib.boulder.ibm.com/infocenter/wasinfo/v6r0/index.jsp?topic=/com.ibm.websphere.express.doc/info/exp/ae/rweb_jspengine.html

as per above link i have even changed like this in the ibm-web-ext.xmi in WeatherContentWeb.war/WEB-INF folder but still problem persists.

<?xml version="1.0" encoding="UTF-8"?>
<com.ibm.ejs.models.base.extensions.webappext:WebAppExtension xmi:version="2.0" xmlns:xmi="http://www.omg.org/XMI" xmlns:com.ibm.ejs.models.base.extensions.webappext="webappext.xmi" xmi:id="WebAppExtension_1" reloadInterval="3" reloadingEnabled="true" additionalClassPath="" fileServingEnabled="true" directoryBrowsingEnabled="false" serveServletsByClassnameEnabled="true">
  <webApp href="WEB-INF/web.xml#WebApp_1297856567155"/>
   <fileServingAttributes xmi:id="FileServingAttribute_1297856567155" name="extendedDocumentRoot"
       value="D:/MYCA/RAD75/SDP/runtimes/base_v61/profiles/was61profile1/installedApps/pc120686Node01Cell/Weather.ear/WeatherContentWeb.war"/>
  <jspAttributes xmi:id="JSPAttribute_1297856567155" name="reloadEnabled" value="true"/>
</com.ibm.ejs.models.base.extensions.webappext:WebAppExtension>
0
 
LVL 11

Expert Comment

by:Radek Baranowski
ID: 34915037
you might want to check this:

http://www.ibm.com/developerworks/websphere/techjournal/0211_brown/brown.html

was is a bit cllumsy when it comes to static content. see the article.
0
 
LVL 20

Accepted Solution

by:
chaitu chaitu earned 0 total points
ID: 34915773
above solutions not worked...

need enable ServingEnabled="true" in the below file has done the trick.

config\cells\pc120686Node01Cell\applications\Weather.ear\deployments\Weather\WeatherContentWeb.war\WEB-INF\ibm-web-ext.xmi
0
 
LVL 20

Author Closing Comment

by:chaitu chaitu
ID: 34978090
none of the above comments  not worked.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Verbose logging is used to diagnose garbage collector problems. By default, -verbose:gc output is written to either native_stderr.log or native_stdout.log.   It is also possible to redirect the logs to a user-specified file. This article will de…
Meet the world's only “Transparent Cloud™” from Superb Internet Corporation. Now, you can experience firsthand a cloud platform that consistently outperforms Amazon Web Services (AWS), IBM’s Softlayer, and Microsoft’s Azure when it comes to CPU and …
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
With the power of JIRA, there's an unlimited number of ways you can customize it, use it and benefit from it. With that in mind, there's bound to be things that I wasn't able to cover in this course. With this summary we'll look at some places to go…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now