Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1618
  • Last Modified:

ClickOnce / IIS Issue : Could not download '...dll.deploy' from http://www...

We recently setup a new site on our IIS 6 server which does not download the published ClickOnce application; however, it does upload the actual files to the server in the proper directory.

If I stop the new site and start the old site, it all works.

After looking through all the options, I have been unable to locate the setting that is causing this problem.

 Visual Studio Screen Shot
Once promising option is the Anonymous access.  However, I wasn't able to find the switch in IIS for it.

When you publish to a remote server that has "Anonymous Access" turned off, you will receive the following warning:

http://msdn.microsoft.com/en-us/library/ms228998.aspx
0
Officedoxs
Asked:
Officedoxs
  • 3
  • 2
2 Solutions
 
CodeCruiserCommented:
0
 
OfficedoxsAuthor Commented:
The MIME Types for both the old and new sites are exactly the same.  I double checked the count and individual items.
0
 
OfficedoxsAuthor Commented:
The issue was Execute permissions in Handler Mappings.  I disabled the option and all worked successfully.

http://blogs.iis.net/davcox/archive/2008/09/05/where-is-execute-permission-in-the-ui.aspx
0
 
OfficedoxsAuthor Commented:
My answer is complete.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now