Solved

Linux Apic

Posted on 2011-02-17
8
508 Views
Last Modified: 2012-05-11
Hi guys,

I have a fresh installation of Fedora 14 64b. I have tried pretty much distributives and finally my choice is Fedora. I have an Asus M4A89GTD Pro /usb3 mobo and If APIC is enabled in my BIOS I can't turn off my machine, I mean procedure is normally running and I can see that all services are stopped but there is no automatic PSU turn off.

If I disable APIC I can normally turn off my machine but from CPU information I see only 1 available core instead of 4. I have googled this problem pretty much time but there is no usful information. At this time my workaround is sleeping mode which is working fine with or without APIC option. The reason why I offer 500 points for this issue resolution is just because this is very important for me to resolve and during huge amount of time I couldn't find out normal solution. If somebody have an idea, please help!

Many thanx,
Alex
0
Comment
Question by:NiconPhantom
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 2
8 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 34921594
Have you checked to see if your system board BIOS is the latest version?
0
 

Author Comment

by:NiconPhantom
ID: 34924131
Hi, sure.... I have the last version of BIOS.
0
 

Accepted Solution

by:
NiconPhantom earned 0 total points
ID: 34924142
I don't know where is the logic, but today I have installed Arch linux instead of Fedora, and I was shocked after my PC has been normally turned off with Arch :-) I think that diference can be in kernel version, Arch always offer new versions of kernels and other stuff little bit faster than another distributives. At this moment as I got positive result and my system is working fine, we can close this question.
0
Database Solutions Engineer FAQs

In this series, we will discuss common questions received as a database Solutions Engineer at Percona. In this role, we speak with a wide array of MySQL and MongoDB users responsible for both extremely large and complex environments to smaller single-server environments.

 
LVL 12

Expert Comment

by:HappyCactus
ID: 34924778
Just to explain why you solved, you must enable the "loapic" option on boot, since (as you can read from the kernel documentation) loapic is used to manage the interrupts for power management and SMP management of interrupts. without loapic the kernel can't run in a SMP mode, so no more than 1 core.
0
 

Author Comment

by:NiconPhantom
ID: 34924991
Happy Cactus, thank you for reply, actually after installation, suggested by you loapic flag has not been manually specified by me. At this time I use APIC enabled Bios setting and absolutely defaul Kernel 2.6.37-6 without any additional flag. It is very interesting because as far as I remeber I have tried Arch last time with ~2.6.35 Kernel but without successful poweroff. Here is my original comment on Arch BBS: https://bbs.archlinux.org/viewtopic.php?id=104124
0
 
LVL 12

Expert Comment

by:HappyCactus
ID: 34925045
Maybe something was changed in the chipset driver - you should check the changelog, very difficult to say.
loapic is an option that "should" by set by default, since enabling it on uniprocessor it's (where no loapic is present) doesn't make any difference.

In any case, I would check (with diff -ub) the different kernel configuration.
0
 

Author Comment

by:NiconPhantom
ID: 34937418
Thank you very much HappyCactus for detailed description! Next time if I'll use other distro with older Kernel, I'll follow your suggestion.
0
 

Author Closing Comment

by:NiconPhantom
ID: 34949992
New distro, newer version of kernel, I think that that is the solution. I have tried Arch before, maybe 6 months ago but result was the same. So, Arch + 2.6.37-5 is solution of my problem.
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question