Solved

Cisco 837 ADSL PPPoE + NAT basic configuration

Posted on 2011-02-17
2
2,799 Views
Last Modified: 2012-07-23
Hi there,
The goal is to configure (from scratch)  and connect a modem/router ADSL Cisco 837 to the Belgian ISP Skynet/Belgacom
The subscription is a standard "Belgacom Favorite package" (Dynamic IP, PPPoE,  PVC 8/35, etc ...)

=> http://www.belgacom.be/private/en/jsp/dynamic/productCategory.jsp?dcrName=internet_access_withvoice&mc_id=adw_cbu_B_B1_1

Since I am not used with the Cisco ISO CLI, could somebody give my some help to write a basic config (PPPoE Internet connection + NAT) to connect this 837 Cisco router ?
Many thanks

More tech info about the router
------
IOS (tm) C837 Software (C837-K9O3Y6-M), Version 12.2(13)ZH4
CISCO C837 (MPC857DSL) processor (revision 0x200) with 29492K/3276K bytes of memory.
Processor board ID AMB070100Q2 (1202893312), with hardware revision 0000
CPU rev number 7
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 ATM network interface(s)
128K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Web flash (Read/Write)
----

0
Comment
Question by:LeTay
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 35

Accepted Solution

by:
Ernie Beek earned 500 total points
ID: 34914492
0
 
LVL 6

Expert Comment

by:vikrantambhore
ID: 34914561
Hi use as per below, u need to eneter shut & No shut under every interface, Let me know if more help
U can chage SSID & Hostname as per ur requirment This is all  Include all

Router>enable
Router#config t
Router(config)#Hostname cisco
cisco(config)#Line console 0
cisco(config-line)#Password cisco
cisco(config-line)#login
cisco(config-line)#exit
cisco(config)#Line vty 0 4
cisco(config-line)#Password cisco
cisco(config-Line)#login
cisco(config-line)#exit
cisco(config)#Line aux 0
cisco(config-line)#Password cisco
cisco(config-line)#login
cisco(config-line)#exit
cisco(config)#service password-encryption
cisco(config)#enable secret cisco
cisco(config)#exit
cisco(config)#username vikrant password cisco
cisco(config)#line console 0
cisco(config-line)#login local
cisco(config-line)#exit
cisco(config)#line vty 0 4
cisco(config-line)#login local
cisco(config-line)#exit
cisco(config)#line aux 0
cisco(config-line)#login local
cisco(config-line)#exit
cisco(config)exit
cisco#wr
!
Then

dot11 ssid <VIKRANT>-----------Name of WI-Fi
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii <WI-Fi KEY>
!
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.15
!
ip dhcp pool LAN-POOL
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 192.168.1.1
   lease 0 2
!
!
ip name-server XX.XX.XX.XX   preferred DNS Server IP
ip name-server XX.XX.XX.XX   Alternate DNS Server IP
!
multilink bundle-name authenticated
!
!
!
!

!
!
archive
 log config
  hidekeys
!
!
!
bridge irb
!
!
interface Loopback0
 no ip address
!
interface Loopback1
 no ip address
!
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 description $ES_WAN$
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 no ip address
 ip nat inside
 ip virtual-reassembly
 !
 encryption vlan 1 mode ciphers tkip
 !
 ssid VIKRANT
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
 54.0
 station-role root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 description $ES_LAN$
 no ip address
 ip access-group BlockIPSec2HQ in
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1412
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Dialer0
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname <    > --------> Hostname from ISP
 ppp chap password < > -----------> Password
 ppp pap sent-username <UserName> password < passwor> ----------Internet access detail
 
!
interface Dialer1
 no ip address
!
interface BVI1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 !
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
ip http authentication local
ip http secure-server
ip dns server
ip nat inside source list ToNAT interface Dialer0 overload
!
ip access-list extended ToNAT
 deny   ip any 192.168.0.0 0.0.255.255
 permit ip 192.168.1.0 0.0.3.255 any
!
!
!
route-map SDM_RMAP_1 permit 1
 match ip address 100
!
!
control-plane
!
bridge 1 route ip
!
0

Featured Post

Enroll in June's Course of the Month

June’s Course of the Month is now available! Experts Exchange’s Premium Members, Team Accounts, and Qualified Experts have access to a complimentary course each month as part of their membership—an extra way to sharpen your skills and increase training.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question