Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1309
  • Last Modified:

Unable to Remote Desktop on to upgraded Windows Server 2008 R2 Standard

Hi All,

I am having trouble connecting to one of our server 2008 machines.

I have just upgraded it from 2003 to Server 2008 R2 Standard. Before the upgrade it was working fine. After it just doesn't accept any connections with the error:
This computer can't connect to the remote computer.
Try connecting again. If the problem continues, contact the owner of the remote computer or you rnetwork administrator.

If I try to connect from a different subnet (allowed through firewall) then I get this error:
Remote Desktop cannot connect to the remote computer for one of these reasons:
1) Remote access to the server is not enabled
2) The remote computer is turned off
3) The remote computer is not available on the network
Make sure the remote computer is turned on and connection to the network, and that remote access is enabled.


So,
I've got the Firewall off for all connections, and the service is running.
the allow/deny log on policies are not defined by group policy. We have another 2008 fresh build on the same domain which works fine.
I can RDP from the machine no problem, just looks like incomming connections are not working.
The remote settings are set to "Allow connections from computers running any version of Remote Desktop (less secure).
The only odd thing here is that I can't change it to 'Don't allow connections to this computer, whereas I can on another 2008 machine on the same domain.... I wanted to try setting it off, rebooting and turning it on again just to see.

I wonder if something has to be done after a 2003 machine is upgraded to 2008 before it starts working again? or is there anything else I can check/try?

Anyone got any ideas?
0
bankhall
Asked:
bankhall
  • 6
  • 5
3 Solutions
 
h3nnysCommented:
HI

Once you upgraded did you check to see if Terminal Services were installed and activated ?
0
 
bankhallAuthor Commented:
Is that required for remote desktop administration? The working 2008 machines we have are not terminal servers.
0
 
h3nnysCommented:
Ok If tthe server is not a terminal server then its not required.

Try This

in your Administrative Tools on top there should be a Remote Desktop Services sub folder which contains Remote desktop session host configuration utility

go to that utillity and do check the following :

click remote desktop licensing mode and edit the settings there to allow all connections

if the sub folder is not there then RD is not setup correctly on that server
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
bankhallAuthor Commented:
when going to the licensing mode it said that the Remote desktop services role was not installed, which should be fine as again it's not installed on a working 2008 server that allows RDP for administration.

I could install it to test but it won't be licensed
0
 
bankhallAuthor Commented:
hang about! just installed it and it works!

Surely this isn't required for remote desktop administration???

maybe if I uninstall it now it will still work..
0
 
h3nnysCommented:
It does not need to be Licenced but you can try uninstalling but I doubt that it will still work
0
 
bankhallAuthor Commented:
Uninstalled it and it still works...... I've love to explain that but I can't think why that's fixed it.

perhaps, when it installs Remote desktop services, it fixes the issue with remote desktop administration and then when it removes the role it simply gets rid of the extra functionality that comes with the remote desktop service but leaves the 'fixed' remote desktop administration settings.

Maybe it's fixing a permission, or a registry entry of some sort - who knows! as I said I'd love to know so that fuure upgrades could be fixed a bit easier but it beats having to build a new server from scratch!

cheers for the fix h3nnys!
0
 
Don ThomsonCommented:
Under Services you need the following started:
Terminal Services
Terminal Services Configuration
Terminal Serivces Gateway
Terminal Services UserMode Port Redirector

In Administration Tools under Terminal Serices Configuration

Connections - RDP-TCP -Client Compatible

Under Licensing  Mode Remote Desktop for Administration   (This mode does not require Licensing and give you two concurrent connections in addition to the Console


Under Server Manager
Under Roles - Terminal Serices must be added
0
 
h3nnysCommented:
Thats good and I will research why it does that

glad to have helped !

Could you mark the "Was this comment helpful tab for me " please
0
 
bankhallAuthor Commented:
DTHConsulting,
Thanks for your comment. The services were running fine, but I don't have the terminal services (remote desktop services in 2008) installed on this machine and it works, so surely it is not required? it's just strange that installing it and removing it again fixed it.

I'll close this one shortly but will be keeping an eye on it to see if your research solves the mystery h3nnys.

thanks again!
0
 
h3nnysCommented:
Will Keep you updated on that
0
 
bankhallAuthor Commented:
Hopefuly the reason this works will be found out and added later.
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now