Solved

Unable to Remote Desktop on to upgraded Windows Server 2008 R2 Standard

Posted on 2011-02-17
12
1,300 Views
Last Modified: 2012-05-11
Hi All,

I am having trouble connecting to one of our server 2008 machines.

I have just upgraded it from 2003 to Server 2008 R2 Standard. Before the upgrade it was working fine. After it just doesn't accept any connections with the error:
This computer can't connect to the remote computer.
Try connecting again. If the problem continues, contact the owner of the remote computer or you rnetwork administrator.

If I try to connect from a different subnet (allowed through firewall) then I get this error:
Remote Desktop cannot connect to the remote computer for one of these reasons:
1) Remote access to the server is not enabled
2) The remote computer is turned off
3) The remote computer is not available on the network
Make sure the remote computer is turned on and connection to the network, and that remote access is enabled.


So,
I've got the Firewall off for all connections, and the service is running.
the allow/deny log on policies are not defined by group policy. We have another 2008 fresh build on the same domain which works fine.
I can RDP from the machine no problem, just looks like incomming connections are not working.
The remote settings are set to "Allow connections from computers running any version of Remote Desktop (less secure).
The only odd thing here is that I can't change it to 'Don't allow connections to this computer, whereas I can on another 2008 machine on the same domain.... I wanted to try setting it off, rebooting and turning it on again just to see.

I wonder if something has to be done after a 2003 machine is upgraded to 2008 before it starts working again? or is there anything else I can check/try?

Anyone got any ideas?
0
Comment
Question by:bankhall
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
12 Comments
 
LVL 4

Expert Comment

by:h3nnys
ID: 34914863
HI

Once you upgraded did you check to see if Terminal Services were installed and activated ?
0
 

Author Comment

by:bankhall
ID: 34914968
Is that required for remote desktop administration? The working 2008 machines we have are not terminal servers.
0
 
LVL 4

Accepted Solution

by:
h3nnys earned 500 total points
ID: 34915237
Ok If tthe server is not a terminal server then its not required.

Try This

in your Administrative Tools on top there should be a Remote Desktop Services sub folder which contains Remote desktop session host configuration utility

go to that utillity and do check the following :

click remote desktop licensing mode and edit the settings there to allow all connections

if the sub folder is not there then RD is not setup correctly on that server
0
Guide to Performance: Optimization & Monitoring

Nowadays, monitoring is a mixture of tools, systems, and codes—making it a very complex process. And with this complexity, comes variables for failure. Get DZone’s new Guide to Performance to learn how to proactively find these variables and solve them before a disruption occurs.

 

Author Comment

by:bankhall
ID: 34915798
when going to the licensing mode it said that the Remote desktop services role was not installed, which should be fine as again it's not installed on a working 2008 server that allows RDP for administration.

I could install it to test but it won't be licensed
0
 

Assisted Solution

by:bankhall
bankhall earned 0 total points
ID: 34915818
hang about! just installed it and it works!

Surely this isn't required for remote desktop administration???

maybe if I uninstall it now it will still work..
0
 
LVL 4

Expert Comment

by:h3nnys
ID: 34915855
It does not need to be Licenced but you can try uninstalling but I doubt that it will still work
0
 

Assisted Solution

by:bankhall
bankhall earned 0 total points
ID: 34915930
Uninstalled it and it still works...... I've love to explain that but I can't think why that's fixed it.

perhaps, when it installs Remote desktop services, it fixes the issue with remote desktop administration and then when it removes the role it simply gets rid of the extra functionality that comes with the remote desktop service but leaves the 'fixed' remote desktop administration settings.

Maybe it's fixing a permission, or a registry entry of some sort - who knows! as I said I'd love to know so that fuure upgrades could be fixed a bit easier but it beats having to build a new server from scratch!

cheers for the fix h3nnys!
0
 
LVL 14

Expert Comment

by:Don Thomson
ID: 34915972
Under Services you need the following started:
Terminal Services
Terminal Services Configuration
Terminal Serivces Gateway
Terminal Services UserMode Port Redirector

In Administration Tools under Terminal Serices Configuration

Connections - RDP-TCP -Client Compatible

Under Licensing  Mode Remote Desktop for Administration   (This mode does not require Licensing and give you two concurrent connections in addition to the Console


Under Server Manager
Under Roles - Terminal Serices must be added
0
 
LVL 4

Expert Comment

by:h3nnys
ID: 34916039
Thats good and I will research why it does that

glad to have helped !

Could you mark the "Was this comment helpful tab for me " please
0
 

Author Comment

by:bankhall
ID: 34916309
DTHConsulting,
Thanks for your comment. The services were running fine, but I don't have the terminal services (remote desktop services in 2008) installed on this machine and it works, so surely it is not required? it's just strange that installing it and removing it again fixed it.

I'll close this one shortly but will be keeping an eye on it to see if your research solves the mystery h3nnys.

thanks again!
0
 
LVL 4

Expert Comment

by:h3nnys
ID: 34916393
Will Keep you updated on that
0
 

Author Closing Comment

by:bankhall
ID: 34949680
Hopefuly the reason this works will be found out and added later.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

We recently had an issue where out of nowhere, end users started indicating that their logins to our terminal server were just showing a "blank screen." After checking the usual suspects -- profiles, shell=explorer.exe in the registry, userinit.exe,…
Redirected folders in a windows domain can be quite useful for a number of reasons, one of them being that with redirected application data, you can give users more seamless experience when logging into different workstations.  For example, if a use…
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question