Solved

Cannot connect to the Citrix XenAPP server

Posted on 2011-02-17
7
3,596 Views
Last Modified: 2012-06-27
I wonder if some one can help me on this issue?

Server 2008 R2, Xenapp 6

For our streamed application since last week few users are having this error:

Unable to Launch your application. Contact your help desk with the following information: Cannot connect to the Citrix XenAPP server, the server (Unknown) is not trusted for ICA connections. Connections to all Allregions are not allowed by lockdown settings. Please contact your administrator.


wiered thing is its not effecting all the users, I tried changing registery:
HKEY_CURRENT_USER\Software\Citrix\ICA Client as per below:
http://www.brianmadden.com/forums/t/34675.aspx

Tried GP as per below:
 http://support.citrix.com/article/CTX112653

But still no joy. any idea what this problem is and how can we fix it?

Your help as usual would be highly appreciated.

Thanks Sohail


0
Comment
Question by:nhsconfed
  • 4
  • 2
7 Comments
 
LVL 3

Expert Comment

by:CadrePro1
ID: 34923741
Can you temporarily disable GPOs to the XenApp server and try it clean that way. If it works then add back each GPO to see when the problem breaks. Once it breaks again look at the specific configs within that GPO that is causing the problem and we should be able to narrow it down
0
 

Author Comment

by:nhsconfed
ID: 34924453
This was the first thing I did, Disabled the GPO completely, GPupdate /force, rebooted the terminal server (infact couple of reboots) No Joy,

Googled the issue and found above links, implement above but no Joy.

I personally don't think its GPO, GPO is applied globally to all the users, yet few users are infected only.

Any more ideas would be highly appreciated.

Thanks
0
 
LVL 3

Expert Comment

by:CadrePro1
ID: 34927988
is there a common profile or region, or attribute about the users that are able to connect with no problem. Could they be power users, or listed in a different AD group.

What about network filters and restriction policies? Just trying to get a better grasp of the problem.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 15

Expert Comment

by:Lee Osborne
ID: 34933765
Have you tried unchecking the trust xml connections option for the server(s)?

Sorry, I wrote the following resolution out for XenApp 5 and then realised you need XenApp 6! I can't remember off hand where this setting is in the Policies for XenApp 6, but give it a go. The XML Service setting should still be application in v6.

(XenApp 5 Version) Citrix AMC > (Right Click) <servername> > Properties > XML Service

Uncheck the option: Trust requests sent to the XML Service.

Lee
0
 

Author Comment

by:nhsconfed
ID: 34950517
Thanks Lee,

In XenAPP 6, this option is in Policies, there are two options there, Enable trust XML or Disable. It was enabled so I disabled it unfortunately it has made no difference,

We have logged a call with experts now and they are coming to see this problem, as there is no solution I can find anywhere.

Thanks
Sohail
0
 

Accepted Solution

by:
nhsconfed earned 0 total points
ID: 36096175
From one of the working user, HKCU, i exported the citrix reg keys and imported to affected user, it did the trick.

Thanks all for the help.
0
 

Author Closing Comment

by:nhsconfed
ID: 36123126
Thsi was fix research on different artciles by citrix.
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Join & Write a Comment

#Citrix #XenApp #Citrix Scout #Citrix Insight Services #Microsoft VMMAP #Microsoft ADEXPLORE #Microsoft RAMMAP #Microsoft TCPVIEW #Microsoft AUTORUNS #Microsoft PROCESS EXPLORER #Microsoft PROCESS MONITOR
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now