• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1791
  • Last Modified:

Connecting FreeNX on Ubuntu Using NX Client

I am relatively inexperienced with Linux and am trying to setup FreeNX on a new Ubuntu 10.10 box to allow my Windows 7 box to connect using the nomachine client 3.4.0-10. I have followed the instructions at https://help.ubuntu.com/community/FreeNX. I have generated custom keys and imported client.id_dsa.key into NX Client. I am unable to connect and get the following  int eh details section of the Client:-

NX> 203 NXSSH running with pid: 2128
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 192.168.0.118 on port: 22
Write failed: Connection reset by peer

Open in new window


I am at a complete loss as to how to troubleshoot this.
0
cescentman
Asked:
cescentman
  • 7
  • 3
  • 2
1 Solution
 
svgmucCommented:
Is there an SSH server (sshd) running on 192.168.0.118?
Do you have permission to connect to it? The right key file? The password? Even the correct user?

1.
If you have physical access to 192.168.0.118, log in and type

ps xa| grep sshd

You may need root privileges for it to show.

If you don't have physical access, try to log in via ssh.

2.
Try to log in via ssh using the user configured for freenx.
0
 
cescentmanAuthor Commented:
Thanks for the prompt assistance.

Yes the box is on my LAN and SSH is running the grep command produced:

757    ?        Ss    0:00   /usr/sbin/sshd -D
2170  pts/1  S+    0:0    grep ---color=auto sshd

Open in new window


As to the other points:-

There is only one user on the box at the moment, presumably this is the user you are referring to? If so how do I check if it has permissions to use SSH?

The password is correct but not sure about key. I have generated a custom key for NXServer is that the one?

However if I try and connect to the box using Putty I get the error: "Network error: Software caused connection abort". Telnet fails on port 22 as well but connects to Apache on port 80 so I'm assuming that it isn't a firewall issue on my box

0
 
svgmucCommented:
Can you use ssh to that box? Any user...
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
cescentmanAuthor Commented:
Sorry wasn't specific above:-

"... connect to the box using Putty I get the error: "Network error: Software caused connection abort" ..."

I was using the SSH in Putty.
0
 
JackSperowCommented:
Hi,

I tried this tool last month i was also fadeup to configure it properly..
I used Team Viewer and VNC for GUI remote of Linux to Linux..
I would suggest you to go with VNC is the best application instead of FreeNX.
0
 
cescentmanAuthor Commented:
Thanks for the suggestion but VNC lags too much for me, I'm also interested in getting NX up and running as I want to see whether it is as productive as it seems as you can run RDP from it too.
0
 
svgmucCommented:
Okay, then it actually might be a firewall issue.
Check the packet filter, if it allows for port 22 connections from your computer.
0
 
JackSperowCommented:
In VNC also you can set password. to rpotect.
In VNC you can set your display what exectly you want.
About FreeNX i am not sure.
0
 
cescentmanAuthor Commented:
Nope not that, I turned it off just to be sure. Is there a firewall by default on Ubuntu, it's a plain vanilla install with just openssh server and NX server added to it.? If so, it might be that; any idea how you turn that off?
0
 
cescentmanAuthor Commented:
Have now managed to connect using Putty and SSH this was resolved by adding:-

sshd: ALL

Open in new window


in /etc/hosts.allow (I'll sort out a more secure entry later.

Sadly FreeNX is still not connecting giving the error:-

NX> 203 NXSSH running with pid: 5568
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 192.168.0.118 on port: 22
ssh_exchange_identification: read: Connection reset by peer

Open in new window

0
 
cescentmanAuthor Commented:
I decided to revert the server to the default keys. That seems to work. Must be something to do with the key export. Thanks for the help anyway.
0
 
cescentmanAuthor Commented:
Thanks
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

  • 7
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now