Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

portmap translation creation failed for icmp

Posted on 2011-02-17
4
Medium Priority
?
1,660 Views
Last Modified: 2012-05-11
I am getting the following error and need to fix it.

portmap translation creation failed for icmp src inside:172.16.x.x dst dmz:10.x.x.x (type 8, code 0)

My config is below

ASA Version 8.2(2)
!
hostname RDMASA01
domain-name rdmcorp.com
enable password VAGEhPNiUeohpn8K encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Ethernet0/0
 speed 100
 duplex full
 nameif outside
 security-level 0
 ip address 216.254.x.x 255.255.255.240
!
interface Ethernet0/1
 speed 100
 duplex full
 shutdown
 no nameif
 no security-level
 no ip address
!
interface Ethernet0/2
 speed 100
 duplex full
 nameif dmz
 security-level 4
 ip address 10.1.x.x 255.255.255.0
!
interface Ethernet0/3
 speed 100
 duplex full
 nameif inside
 security-level 100
 ip address 172.16.x.x 255.255.255.0
!
interface Management0/0
 shutdown
 no nameif
 no security-level
 no ip address
!
ftp mode passive
dns server-group DefaultDNS
 domain-name rdmcorp.com
access-list dmz_out_access extended permit ip any any
pager lines 24
logging enable
logging asdm informational
mtu outside 1500
mtu dmz 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any dmz
icmp permit any inside
no asdm history enable
arp timeout 14400
global (outside) 1 216.254.x.x netmask 255.255.255.255
nat (dmz) 1 0.0.0.0 0.0.0.0
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 216.254.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http x.x.x.x x.x.x.x outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
username bfrancis password
username dmoody password15
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect ip-options
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny  
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip  
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:ff5482ed90a9b1324eacdcf2cf6f6e1e
: end
no asdm history enable
0
Comment
Question by:expert608
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 34917470
I think you need a:

static (inside,dmz) 172.16.x.x 172.16.x.x netmask 255.255.255.255
0
 

Author Comment

by:expert608
ID: 34926920
So if my interface is 172.16.2.1 would i use the static below

static (inside,dmz) 172.16.2.1 172.16.2.1 netmask 255.255.255.255
0
 

Author Comment

by:expert608
ID: 34928920
the complete message is as follows

3|Feb 17 2011|15:29:25|305006|10.1.2.4||||portmap translation creation failed for icmp src inside:172.16.2.3 dst dmz:10.1.2.4 (type 8, code 0)
0
 
LVL 35

Accepted Solution

by:
Ernie Beek earned 2000 total points
ID: 34930137
Not quite. You then translate one ip address, while you want to translate the network (or more exact you don't translate) so use static (inside,dmz) 172.16.2.0 172.16.2.0 netmask 255.255.255.0

Also my wrong, gave the incorrect subnet mask :-~

0

Featured Post

Are You Ready for GDPR?

With the GDPR deadline set for May 25, 2018, many organizations are ill-prepared due to uncertainty about the criteria for compliance. According to a recent WatchGuard survey, a staggering 37% of respondents don't even know if their organization needs to comply with GDPR. Do you?

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are like regular user of computer nowadays, a good bet that your home computer is on right now, all exposed to world of Internet to be exploited by somebody you do not know and you never will. Internet security issues has been getting worse d…
Do you have a windows based Checkpoint SmartCenter for centralized Checkpoint management?  Have you ever backed up the firewall policy residing on the SmartCenter?  If you have then you know the hassles of connecting to the server, doing an upgrade_…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
Suggested Courses

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question