• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 770
  • Last Modified:

speed issues with 3560 switches

I have a series of trunked 3560 switches. When I patch into one of the switches and try to connect through it to one of my servers, the connection is slow.  For example, trying to pull down files off a share, the speed crawls.

The 3560's are not configured to route.  They trunk back to a 3550, which is configured to route back to our core.

What is interesting is that when I connect a netgear switch to one of the 3560's as an access port, anything connecting to that switch works fine.

So it seems to be some kind of trunking issue, but I can't seem to put my finger on it.

Any insight would be helpful.

0
scottman29
Asked:
scottman29
  • 3
  • 2
1 Solution
 
Ken BooneNetwork ConsultantCommented:
I would check the speed and duplex on each of the ports between the switches.  You didn't say how they were connected.  Fiber or cat5/6?  If fiber then you are most likely using a gbic on the 3550 and an sfp on the 3560.  So check those ports for CRC errors to see if the #1) sfp, #2) gbic, or #3 the fiber patch cable is bad.  

If you are connecting via cat5/6 assuming you are trying to make the connection at the speed of 100.  Then you need to check the speed/duplex.  Many times the auto-negotiate thing doesn't work so well and you end up with one of the switches running at 100/half.  This would definitely cause the problem you see.  I like to hard code the speed and duplex when running at 100 between switches.   Set it to 100/full.  Now if you are running on gigabit ethernet ports you should not have this problem.

Hope that helps.
0
 
scottman29Author Commented:
Thanks, I will try hardcoding the speeds.  It's is cat 5/6 between the switches using copper sfps at the 3560 and regular copper ports on the 12G 3550... I'll let you know how it goes.
0
 
scottman29Author Commented:
Ken,

This was it.  On the 3560, the ports were 1/2 duplex, and on the 3550, they were full.  On the 3560, I set the mdix auto, and then on the 3550 I hardcoded the speed to 100 and the duplex to 1/2.  Do you know why this happens?  If I had a 3560 to 3560 trunk would the auto negotiate work properly?  Or does it typically not work in general?
0
 
Ken BooneNetwork ConsultantCommented:
Glad you found the problem.  With autonegotiation turned on here is how it works.  

If both ports are set to auto it will try to autonegotiate.  On some older switches this doesn't always work so well.  Even cisco to cisco.  blows your mind.  Any way if one port is hard-coded and the other is auto OR if it can't figure out how to auto set the duplex the default settings get used which are 100/half.  

So typically what you need to do is run auto on both sides.  If auto is not giving the right settings on both sides, then you want to hard code both sides.  You want to hard code them to 100 Full though.  You won't get the collisions with full duplex like you get with half.  Do this to both sides and you should be good to go.
0
 
scottman29Author Commented:
I think part of the problem was that the 3560 is an older 3560 and is 1/2 duplex. Go figure it's working now. Thanks for your help!
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now