Forwarding HTTP traffic to our public IP internally for exchange/wireless phones?

Basically what happened was about a month ago our Sonicwall router died and I had  a new one shipped over night. I got the new one up and running in a couple hours and I was pretty proud of myself. One issue remains though. When users with iphones are on the lan through the wireless they can't use the internet. The reason being is in their email settings they are using our public IP address. I can tell this isn't going to work because I will get on a workstation and type in our public ip address in the browser using: Https://65.40.X.X and I go no where. I'm pretty sure that https is the port that would need to be forward to get this to work. This was my guess on how it should work that doesn't seem t work:

Original Source: LAN SUBNETS
Translated Source: ORIGINAL
Original Destination: Server's public IP Address
Translated Destination: Server's internal IP Address
Original Service: HTTPS
Translated Service: Original

sagetechitAsked:
Who is Participating?
 
digitapConnect With a Mentor Commented:
it could be one of two things or both.  first thing i'd check is if you've enabled the management on the WAN interface.  if you have, then you might consider changing the https port to something other than 443.  go to system > administration to do that.

second, you might check to confirm you have a loopback configured.  if you ran the public server wizard, it would have created one for you.  putting the public IP for mail would then work.  the loopback says internal requests bound for the public IP of the WAN interface internal.  otherwise, it drops that traffic.

so, your iphone users can't get email or they can't get to the internet?
0
 
sagetechitAuthor Commented:
When they are on the wan, and they get on the wifi, there email no longer works. They can surf the web just fine.

You might be on to something with the interface management, I'll check it out.

I went through the wizards to set most of this up so I think my loopback is created...
0
 
sagetechitAuthor Commented:
It appears I only have SSH and Ping enabled under management
 snapshot of interface
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
sagetechitAuthor Commented:
The LAN address has http and https selected, would that screw it up?
0
 
digitapCommented:
no, just the WAN since the management and the email may be using the same public IP address.  the LAN IP would be different from your exchange server.

you said, "When they are on the wan, and they get on the wifi, there email no longer works."  when you say WAN, i think the WAN zone on the sonicwall and when you say wifi, i think WLAN zone on the sonicwall.  can you clarify that sentence from those perspectives?
0
 
sagetechitAuthor Commented:
http://www.experts-exchange.com/Hardware/Networking_Hardware/Firewalls/Q_23347507.html

this is what i used to fix my issue, but I didn't know about the loopback until I read his comment
0
 
digitapCommented:
so, you must have had some NAT policies created manually.  glad you found it and thanks for the points!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.